07:13:44 <joehuang> #startmeeting multisite
07:13:44 <collabot`> Meeting started Thu May 12 07:13:44 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:13:44 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:13:44 <collabot`> The meeting name has been set to 'multisite'
07:13:58 <SAshish> #info Ashish
07:14:04 <joehuang> do you think that Sebastien will attend or not
07:14:10 <joehuang> #info joehuang
07:14:32 <SAshish> Guys, its 9 am cet
07:14:35 <SAshish> right?
07:14:40 <joehuang> I think so
07:14:45 <sorantis> yes
07:14:52 <sorantis> #info dimitri
07:15:05 <sorantis> I don’t think he will
07:15:18 <joehuang> Hi, Ashish, we are talking about the design summit in Berlin
07:15:29 <SAshish> okay
07:15:36 <SAshish> nice
07:15:58 <SAshish> so, we have to book a room there? decide Agenda?
07:16:23 <joehuang> And also to retrospect other use cases, to see if  there is some other gaps in OpenStack
07:16:43 <joehuang> I asked in the M-L, but Raymond not answered yet
07:16:47 <joehuang> not sure
07:18:21 <joehuang> so, Dimitri please register some sessions in the design summit. If you and Ashish have other ideas, also submit please
07:18:30 <sorantis> ok
07:18:42 <SAshish> okay
07:19:00 <joehuang> #action register some sessions in the design summit in Berlin
07:19:34 <joehuang> ok, let's come back to today's agenda
07:20:21 <joehuang> #topic  multisite deployment with centralized Keystone
07:20:47 <SAshish> Dimtri has done this I guess
07:20:50 <joehuang> Hi, Ashish, are you able to access the lab
07:20:52 <sorantis> Ashish will get access to the lab and install kb there
07:21:04 <sorantis> the m-r setup is in place
07:21:09 <sorantis> no fernet though
07:21:12 <joehuang> But I am not able to access the lab
07:21:23 <SAshish> I had to reopen ticket
07:21:24 <joehuang> I suggest we skip Fernet token
07:21:48 <joehuang> Fernet token is mainly to verify the use case one
07:21:55 <sorantis> we’ll see, i’ve no idea how to configure keystone, but perhaps it’s easy
07:22:00 <SAshish> which usecase?
07:22:12 <sorantis> UC1
07:22:15 <joehuang> but KB is able to run even without using Fernet token
07:22:24 <SAshish> Multisite identity service management?
07:22:29 <sorantis> yes
07:22:34 <SAshish> okay
07:22:40 <joehuang> It's not difficult, only need to do configuration
07:23:02 <joehuang> but the major concerns from mine is the automation for functest purpose
07:23:33 <SAshish> also, the automated deployment of kb with fuel
07:23:38 <joehuang> Do we need to dynamicly install a new multisite environment when functest for KB is triggered
07:24:07 <joehuang> to Ashish, +1
07:25:26 <joehuang> For other projects, usually will have a dynamically created SUT in functest (SUT, system under test)
07:25:51 <SAshish> or can we configure m-r environment upfront which can be pointed out by functest when running KB
07:26:35 <joehuang> You mean we have a static m-r envrionement, and just deploy KB when needed, and execute the test
07:27:15 <SAshish> something like that, I did not know how it happens in other projects
07:27:25 <SAshish> as you are saying there is SUT
07:27:34 <SAshish> then may be we need to follow that
07:28:45 <joehuang> to Dimitri, currently two region shared with same Keystone, and PKI or UUID token used?
07:29:06 <sorantis> UUID i think
07:29:11 <sorantis> need to check
07:29:27 <joehuang> It woks for test
07:30:17 <joehuang> to Dimitri, do you agree to skip the Fernet token configuration currently?
07:30:40 <sorantis> I’d first check if it’s easy to confiug
07:30:48 <sorantis> configure Fernet
07:30:50 <joehuang> ok
07:31:00 <sorantis> if so, then I don’t see why we should skip it
07:31:13 <SAshish> yes, if it is done then we can verify both
07:31:17 <SAshish> UC1 and KB
07:32:10 <joehuang> I found that at least 3 projects in Colorodo need mutlisite environments: Domino, IPv6 and Multisite
07:32:31 <joehuang> But each project using different installer
07:32:54 <joehuang> IPv6 Apex, Multisite now for KB is Fuel
07:33:21 <joehuang> Don't know which installer Domino wants to support
07:33:30 <sorantis> what’s domino?
07:33:41 <joehuang> Another project
07:34:07 <joehuang> https://wiki.opnfv.org/display/PROJ/Project+Proposals+Domino
07:34:28 <joehuang> https://wiki.opnfv.org/display/domino/Domino+Home
07:35:22 <joehuang> If each project need to support 4 installer ( Fuel, Apex, Compass4NFV, ), it's crazy
07:35:56 <sorantis> that’s not multisite’s concern
07:37:18 <joehuang> I think each installer should support multisite installation automation by themself, it's basic capability for other feature projects
07:37:57 <sorantis> +1 however none supports m-r yet
07:38:42 <sorantis> Fuel at least has the option to create multiple environments
07:38:59 <joehuang> that's the issue, gensis project is to set standard for installers to follow
07:39:04 <sorantis> which effectively could be used for m-r setup
07:39:08 <SAshish> yeah. the ISO installer
07:39:33 <joehuang> but how to connect the multisite envrioment with Functest
07:40:03 <sorantis> just point the test to a fixed keystone endpoint
07:40:09 <sorantis> tests*
07:40:25 <sorantis> assume there’s an existing deployment and use it
07:40:27 <joehuang> just mentioned that for single site functest, the OpenStack(and other components) as SUT are created dynamicly before the test
07:40:27 <SAshish> functest should have configurations
07:40:50 <sorantis> well, we could do the same, but different :)
07:41:15 <SAshish> we will considered a static m-r as SUT
07:41:42 <sorantis> creating 2 SUT dynamically shoudn’t be a problem. Centralizing keystone on the other hand can be hard
07:41:50 <joehuang> so, could Ashish help to check whether we can use pre-configured M-R enviroment as the SUT, just install KB / tempest for KB on demand
07:42:47 <sorantis> ashish will do the KB part. I thought you joe would look into functest and preconfigured m-r
07:42:52 <joehuang> to Dimitri, yes, "Centralizing keystone on the other hand can be hard"
07:43:09 <SAshish> am not sure with that
07:43:11 <joehuang> ok
07:43:19 <joehuang> I'll check that
07:43:26 <SAshish> I am still trying to understand the ecosystem
07:43:57 <joehuang> to Ashish, I
07:44:01 <joehuang> sorry
07:44:03 <SAshish> what works with whom,
07:44:08 <SAshish> :)
07:44:23 <joehuang> to Ashish, I will sent you the link of the material of Functest first
07:44:51 <joehuang> sent -> send
07:44:52 <SAshish> okay
07:45:23 <joehuang> #action look into functest to see if pre-configured m-r is possible
07:45:32 <sorantis> sorry I have to leave now
07:45:49 <joehuang> ok, we can conclude the meeting today
07:46:02 <SAshish> fine
07:46:24 <joehuang> thank you for attending the meeting
07:46:32 <joehuang> #endmeeting