#opnfv-meeting: Testing group weekly meeting May, 19th

Meeting started by morgan_orange at 14:00:47 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 14:01:39)
    1. morgan Richomme (morgan_orange, 14:01:42)
    2. Maryam Tahhan (mtahhan_, 14:01:55)
    3. Jose Lausuch (jose_lausuch, 14:01:57)
    4. Billy O'Mahony (billyo, 14:02:02)
    5. Larry Lamers (ljlamers, 14:02:14)

  2. agenda bashing (mtahhan_, 14:02:52)
    1. actions follow up (mtahhan_, 14:03:25)
    2. testing page updates (mtahhan_, 14:03:35)
    3. scenario vs tests discussion (mtahhan_, 14:03:48)
    4. infra discussion (mtahhan_, 14:03:58)

  3. testing page updates (mtahhan_, 14:04:12)
    1. testing page updated to reflect how the various testing projects interact (mtahhan_, 14:05:28)
    2. https://wiki.opnfv.org/display/functest/testing (mtahhan_, 14:05:45)
    3. testcase definitions can be found @ http://testresults.opnfv.org/testapi/test_projects/functest/cases (mtahhan_, 14:07:55)
    4. test criteria https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria (mtahhan_, 14:08:30)
    5. Test coverage spans a number of domains (mtahhan_, 14:09:25)
    6. https://wiki.opnfv.org/display/functest/Testing+Coverage (mtahhan_, 14:09:29)
    7. ACTION: test projects to consider test coverage for OPNFV (mtahhan_, 14:09:55)
    8. test coverage will be covered in detail next week (mtahhan_, 14:10:30)
    9. 2 dashboards planned for Colorado (mtahhan_, 14:11:02)
    10. Grafana and ELK (mtahhan_, 14:11:24)
    11. if you are graphing test status, it will be recommended to use the first option. If you need to graph results = f(time) for longer duration test and visualize bandwidth, lattency, ..evolution, it will be recommended to use InfluxDB/grafana (mtahhan_, 14:11:52)
    12. Brahmaputra test page is now deprecated (mtahhan_, 14:12:13)
    13. https://wiki.opnfv.org/display/functest/Collection+Of+Test+Results (jose_lausuch, 14:21:54)

  4. Test Scenario Vs Tests (mtahhan_, 14:24:08)
    1. Mark Beierl (mbeierl, 14:32:51)
    2. https://www.youtube.com/watch?v=nfCRi8mY2MM&list=WL&index=14 (mtahhan_, 14:34:51)
    3. functest videos https://wiki.opnfv.org/display/functest/videos (mtahhan_, 14:36:40)
    4. https://wiki.opnfv.org/display/functest/videos for the collection of videos for Functest (mbeierl, 14:36:42)
    5. https://git.opnfv.org/cgit/functest/tree/ci/testcases.yaml <- file that controls what tests are run (mbeierl, 14:44:18)
    6. ACTION: morgan_orange initiate table scenario / tests (inspired by Frank's page) in test Criteria page (morgan_orange, 14:53:32)

  5. sync with Infra group (morgan_orange, 14:55:44)
    1. jose_lausuch is also in charge of a pilot to book PODs in infra group (morgan_orange, 14:56:02)
    2. http://52.11.159.93/opnfv-ci-dashboard/index.php (morgan_orange, 14:56:22)
    3. proposal => so any comments are welcome... (morgan_orange, 14:56:46)
    4. https://wiki.opnfv.org/display/DEV/Intern-projects-page, Project 5 (mbeierl, 14:58:09)
    5. https://wiki.opnfv.org/display/DEV/Intern-projects-page (jmorgan1, 14:58:54)


Meeting ended at 15:01:24 UTC (full logs).

Action items

  1. test projects to consider test coverage for OPNFV
  2. morgan_orange initiate table scenario / tests (inspired by Frank's page) in test Criteria page


Action items, by person

  1. morgan_orange
    1. morgan_orange initiate table scenario / tests (inspired by Frank's page) in test Criteria page


People present (lines said)

  1. mtahhan_ (25)
  2. mbeierl (12)
  3. morgan_orange (11)
  4. collabot` (6)
  5. jose_lausuch (6)
  6. jmorgan1 (5)
  7. ljlamers (1)
  8. billyo (1)
  9. MatthewLi (0)


Generated by MeetBot 0.1.4.