07:07:18 <joehuang> #startmeeting multisite
07:07:18 <collabot`> Meeting started Thu May 26 07:07:18 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:07:18 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:07:18 <collabot`> The meeting name has been set to 'multisite'
07:07:32 <joehuang> #topic rollcall
07:07:44 <joehuang> #info joehuang
07:07:53 <SAshish> #info Ashish
07:08:05 <SAshish> update on temepst refactoring
07:08:11 <joehuang> please
07:08:12 <SAshish> will wait for DImitri
07:08:19 <SAshish> for sometime
07:08:27 <joehuang> we can wait a moment for him
07:09:05 <margaret> #info margaret
07:09:05 <joehuang> and Meimei is preparing the development environment for integration
07:09:23 <joehuang> so she will not attend today's meeting
07:09:30 <SAshish> okay
07:10:23 <SAshish> Joe. I was trying configuring openvpn on my machine
07:10:27 <SAshish> I use a windows machine
07:10:45 <joehuang> does it work?
07:10:47 <SAshish> and have followed the steps given at
07:10:48 <SAshish> https://wiki.opnfv.org/display/pharos/Intel+Labs+VPN+Quickstart
07:11:37 <SAshish> I am able to connect openvpn but not able to ping the ips given in that link
07:11:40 <SAshish> To confirm you have a VPN connection, ping 10.2.84.250, you should get a reply. This is the IP of the VPN server.
07:11:44 <SAshish> this step I am not able to do
07:12:03 <SAshish> I am behind my company proxy
07:12:04 <joehuang> VPN server is not ping-able
07:12:26 <SAshish> Hi Dimitri
07:12:31 <joehuang> hello, Dimitri
07:13:06 <joehuang> Hi, Margaret is also attending the meeting today
07:13:23 <joehuang> so let's welcome Margaret to join the meeting :)
07:13:23 <SAshish> Hi Margaret
07:13:35 <SAshish> you are welcome
07:14:07 <sorantis> hi
07:14:13 <joehuang> hi
07:14:22 <margaret> hi
07:14:32 <joehuang> #topic tempest refactoring update
07:14:38 <SAshish> Dimitri I was explaning Joe about the issue which I am facing in connecting to lab
07:15:04 <SAshish> okay. let us have tempest first.
07:15:31 <joehuang> I also reported to the VPN connection problem and log to Jack, but no reply yet
07:15:41 <SAshish> what problem you are facing?
07:15:48 <joehuang> please, Ashish
07:16:00 <joehuang> handshake problem with VPN server
07:16:04 <SAshish> I have connected to vpn but not able to ping  VPN server
07:16:08 <joehuang> can't establish connection
07:16:29 <sorantis> ok
07:16:31 <SAshish> okay. I have a doubt. we are connecting through outisde one right
07:16:32 <sorantis> so you did connect
07:17:08 <SAshish> same problem with me. not able to ping VPN server( 10.2.84.250,)
07:17:17 <SAshish> but I have connected successfully
07:17:38 <SAshish> the doubt is: I am behind me company corporate proxy
07:17:42 <SAshish> will I be able to connect?
07:17:49 <SAshish> OR I have to bypass proxy?
07:18:09 <joehuang> no, even Meimei had same issue
07:18:30 <joehuang> no proxy on my environment
07:18:52 <SAshish> @Dimitri, you are able to connect right.
07:18:52 <collabot`> SAshish: Error: "Dimitri," is not a valid command.
07:18:56 <joehuang> So I suggest report it to Jack or attach the log to your ticket
07:19:11 <SAshish> are you behind proxy?
07:19:29 <joehuang> no, not behind proxy, but nat
07:20:00 <SAshish> so do I have to by pass proxy?
07:20:00 <sorantis> so I’ve just managed to connect
07:20:37 <sorantis> then ssh jenkins@10.2.117.70
07:20:55 <sorantis> after that I’m on a jump server
07:21:13 <sorantis> from there I can connect to fuel/controllers/etc
07:21:20 <sorantis> Ashish, can you try now?
07:21:50 <SAshish> yes, tried it in morning and trying right now as well
07:22:07 <SAshish> state: connected
07:22:16 <SAshish> but not able to ping vpn server
07:22:31 <SAshish> Dimitr, are you behind pxory??
07:23:38 <joehuang> could you ping 10.2.117.70 directly
07:23:47 <sorantis> I can’t ping the server either
07:23:50 <joehuang> and check whether there are virtual tap/tun established in your local machine
07:23:50 <sorantis> why do you want that?
07:23:58 <SAshish> just a sec
07:24:02 <SAshish> I am able to ping 10.2.117.70
07:24:13 <joehuang> if you can ping 10.2.117.70
07:24:21 <sorantis> I can
07:24:32 <joehuang> you can directly ssh jekins@10.2.117.70
07:24:33 <sorantis> so just ssh to the jumphost
07:24:44 <sorantis> and then you just switch to fuel
07:24:47 <sorantis> try that
07:24:53 <joehuang> ok. Ahsish, you have connected to the environment
07:25:12 <joehuang> can we back to the topic now?
07:26:00 <SAshish> yes. just a sec.
07:26:19 <SAshish> Dimitri password for jenkins@10.2.117.70
07:26:20 <SAshish> ?
07:27:00 <joehuang> send you in mail, the meeting log is visible to anyone
07:27:15 <SAshish> okay. fine.
07:27:19 <SAshish> back to the topic
07:27:26 <sorantis> I’ll send you in private
07:30:22 <SAshish> so, last time I have referred mistral tempest. As we know it is not autodiscoverable by tempest. There is no proper documentation for tempest in mistral and there mistral tempest plugin is not auto discoverable. I have followed the plugin link and sahara and tried. Now KB tempest is autodiscoverable and can be run with tempest.
07:30:47 <joehuang> perfect
07:31:07 <SAshish> So, now we need not copy kingbird tempest into tempest repo, we just install kingbird and the kingbird repo has tempest plugin so this plugin is also installed
07:31:12 <SAshish> with kingbird installation
07:31:38 <joehuang> #info kingbird tempest plugin can be discovered by tempest
07:31:40 <SAshish> now, when we run tempest, it discovers all the plugins and tries to run kb FTs we all
07:31:59 <SAshish> without putting the kb testcases into tempest repo
07:32:08 <joehuang> great. just copy kingbird may not work
07:32:25 <joehuang> need to install, or use sudo pip install -e .
07:32:35 <joehuang> in kingbird root folder
07:32:35 <SAshish> the machine on which we are running tempest needs to have kb installed
07:32:47 <joehuang> yes
07:32:58 <SAshish> kb installation will internally have tempest plugin installed
07:33:24 <SAshish> so, tempest FTs now will be under kingbird/tests/tempest
07:34:02 <SAshish> now in <kbroot>/tempest. I still have to do good amount of refactoring with new structure
07:34:06 <joehuang> the folder name kingbird/tests/tempest may lead to a little issue in import
07:34:25 <SAshish> yes, it has happend. thats why it is taking time
07:34:36 <joehuang> because the folder name is same as tempest
07:34:53 <SAshish> I am working on that
07:34:57 <joehuang> I recommend you to rename kingbird/tests/tempest to a new name
07:34:59 <SAshish> resolving it
07:35:16 <joehuang> same idea, :)
07:35:21 <margaret> #help is there a doc which describes the KB tests being run?
07:35:35 <SAshish> yes, because for few operations we directly tempest
07:35:45 <SAshish> and for few we use kingbird.tests.tempest
07:36:03 <joehuang> currently no doc yet
07:36:12 <SAshish> I will prepare readme.rst
07:36:15 <SAshish> you can follow that
07:36:25 <joehuang> thanks to Ashish
07:36:26 <SAshish> I will udpate rather as per new structure
07:36:31 <SAshish> welcome
07:36:44 <joehuang> #action  doc which describes the KB tests being run
07:36:46 <SAshish> there is already a readme.rst which needs update
07:37:02 <joehuang> we have readme in each folder
07:37:20 <SAshish> there is still one issue with configurations for kingbird tempest
07:37:23 <joehuang> configuration guide and user guide will be provided later
07:37:35 <SAshish> config for kingbird tempest
07:37:37 <margaret> thanks
07:37:48 <SAshish> there is config.py for plugin as well.
07:37:49 <joehuang> which configuration
07:37:59 <SAshish> then tempest has its own config.py
07:38:10 <SAshish> both are loaded by tempest when we run it
07:38:24 <SAshish> so that we can use those variables directly inside our testcases
07:38:41 <SAshish> tempest configurations can be set with etc/tempest.conf
07:39:01 <joehuang> you need to run tox -egenconfig then tempest will discover and generate these configuration together
07:39:09 <SAshish> yes, that is for temepst.conf
07:39:22 <joehuang> run tox -egenconfig under tempest root folder
07:39:24 <SAshish> I am talking about configuration which is specific to kingbird plugin
07:39:45 <SAshish> https://github.com/openstack/sahara/blob/master/sahara/tests/tempest/scenario/data_processing/config.py
07:39:53 <SAshish> something like this
07:40:18 <sorantis> which basically overwrites kb config values
07:40:44 <SAshish> there will not be overlapped configurations
07:40:55 <sorantis> it’s not necessary if we’re ok with the default values i guess
07:41:14 <SAshish> yes, I could move forward with default values
07:41:19 <joehuang> of course, if you have default value, then no configuraiton file items needed
07:41:20 <sorantis> but could be good to tweak the timeout values
07:41:30 <joehuang> you can refer to https://github.com/openstack/cinder/blob/master/cinder/tests/tempest/config.py
07:41:48 <joehuang> Cinder also provides its own configuration
07:42:11 <SAshish> this is for overwriting
07:42:18 <SAshish> existing one
07:42:27 <joehuang> but with default value provided
07:42:43 <SAshish> if there are new values which are not in tempest.conf
07:42:57 <joehuang> will try after the meeting
07:43:15 <SAshish> sure. I could move forward with default values though
07:43:37 <sorantis> keep the config.py
07:43:44 <SAshish> yes it is there
07:43:45 <sorantis> it can be good for the future customization
07:43:54 <joehuang> Sure
07:43:56 <SAshish> I will keep,
07:43:59 <SAshish> and using it also
07:44:02 <SAshish> with defalut
07:44:05 <SAshish> in config.py
07:44:22 <SAshish> what I am not getting is how to set those during running
07:44:26 <SAshish> like we set in tempest.conf
07:44:33 <SAshish> we change default values
07:44:58 <SAshish> simillary how to change default conf for kingbird/tests/tempest/config.py
07:45:04 <joehuang> it should be able to modify the config value
07:45:29 <SAshish> https://github.com/openstack/sahara/blob/master/sahara/tests/tempest/scenario/data_processing/etc/sahara_tests.conf
07:45:32 <SAshish> I tried this even
07:45:46 <joehuang> Can you find these configuration item in generated configuration sample file?
07:46:13 <SAshish> no, somehow this etc directory itself is not generated when I install KB
07:46:20 <joehuang> after run tox -egenconfig in tempest root folder after tempest discovery kingbird tempest plugin
07:46:35 <SAshish> yes. I have done that.
07:47:12 <joehuang> Then cd into the newly created working dir and also modify the local config files located in the etc/ subdir created by the tempest init command. Tempest is expecting a tempest.conf file in etc/ so if only a sample exists you must rename or copy it to tempest.conf before making any changes to it otherwise Tempest will not know how to load it.
07:47:35 <joehuang> #link http://docs.openstack.org/developer/tempest/overview.html
07:48:01 <SAshish> yes Joe, problem is not with tempest.conf
07:48:20 <SAshish> tempest.conf is file
07:48:29 <joehuang> ok. I'll also try after the meeting
07:48:41 <SAshish> am talking about config for just the plugin
07:48:44 <SAshish> now tempest
07:49:42 <joehuang> ok, let's try to solve this issue after the meeting
07:49:57 <SAshish> right now I am moving ahead with default values inside kingbird/tests/tempest/scenario/quota_management/config.py
07:50:14 <SAshish> which is loaded by tempest
07:50:52 <joehuang> looking forward to your new patch
07:51:06 <SAshish> import issues I am checking, needs some restrucing and fixing few issues with current implementation
07:51:08 <SAshish> yes sure.
07:51:34 <joehuang> good job
07:52:05 <SAshish> once, it is in place. will add cinder, neutron and quota classes FTs
07:52:14 <SAshish> as a separate commit
07:52:20 <joehuang> understand
07:52:37 <SAshish> thanks for good job :)
07:53:05 <SAshish> so how is it going with integration work?
07:53:06 <joehuang> And Meimei is preparing environment to do the integration with Functest
07:53:17 <joehuang> will do it after your patch merged
07:53:45 <SAshish> and how is the environment look like?
07:54:22 <joehuang> a slides sent in the mail-list, you can review and comment
07:54:42 <SAshish> sure
07:54:55 <sorantis> preparing environment where?
07:55:17 <SAshish> is it local?
07:55:18 <SAshish> right now
07:55:20 <joehuang> #link https://docs.google.com/presentation/d/12Svp-mv9ROHDxE7ifrrBGEm1IBM6DPzniISX2OiXBWc/edit
07:55:26 <joehuang> in Shanghai lab for develoment
07:55:49 <sorantis> well I dond’t have the edit rights
07:55:57 <sorantis> but I would rather install kingbird in a docker container
07:56:12 <sorantis> this way installation can be automated from CI
07:56:12 <joehuang> it's in Functest container
07:56:35 <sorantis> According to slide 3 it’s on one of the openstacks
07:56:43 <joehuang> becaure tempest need to discover the plugin of kingbird
07:57:05 <joehuang> you want to deploy in a seperate container?
07:57:12 <joehuang> it's also ok
07:57:31 <joehuang> your gmail-address to edit the doc
07:57:45 <sorantis> I’ll send in private
07:58:01 <sorantis> I think a separate container is better
07:58:02 <joehuang> ok
07:58:12 <sorantis> this way we can also have kingbird contenerized
07:58:14 <joehuang> it works
07:58:18 <sorantis> containerized
07:58:31 <joehuang> but kingbird need to be able to talk to keystone
07:58:35 <sorantis> sent request
07:58:45 <sorantis> yes
07:59:16 <sorantis> and I believe Keystone publicURL should be accessible from outside
07:59:21 <joehuang> good, and idea about the design summit, please
07:59:28 <sorantis> ?
08:00:17 <joehuang> we have some break out session in design summit, so think about what to be done next, features, etc...
08:00:33 <margaret> #topic OPNFV multi-site relationship with high availability project - should there be?
08:01:08 <joehuang> I am not sure whether there is a such topic
08:01:14 <sorantis> +1
08:01:41 <sorantis> Multisite breakout session is about the multisite roadmap itself
08:01:52 <joehuang> to Sorantis +1
08:01:53 <sorantis> colaboration with other projects can be a separate session
08:02:00 <joehuang> yes
08:02:12 <joehuang> contact HA team after the meeting
08:02:21 <sorantis> time’s up
08:02:26 <sorantis> gotta run to another meeting :)
08:02:35 <joehuang> yes, let's end today's meeting
08:02:38 <margaret> I won't be at Berlin - but I do think it makes sense to tie the 2 together.
08:02:39 <sorantis> thanks for the updates
08:02:41 <margaret> ok by
08:02:41 <joehuang> thanks for your attending
08:02:42 <margaret> bye
08:02:48 <joehuang> yes
08:02:51 <SAshish> bye
08:02:52 <joehuang> bye
08:02:59 <joehuang> #endmeeting