#opnfv-meeting: Test subgroup weekly meeting June 2nd

Meeting started by morgan_orange at 14:00:51 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 14:00:57)
    1. Mark Beierl (StorPerf) (mbeierl, 14:01:06)
    2. kubi (kubi, 14:01:07)
    3. Jose Lausuch (jose_lausuch, 14:01:14)
    4. Morgan (morgan_orange, 14:03:04)
    5. Maryam Tahhan (mtahhan, 14:03:10)

  2. Action point follow up (morgan_orange, 14:05:25)
    1. nothing this week (morgan_orange, 14:05:30)

  3. Colorado Status (morgan_orange, 14:05:35)
    1. vsperf started integration with yardstick, moongen integration is well underway and outstanding item for C release is the update to use the new results API (mtahhan, 14:07:30)
    2. storperf relatively quiet (part time job, really??), new Cengn contributor joined, discussion with Yardstick (initiated during the plugfest) (morgan_orange, 14:07:42)
    3. ACTION: morgan_orange presentation of refactored test API next week, Senera will be in Berlin for the Summit (morgan_orange, 14:11:06)
    4. Functest stable (first blue balls in CI) (morgan_orange, 14:11:46)
    5. Trevor Cooper (trevor_intel_, 14:11:51)
    6. first Apex results collected this week (morgan_orange, 14:12:03)
    7. new testcases about security scanning (jose_lausuch, 14:12:56)
    8. http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html (jose_lausuch, 14:13:38)
    9. yardstick new plugin made available for sub projects: vsperf, storperf, etc. (mbeierl, 14:15:27)
    10. meeting yardstick / ha (morgan_orange, 14:15:38)
    11. https://gerrit.opnfv.org/gerrit/#/c/15087/2 (mbeierl, 14:22:23)
    12. Gerrit review for the Presentation ^ (mbeierl, 14:22:48)
    13. https://gerrit.opnfv.org/gerrit/#/c/15087 (mbeierl, 14:23:32)
    14. In Brahmaputra feature projects had 2 choices to place tests cases, functest and yardstick (jose_lausuch, 14:29:43)
    15. the allocation was decided according to the idea of sharing the load between them, without thinking much the nature of the test case (functional, performance,.... ) (jose_lausuch, 14:30:22)
    16. Morgan suggests to rethink the way we use the umbrella projects for testing (jose_lausuch, 14:31:09)
    17. ebrjohn, Brady Johnson SFC PTL (ebrjohn, 14:32:06)
    18. when selecting a test project, there are some steps to follow like declaring the test in the DB, provide a success criteria of the test cases, create JIRA for integration and work together with the test project members and collaborate with documentation (jose_lausuch, 14:33:53)
    19. Morgan proposes a if-else diagram about the nature of the test cases to make clear where to place the tests (jose_lausuch, 14:35:24)
    20. question: where to find information about the different testing frameworks in OPNFV --> also needed when deciding where to place the tests (jose_lausuch, 14:36:46)
    21. VOTE: Voted on "Shall the test projects adopt the layout of Yardstick/Functest as described by morgan_orange?" Results are, +1: 9 (dfarrell07, 14:52:58)
    22. ACTION: PTL => provide input on test slicing (morgan_orange, 14:58:49)

  4. AoB (morgan_orange, 15:00:03)
    1. ACTION: morgan_orange create wiki page to reflect discussion on test tiering (morgan_orange, 15:00:24)


Meeting ended at 15:01:13 UTC (full logs).

Action items

  1. morgan_orange presentation of refactored test API next week, Senera will be in Berlin for the Summit
  2. PTL => provide input on test slicing
  3. morgan_orange create wiki page to reflect discussion on test tiering


Action items, by person

  1. morgan_orange
    1. morgan_orange presentation of refactored test API next week, Senera will be in Berlin for the Summit
    2. morgan_orange create wiki page to reflect discussion on test tiering


People present (lines said)

  1. morgan_orange (22)
  2. mbeierl (18)
  3. jose_lausuch (16)
  4. kubi002 (11)
  5. ebrjohn (10)
  6. collabot` (10)
  7. dfarrell07 (6)
  8. mtahhan (4)
  9. trevor_intel_ (2)
  10. timirnich (1)
  11. kubi (1)
  12. MatthewLi (0)


Generated by MeetBot 0.1.4.