07:01:53 <joehuang> #startmeeting multisite
07:01:53 <collabot> Meeting started Thu Aug 11 07:01:53 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:53 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:01:53 <collabot> The meeting name has been set to 'multisite'
07:01:57 <SAshish> Same here :)
07:02:02 <joehuang> hi meimei
07:02:59 <joehuang> Hi, Ashish, how about the functest ci job now
07:03:02 <May-meimei> have you saw that patch: https://gerrit.opnfv.org/gerrit/#/c/18379/
07:03:19 <SAshish> yes, its working now
07:03:31 <joehuang> yes
07:03:48 <SAshish> there were 5 failures, have committed a patch for fixing 2 of them
07:03:56 <joehuang> so the job can be triggered, and most of test cases can pass the test
07:04:02 <May-meimei> https://build.opnfv.org/ci/view/functest/job/functest-fuel-virtual-suite-master/lastFailedBuild/console
07:04:19 <SAshish> also, one more thing
07:04:30 <SAshish> let us wait for Dimitri for 5 mins
07:04:44 <joehuang> ok
07:07:54 <sorantis> hi
07:07:59 <SAshish> Hi Dimitri
07:08:36 <SAshish> so we were discussing about the functest job run
07:09:14 <joehuang> hi
07:10:47 <sorantis> yes, it’s failing :)
07:11:01 <SAshish> yeah. 5 are failing
07:11:15 <SAshish> have committed the patch for fixing two of them
07:11:28 <SAshish> and remaning 3 are due to token expiration
07:11:44 <SAshish> I think If we have a complete build now
07:11:50 <SAshish> then it will pass all
07:12:03 <SAshish> Meimei can you trigger the complete job once?
07:12:05 <sorantis> that can be fixed by changing the expiration time in keystone.conf
07:12:17 <sorantis> i can trigger
07:12:40 <joehuang> the token is valid for 1 hour by default, I remember
07:12:59 <SAshish> yes, but we need to handle in KB as well
07:13:08 <sorantis> yes, which can be an issue if the tests run for more
07:13:22 <SAshish> we already have a bug raised long back for this
07:13:32 <sorantis> don’t we update kb’s cache if authentication fails?
07:13:47 <SAshish> fine, Dimitri please trigger a job
07:14:00 <joehuang> need to do cache update if auth failed
07:14:17 <sorantis> it’s running
07:14:18 <SAshish> that is not done in endpoint caching I suppose
07:14:22 <SAshish> okay
07:14:55 <joehuang> according to release manager's plan
07:15:36 <joehuang> complete documentation by Monday, August 15.
07:16:10 <joehuang> so the documentation patch https://gerrit.opnfv.org/gerrit/#/c/17895/ needs to be merged ASAP
07:16:28 <joehuang> and then 1 week window for stable branch creation
07:17:38 <sorantis> I’ll review the patch today
07:17:44 <joehuang> Meimei's patch for refactoring also need to be merged soon
07:18:03 <joehuang> #link https://gerrit.opnfv.org/gerrit/#/c/18379/
07:18:12 <SAshish> Meimei: rebase it
07:18:18 <joehuang> #link https://gerrit.opnfv.org/gerrit/#/c/17687/
07:18:28 <joehuang> yes, rebase is needed, Meimei
07:21:49 <joehuang> #info documentation should be complemented next Monday, Aug.15
07:22:18 <joehuang> #info 1 week window for stable branch creation for Colorado release, by Aug.22.
07:23:12 <SAshish> what is healthcheck
07:23:17 <SAshish> 2016-08-11 08:21:26,081 - openstack_clean - INFO - Cleaning OpenStack resources...
07:23:21 <SAshish> 2016-08-11 08:21:49,769 - run_tests - INFO - Test execution time: 02:31
07:23:24 <SAshish> 2016-08-11 08:21:49,769 - run_tests - ERROR - The test case 'healthcheck' failed.
07:24:53 <sorantis> is it in functest?
07:25:15 <joehuang> basic gate test for OpenStack?
07:25:47 <joehuang> functest selected some basic test cases
07:25:53 <SAshish> The functest docker image is also not generated for the current run
07:26:57 <joehuang> do you have the link for the test result?
07:27:11 <SAshish> test didnt start
07:27:17 <joehuang> :(
07:27:32 <sorantis> testcases/OpenStack/healthcheck/healthcheck.sh
07:27:55 <SAshish> [jenkins@pod4-node6 ~]$ docker ps
07:27:59 <SAshish> CONTAINER ID        IMAGE               COMMAND             CREATED             STATUS              PORTS               NAMES
07:28:02 <SAshish> [jenkins@pod4-node6 ~]$
07:28:10 <SAshish> nothing here
07:29:05 <joehuang> docker container exit
07:29:52 <SAshish> 151 2016-08-11 08:27:58,103 - run_tests - ERROR - Unknown test case or tier 'multisite', or not supported by the given scenario 'os-odl_l2-nofeature-ha'.
07:30:19 <SAshish> this line is there in functest.log in /home/jenkins/opnfv/functest/results/master/
07:30:58 <SAshish> do Meimei's commit is the fix for this??
07:30:59 <SAshish> https://gerrit.opnfv.org/gerrit/#/c/18379/
07:30:59 <SAshish> this one?
07:31:09 <May-meimei> yes
07:32:04 <SAshish> but the job before the last one could run the testcases
07:32:27 <joehuang> so Meimei's patch needs to be merged
07:32:29 <May-meimei> which one?
07:33:00 <sorantis> we can also remove this one
07:33:00 <sorantis> - string:
07:33:01 <sorantis> name: KINGBIRD_LOG_FILE
07:33:02 <sorantis> default: $WORKSPACE/kingbird.log
07:33:08 <sorantis> the parameter is unnecessary
07:33:32 <sorantis> because the build log is attached to the console output anyway
07:34:39 <joehuang> same question, the last job works without this patch, only some test cases failed.
07:35:13 <May-meimei> yes, this job is triggered by me
07:35:35 <May-meimei> but last job was triggered by daily job
07:36:02 <May-meimei> I triggered this job with scenario involved"multisite"
07:36:32 <joehuang> so, trigger the daily job can verify Ashish's new fix
07:36:46 <joehuang> could you trigger the daily job
07:36:55 <SAshish> If it starts the tempest then it should
07:37:33 <May-meimei> SAshish: you have some update?
07:37:37 <joehuang> os-nosdn-multisite-ha, do we need "HA" scenario? non-HA also works
07:38:05 <May-meimei> yes, non-HA also works
07:38:30 <SAshish> which update?
07:38:58 <SAshish> so can you just trigger the ML scenario
07:41:13 <joehuang> during trigger the job, how about to have multisite colorado stable branch on next Friday, i.e Aug.19
07:42:22 <SAshish> yes, so what we have to include in stable branch?
07:43:35 <May-meimei> SAshish: just trigger the ML scenrio?
07:44:04 <joehuang> CI/Functest/Documentation scripts get merged
07:44:12 <May-meimei> oh, got it
07:44:25 <joehuang> and fix critical/major bugs
07:44:42 <sorantis> regarding that
07:45:21 <sorantis> if you mean bugs in kingbird, then it’s outside of opnfv, so branch open/closing doesn’t apply
07:45:58 <sorantis> since our build always installs kingbird master we can prioritize and fix bugs keeping the openstack roadmap
07:46:18 <joehuang> yes, the installation guide can help end user to install latest code or stable code, kingbird is aligned with OpenStack
07:47:13 <joehuang> it's mainly to create multisite repository stable branch
07:47:24 <sorantis> yes
07:48:45 <joehuang> so CI/Functest/Documentation scripts are the major contents to be included.
07:50:02 <joehuang> So do you guys think Aug.19 is feasible?
07:50:21 <sorantis> should our CI jobs build from colorado branch or master?
07:50:48 <joehuang> from master, and cherry pick back to colorado if needed
07:51:06 <SAshish> so we do tagging?
07:51:36 <joehuang> you mean multisite repository or kingbird repository?
07:52:06 <sorantis> multisite
07:52:12 <SAshish> multisite repo and kb as submodule
07:52:17 <sorantis> we have kb installation script in the repo
07:52:27 <joehuang> yes, stable branch in multisite repository
07:53:41 <joehuang> Is there any job in stable branch? I didn't heard that in B release. Need to confirm that.
07:54:22 <joehuang> if we found bugs in the master branch, then cherry pick to stable branch. If so, we need add one more job for stable branch
07:54:39 <May-meimei> yes, will do that
07:54:49 <joehuang> ok, thanks to Meimei
07:55:08 <May-meimei> there will be the some jobs for Calorad
07:55:17 <SAshish> so release will be based on the stable branch
07:55:24 <May-meimei> yes
07:55:29 <joehuang> yes
07:55:36 <sorantis> ok
07:55:59 <sorantis> then I’d do a separate job for master
07:56:11 <sorantis> how long will we keep colorado branch running?
07:56:58 <joehuang> does the intel lab support two jobs at the same time, or trigger them at different time?
07:57:17 <sorantis> different time is an option
07:57:22 <May-meimei> sorantis: you mean the job for Colorado?
07:57:27 <sorantis> yes
07:58:07 <sorantis> I don’t see why we should run specific jobs for colorado
07:58:18 <sorantis> we make things stable and branch our for C-release
07:58:21 <joehuang> I also prefer different time
07:58:28 <sorantis> and keep our build system running master
07:58:53 <joehuang> This is also one option
07:59:17 <sorantis> this way we can keep one CI
07:59:19 <joehuang> need to confirm should we have one job in colorado or not
07:59:29 <sorantis> please check
07:59:32 <joehuang> yes, it makes thing complex
07:59:54 <joehuang> #action should we keep CI/functest job for colorado release
08:00:13 <joehuang> other topics?
08:01:07 <sorantis> nope
08:01:22 <SAshish> once Meimei's patch is merged we have some update
08:01:44 <joehuang> thanks great job, team. let's end the meeting
08:02:03 <sorantis> thanks everybody
08:02:04 <joehuang> to Ashish, ok, please update
08:02:05 <sorantis> bye
08:02:09 <joehuang> bye
08:02:11 <SAshish> Good Bye
08:02:14 <joehuang> #endmeeting