14:01:43 <dfarrell07> #startmeeting testperf
14:01:43 <collabot> Meeting started Thu Aug 11 14:01:43 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:43 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:43 <collabot> The meeting name has been set to 'testperf'
14:02:00 <dfarrell07> Someone needs to start the g2m?
14:02:04 <morgan_orange> I do
14:02:10 <morgan_orange> done
14:02:11 <dfarrell07> cool, just started, thanks morgan_orange :)
14:02:26 <dfarrell07> #info CPerf (dfarrell07) is chairing today, VSPerf is taking notes
14:02:36 <morgan_orange> #info Morgan Richomme
14:02:41 <mbeierl> #info Mark Beierl
14:02:46 <kubi002> #info kubi
14:02:50 <durschatz> #info Dave Urschatz
14:02:59 <matthewli_> #info Jun Li
14:03:45 <yujunz> #info Yujun Zhang (IRC only)
14:05:07 <mtahhan__> #info Maryam Tahhan
14:05:15 <dfarrell07> #info dfarrell07
14:06:13 <dfarrell07> #topic APAC-friendly Meeting Time
14:06:21 <dfarrell07> #info We did a vote in this meeting (noting sampling bias) and tool a poll over email (to avoid sampling bias) about best time slots
14:06:28 <dfarrell07> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-August/011902.html Email with link to poll
14:06:32 <dfarrell07> #link http://doodle.com/poll/fa4nspdf4ta2u7pb Poll about APAC-friendly meeting times
14:06:39 <dfarrell07> #info Second Wednesday of the month at 0800 UTC is currently winning with 6-yes, 1-if-need-be, 0-no
14:06:51 <dfarrell07> #info Others should go vote
14:07:05 <dfarrell07> #info Second Wed. was yesterday, so if we agree we'd start next month
14:08:34 <dfarrell07> #topic Meeting Minutes
14:08:46 <dfarrell07> #info In the last month or so started taking minutes via collabot in #opnfv-meetings
14:08:56 <dfarrell07> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-meeting/2016/ All #opnfv-meeting minutes in one big dir
14:09:05 <dfarrell07> #info Up until 7-14-16, we took meeting minutes in #opnfv-testperf, which gave us a dir for all notes
14:09:12 <dfarrell07> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/ Meeting minutes in dir for #opnfv-testperf chan only
14:09:17 <dfarrell07> #info This is a problem because all meeting minutes get stored in the same dir and there's not a good way to find testperf ones
14:09:18 <acm> #info Al Morton
14:09:22 <dfarrell07> #info ODL's meetbot breaks minutes up into <channel>/<meeting title> dirs, which would make #opnfv-meeting work
14:09:32 <dfarrell07> #link https://meetings.opendaylight.org/opendaylight-integration/2016/
14:09:36 <dfarrell07> #info dfarrell07 thinks we need a) collabot to start splitting up meetings into dirs based on title 2) start using #opnfv-testperf to org notes
14:09:42 <dfarrell07> #info We'll need to update meeting wiki
14:10:29 <yujunz> Which project is maintaining the meeting bot?
14:10:46 <morgan_orange> yujunz: releng
14:11:09 <mtahhan__> I think it's the Linux Foundation that maintains the collabot
14:11:33 <mtahhan__> but maybe it is releng
14:11:33 <morgan_orange> yes Ari and Trevorc, who are attached to releng project
14:11:35 <mtahhan__> :)
14:11:41 <ChrisPriceAB> #info this can be proposed to be update by an a-mail to the help-desk
14:11:52 <ChrisPriceAB> #undo
14:11:57 <ChrisPriceAB> #info this can be proposed to be update by an e-mail to the help-desk
14:12:00 <ChrisPriceAB> :D
14:12:21 <acm> #info Finding minutes -- hard to do.
14:12:22 <dfarrell07> #info morgan_orange reports that #opnfv-testperf chan was functest, but they have moved, so we could use it
14:13:07 <dfarrell07> #info morgan_orange had been linking to minutes from wiki to make finding later possible
14:13:17 <acm> #info lots of projects send URLs to minutes in e-mail
14:13:19 <morgan_orange> #link https://wiki.opnfv.org/display/meetings/TestPerf
14:14:24 <dfarrell07> #action dfarrell07 to raise helpdesk ticket about meetbot update to get title dirs
14:15:15 <matthewli_> :)
14:15:17 <mtahhan__> sounds good to me
14:15:26 <dfarrell07> #agreed for testperf, we'll use #opnfv-testperf channel in future, as well as fix meetbot to give dirs for other projects
14:15:47 <yujunz> sounds good to me
14:15:47 <dfarrell07> #action dfarrell07 to update the wiki with info about chan
14:15:51 <acm> #info only +3 for our title directories
14:17:11 <acm> #info TSC moving to election of comitters system (?) and voting system?
14:18:00 <acm> #info TSC structure was not well recognizing the meritocracy of the community
14:18:30 <dfarrell07> #info morgan_orange gives background on TSC elections. There was feedback that there wasn't the merit in elections, so adding way to elect non-platinum members
14:18:43 <dfarrell07> #info There's a self-nomination phase open currently
14:18:50 <acm> #info so, elect some committers to the TSC - nominations in progress for 5 seats.
14:19:20 <dfarrell07> #info morgan_orange was nominated by fatih (cool)
14:19:26 <acm> #info nominations end Friday, Aug 12
14:19:35 <dfarrell07> #info TestPerf is kinda a big part of OPNFV, so would make sense to have that voice on TSC
14:21:26 <dfarrell07> #info mbeierl has been attending TSC's, morgan_orange says, and would be good rep
14:21:52 <acm> #info Mark's question: Is Morgan on TSC? -- no, just platinum companies
14:22:34 <dfarrell07> #info morgan_orange clarifies that there's no overlap between commiters, PTLs and TSC members
14:22:41 <dfarrell07> #undo
14:22:41 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2e7b910>
14:22:46 <dfarrell07> #info morgan_orange clarifies that there's no formal overlap between commiters, PTLs and TSC members
14:23:12 <dfarrell07> #info morgan_orange was elected as dev rep to Board, which is different than TSC seats
14:23:14 <acm> #info Morgan "we need test reps on TSC" -- this is not the same as the OPNFV Board
14:23:28 <dfarrell07> #chair acm
14:23:28 <collabot> Current chairs: acm dfarrell07
14:23:56 <acm> #info Committer term for TSC is one year
14:24:15 <dfarrell07> #info mbeierl if morgan_orange wants to be test rep, or if has too much on plate
14:24:55 <dfarrell07> #info Fatih has been nominated for infra, good connections with TestPerf
14:25:08 <acm> #info reps from INFRA, Doctor with good connection to OpenStack (Ryota)
14:25:42 <dfarrell07> #info mbeierl has been following TSC closely since started in OPNFV last sep.
14:25:43 <acm> #info Marck feeld he could be a good rep
14:26:14 <dfarrell07> #action acm to send email nominating mbeierl for TSC
14:26:20 <matthewli_> :)
14:26:23 <mbeierl> Thanks acm :)
14:27:02 <mbeierl> oh, Al, you're off the hook
14:27:11 <mbeierl> acm: check the email from Uli just now :)
14:27:32 <dfarrell07> is acm != Al?
14:27:46 <acm> #info yes Al
14:27:49 <mbeierl> acm is Al,
14:27:51 <dfarrell07> cool
14:28:31 <mbeierl> I was just using his real name in a moment of forgetfulness ...
14:28:47 <acm> #info I see Uli's mail, I'll reply mentioning our discussion here today.
14:28:48 <dfarrell07> #info Discussion about which tests are run for scenarios, that scenario owner may only run tests that pass/are easy, that TestPerf may want to mandate some tests are run
14:29:13 <dfarrell07> #undo
14:29:13 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x28eae90>
14:29:26 <dfarrell07> #topic Tests against Scenarios
14:29:28 <dfarrell07> #info Discussion about which tests are run for scenarios, that scenario owner may only run tests that pass/are easy, that TestPerf may want to mandate some tests are run
14:29:55 <dfarrell07> #info Some func projects have very light test coverage, installers can't manage all
14:30:12 <dfarrell07> #info Many more scenarios in C, so more important
14:30:47 <dfarrell07> #info acm asks if there is evidence people are trying to make tests easier in context of some scenarios
14:30:55 <dfarrell07> #info acm thinks could be good to have core set of tests all should pass
14:31:15 <dfarrell07> #info acm thinks we don't need to address too badly until we know it's a problem, people are trying to avoid failing tests
14:31:45 <kubi002> I'm on irc
14:31:59 <kubi002> only can hear you
14:32:15 <dfarrell07> #info morgan_orange thinks there should be a min set of tests compatible with scenario, asks yardstick/kubi002 about input
14:32:57 <kubi002> yardstick could provide smoke test cases
14:33:06 <acm> #info Morgan's recommendation: minimum tests are the same set as Brahmaputra
14:33:23 <dfarrell07> #info kubi002 points out that yardstick has smoke tests that could be used
14:34:15 <dfarrell07> #info having a min set, like smoke tests from functest and yardstick, would give lots of confidence
14:34:31 <dfarrell07> #info another recommendation would be pass both of those smoketest suites
14:35:08 <acm> #info Mark B. - we discussed categories of tests about a montho ago, why not use that?
14:35:20 <dfarrell07> #info mbeierl asks about categories/levels of tests we discussed in past, having some low level be min
14:35:34 <dfarrell07> #info dfarrell07 wonders if there's a diff b/t smoketests and these levels of tests
14:35:42 <acm> #info Morgan still need the functests and smoke tests
14:35:51 <dfarrell07> #info projects can add smoke tests if they have feature-focused ones
14:36:01 <dfarrell07> #info can run all relevant smoketests
14:36:48 <acm> #info Each test project should define different levels of testing - include in teh scenario (or not) (MR)
14:36:59 <dfarrell07> #info Recommendation is for projects to define smoke tests, and all relevant smoke tests run for compatible scenarios
14:37:20 <acm> #info Mark B connection to certification and dovetail?  Morgan: next we we have an update
14:37:23 <dfarrell07> #info OPNFV Cert discussion is relevant, will tie this in next week
14:38:54 <dfarrell07> #topic Docs
14:39:06 <acm> #info ... not clear what will be the final view of testing for Colorado (morgan)
14:39:26 <dfarrell07> #info morgan_orange points out there's a mail asking us to do combined docs for TestPerf group
14:39:43 <dfarrell07> #info we're close to the docs deadline, so if we want docs that ref all test projects we need this ASAP
14:40:32 <dfarrell07> #action morgan_orange to contact Sophia about which docs we need, any updates for TestPerf docs
14:40:38 <acm> #info Morgan: e-amil form Sofia - do we need to creat documentation for the testperf??  no further input
14:41:45 <dfarrell07> #topic APAC Poll Results
14:42:41 <dfarrell07> #agree New APAC meeting will be at 800 UTC first Wed of every month
14:43:30 <dfarrell07> #info Will run this as experiment, but if no one shows up we'll reevaluate
14:43:50 <acm> #info Morgan: this time was tried, and not very successful
14:43:53 <dfarrell07> #info This will be best for EU and APAC people, maybe want one later for APAC and US
14:44:09 <dfarrell07> #info taking good minutes for this call is important, to allow async people to follow
14:44:11 <yujunz> It's second Wednesday if I remember it correctly
14:44:29 <dfarrell07> #agreed Actually second Wed, not first, sorry
14:44:54 <dfarrell07> #action dfarrell07 to update wiki with APAC meeting
14:45:29 <dfarrell07> #info Functest is chair next week, with Bottleknecks taking notes
14:45:36 <dfarrell07> #endmeeting