07:06:01 <joehuang> #startmeeting multisite
07:06:01 <collabot`> Meeting started Thu Sep  8 07:06:01 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:06:01 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:06:01 <collabot`> The meeting name has been set to 'multisite'
07:06:11 <joehuang> #topic rollcall
07:06:17 <joehuang> #info joehuang
07:06:23 <SAshish> #info Ashish
07:06:27 <sorantis> #dimitri
07:06:32 <sorantis> #info dimitri
07:06:47 <joehuang> #topic next step open discussion
07:07:15 <SAshish> are you people able to access the lab?
07:07:21 <joehuang> yes
07:07:49 <joehuang> after they changed the firewall rule, don't know which rule
07:07:49 <SAshish> when did you try lately?
07:08:16 <joehuang> last week or the week before that
07:08:20 <joehuang> what's the issue
07:08:30 <SAshish> currently its not accessible
07:08:34 <SAshish> https://build.opnfv.org/ci/view/multisite/job/multisite-kingbird-daily-master/
07:08:59 <joehuang> but I can access it locally
07:09:05 <joehuang> access the node
07:09:08 <joehuang> locally
07:09:35 <SAshish> daily job triggered recently on 2nd
07:09:48 <SAshish> since then there is no run
07:11:17 <joehuang> so the openstack are not working>
07:12:02 <joehuang> can you access the node now
07:12:30 <SAshish> I am not able to login to setup
07:13:03 <SAshish> sorry. I am able to
07:13:04 <joehuang> no VMs in the node
07:13:34 <SAshish> [jenkins@pod4-node6 ~]$ ssh root@10.20.0.2
07:13:37 <SAshish> ssh: connect to host 10.20.0.2 port 22: No route to host
07:13:38 <joehuang> all fuel and MOS were erased away
07:13:51 <SAshish> is there any update?
07:14:17 <joehuang> I have logged on the the node, but nothing on it
07:14:36 <joehuang> [root@pod4-node6 ~]# virsh list
07:14:36 <joehuang> Id    Name                           State
07:14:37 <joehuang> ----------------------------------------------------
07:15:12 <sorantis> I’ll ask what happened
07:15:15 <joehuang> even no docker installed
07:15:28 <joehuang> [root@pod4-node6 ~]# docker ps
07:15:29 <joehuang> Cannot connect to the Docker daemon. Is the docker daemon running on this host?
07:16:42 <sorantis> something must have happened to the lab. or they didn’t inform us about lab work
07:16:57 <SAshish> yeah, may be some update or so
07:17:27 <joehuang> ok, will consult in the mail-list
07:17:28 <sorantis> this practically means that we can never assume our node stable
07:18:25 <joehuang> so your suggestion?
07:18:54 <sorantis> unless we automate the m-r installation there’s nothing we can do actually
07:18:59 <sorantis> OR
07:19:18 <sorantis> if anything happens or about to happen with the node, we should be informed
07:19:34 <joehuang> they didn't
07:19:40 <SAshish> even we have 1, we should have 2 as well
07:20:03 <joehuang> we may have to run tempest in single region in OpenStack
07:20:29 <SAshish> so, do we have any other node
07:20:29 <SAshish> ?
07:20:36 <sorantis> no
07:20:39 <joehuang> to make sure test cases runing for new patch
07:20:57 <SAshish> but they must inform the user
07:20:59 <SAshish> :(
07:21:53 <joehuang> this is very bad
07:23:32 <joehuang> please review the patch: https://gerrit.opnfv.org/gerrit/#/c/20635/, OPNFV hope all license update to creative common 4.0, and we need to update immeditly
07:24:17 <sorantis> emailed
07:24:59 <joehuang> thanks
07:25:43 <joehuang> last meeting, we discussed some topic to work in release D
07:25:56 <joehuang> 1)KB CLI (joehuang, 07:26:12)
07:25:56 <joehuang> 2)KB SDK (joehuang, 07:26:21)
07:25:56 <joehuang> 3)Resources Sync (joehuang, 07:26:37)
07:25:56 <joehuang> 3.1)SEG (joehuang, 07:27:36)
07:25:56 <joehuang> 3.2)FLAVOR (joehuang, 07:27:54)
07:25:58 <joehuang> 3.3)SSH KEY (joehuang, 07:28:08)
07:26:01 <joehuang> Revisit Geographical Redundancy
07:26:22 <joehuang> 4)cross neutron networking autom
07:26:33 <joehuang> 5) installation cooperation (joehuang, 07:32:18)
07:27:11 <joehuang> ther are some topics which are more clear, just to implement
07:27:27 <joehuang> some topics needs discussion
07:28:23 <joehuang> let's schedule these topics for which needs discussion
07:29:45 <joehuang> your proposal?
07:30:50 <sorantis> I’ve already started som work on the kingbird client
07:31:03 <SAshish> I am looking into SEG syncing
07:31:04 <joehuang> yes, saw that, it's much more clear
07:31:18 <sorantis> since it’s pretty straightforward, I think there’s not much to talk about
07:31:31 <sorantis> implementation is standard to other openstack clients
07:31:43 <sorantis> we just need to ensure that the APIs are properly invoked
07:31:44 <SAshish> we shall complete kb CLI, then can move forward
07:31:48 <joehuang> yes, for client, it's quite straightforward
07:32:36 <joehuang> #info KB CLI is pretty straightforward, just implement it.
07:33:10 <joehuang> for SEG, discussion is needed
07:33:10 <sorantis> regarding kb SDK. I think the priority to this is quite small, so we can consider the other points before coming to this one
07:33:53 <joehuang> can kbSDK included in KB CLI
07:34:09 <joehuang> ususally CLI also call the SDK
07:34:19 <sorantis> I think so. I haven’t looked into it yet. but I guess it’s just another wrapper to the APIs
07:34:29 <sorantis> I’ll look into it
07:34:42 <joehuang> correct, just a client wrapper, like novaclient class
07:34:43 <SAshish> we include kb cli to openstack sdk
07:35:26 <sorantis> ok, time to merge the initial patch
07:35:31 <sorantis> it seems that the requirements are out of date
07:36:06 <joehuang> not include kb cli to openstack sdk, I think it's not possible if KB is not an offical project to be included in openstack sdk
07:36:29 <sorantis> we shall see
07:36:41 <sorantis> we can always write a plugin that connects to openstackcli
07:37:05 <joehuang> #action check whether it's possible to include kb cli/sdk in openstack
07:37:24 <SAshish> one doubt guys
07:37:30 <joehuang> please
07:37:49 <SAshish> how kbsdk is diff from kb cli?
07:38:12 <SAshish> I thought kbsdk == inclusion of kb cli in openstack sdk
07:39:40 <SAshish> kb cli with which we get cli and kb python binding
07:39:43 <joehuang> kbsdk is to provide a client package which could be called by other package
07:40:33 <joehuang> when you install openstack client, cli provided
07:40:38 <joehuang> at the same time
07:41:00 <SAshish> when we install nova client we get python bindings which can be called by other packges also right
07:41:09 <SAshish> + we get CLI
07:41:21 <joehuang> other package for example kingbird can import client and write code to do the api calling
07:41:24 <sorantis> yes
07:41:28 <sorantis> but now it’s separated
07:41:40 <sorantis> since the intention is to have a uniform client for all services
07:41:43 <SAshish> oh I see
07:41:50 <SAshish> that is openstack sdk
07:41:52 <SAshish> not kb sdk
07:41:54 <SAshish> right?
07:42:29 <sorantis> openstacksdk is a way to have programmatic access to all services with a single authentication
07:44:22 <joehuang> provide kb sdk is important, programmatic calling will be more practical than manaullay using cli
07:46:11 <joehuang> hello, dimitri, not received your mail in the mail-list?
07:46:25 <sorantis> I email it to my coleague
07:46:29 <sorantis> He’s here now
07:46:36 <sorantis> I’ll ask him directly and let you know
07:46:45 <sorantis> btw, just updated the common layer patch, please review
07:46:46 <joehuang> good!
07:46:52 <joehuang> ok
07:47:13 <joehuang> so let's finish the kb client first, then discuss other topics
07:47:54 <sorantis> ok
07:48:01 <sorantis> so power went down in the intel lab over the weekend
07:48:28 <sorantis> Fatih will reinstall the node, and then I’ll reconfigure to m-r
07:48:39 <joehuang> thanks a lot!
07:49:20 <joehuang> other topics?
07:49:51 <sorantis> i guess for the time being we’re set
07:50:33 <sorantis> SEG
07:51:43 <joehuang> for what? SEG
07:51:53 <sorantis> Ashish wanted to talk about it
07:51:59 <joehuang> please
07:54:01 <sorantis> ashish?
07:54:07 <joehuang> hello, ashish?
07:54:24 <SAshish> yeah, as we discussed we will leave the remote security groups
07:55:39 <SAshish> and can sync others.
07:56:03 <SAshish> so I am still working on it,
07:56:21 <sorantis> are you working on a solution proposal?
07:56:31 <joehuang> for SEG, shall we implement it in KB or Tricircle(which only deal with networking part after spliting)
07:56:34 <SAshish> yes, but need some setup to verify
07:56:49 <sorantis> yes
07:57:18 <joehuang> and I also discussed with Bin, about how Gluon and Tricircle work together for some issues discussed in the mail-list which are not touched in gluon yet
07:57:24 <sorantis> joe, let’s first see what limitation we will face when syncing security groups
07:57:24 <SAshish> yes, will send the plan for SEG. but verification needs to be done
07:58:07 <sorantis> this should be part of the study of course
07:58:21 <joehuang> ok, more detail proposal, except that, in multi-region deployment, IP address space management and ip allocation is also needed to be considered
07:58:35 <joehuang> good!
07:58:44 <joehuang> we can have open discussion
07:58:55 <SAshish> yeah, need the setup soon
07:59:45 <sorantis> great
07:59:49 <sorantis> time’s up gents
07:59:54 <joehuang> yes
08:00:02 <joehuang> thank you for the meeting
08:00:04 <SAshish> Please follow up with Fatih
08:00:06 <SAshish> for setup
08:00:27 <joehuang> great appreciation
08:00:43 <sorantis> yes
08:00:46 <joehuang> yes
08:00:52 <joehuang> #endmeeting