07:09:47 <joehuang> #startmeeting multisite
07:09:47 <collabot> Meeting started Thu Oct 20 07:09:47 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:09:47 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:09:47 <collabot> The meeting name has been set to 'multisite'
07:10:22 <joehuang> before the meeting, how about to have a meetup in Barcelona next week?
07:10:40 <sorantis> good idea
07:10:49 <SAshish> This time I am not travelling :(
07:11:00 <joehuang> o. it's a pitty
07:11:26 <joehuang> So, may Dimitri and I meet some time next week
07:11:35 <joehuang> what your proposal
07:12:21 <sorantis> Let’s take this offline. I’m sure we can find some time during lunch or instead some session :)
07:12:50 <joehuang> ok
07:13:25 <joehuang> #topic D relase planning
07:13:44 <joehuang> David provides a template for the planning for D release
07:14:21 <joehuang> #link https://wiki.opnfv.org/display/multisite/Multisite+Release+D+Planning
07:14:23 <sorantis> yes, it’s a rather detailed plan
07:14:25 <sorantis> which is good
07:15:00 <joehuang> some phase may be not applicable to multisite
07:15:06 <sorantis> I don’t see time allocated for development
07:15:11 <sorantis> yes
07:15:14 <sorantis> and some are missing
07:15:49 <joehuang> no phase for implementation, all are integrations :(
07:16:38 <joehuang> I also send a mail in the mail-list, hope that David can provide a template for requirements and feature development project
07:17:48 <joehuang> currently the most important milestone for us to keep aligned with is MS6 and MS7, the stable branch creation and close
07:18:24 <joehuang> for other milestones need to discuss with David
07:19:19 <joehuang> Please update the page if needed, also will consult David's suggestion
07:19:45 <SAshish> which part we can update here?
07:20:07 <SAshish> milestones?
07:20:56 <joehuang> milestones before the MS6/MS7 could be updated
07:21:25 <sorantis> +1
07:21:28 <sorantis> these two are important
07:21:38 <sorantis> the rest we can customize
07:21:47 <joehuang> +1
07:21:52 <SAshish> +1
07:21:55 <sorantis> Shall we put our planning to wiki?
07:22:07 <sorantis> We’ve come up with a list a couple weeks back
07:22:20 <joehuang> #info adjust milestone items before MS6/MS7
07:22:35 <joehuang> yes, the link is in the wiki, we can edit it online
07:22:43 <joehuang> #link https://wiki.opnfv.org/display/multisite/Multisite+Release+D+Planning
07:23:14 <sorantis> Joe, do you have our list of requirements for D?
07:23:35 <joehuang> yes
07:23:38 <joehuang> one second
07:24:42 <joehuang> 1)KB CLI (joehuang, 07:26:12)
07:24:42 <joehuang> 2)KB SDK (joehuang, 07:26:21)
07:24:42 <joehuang> 3)Resources Sync (joehuang, 07:26:37)
07:24:42 <joehuang> 3.1)SEG (joehuang, 07:27:36)
07:24:42 <joehuang> 3.2)FLAVOR (joehuang, 07:27:54)
07:24:44 <joehuang> 3.3)SSH KEY (joehuang, 07:28:08)
07:24:47 <joehuang> Revisit Geographical Redundancy
07:24:49 <joehuang> 4)cross neutron networking automation (joehuang, 07:28:31)
07:24:52 <joehuang> 5) installation cooperation (joehuang, 07:32:18)
07:25:17 <joehuang> this is the items for release D
07:26:01 <SAshish> lot of work for D
07:26:36 <joehuang> seems too much
07:26:46 <sorantis> nice, we can start putting it in the wiki, like we did with C
07:26:48 <joehuang> and it's a short release
07:26:55 <joehuang> agree
07:28:28 <joehuang> so, let's back to the thread of resource sync discussion?
07:28:45 <joehuang> and update the plan in the wiki offline first
07:29:08 <joehuang> after update, discuss in the weekly meeting
07:29:20 <sorantis> #action Update D-plan on the wiki
07:30:17 <SAshish> for resource sync, shall we begin with flavors?
07:30:27 <sorantis> let’s take ssh keys
07:30:43 <sorantis> should be straightforward
07:30:43 <joehuang> yes. flavor/volume type ssh keys, I think it's good to start
07:30:55 <sorantis> flavors are also a bit complicated
07:31:05 <SAshish> if numa based
07:31:14 <sorantis> if a flavor has extra_specs defined, then we need to make sure that the infrastructure has those capabilities
07:31:27 <SAshish> yeah. agree
07:31:31 <sorantis> otherwise there’s no use of syncing flavors
07:31:33 <sorantis> however
07:31:41 <sorantis> the user should know best, right?
07:32:03 <joehuang> for flavor is managed by the admin, I think admin will take care to sync the flavor to where the resources support the capabilities
07:32:10 <sorantis> +1
07:32:11 <joehuang> just like configuration in nova.conf
07:32:19 <sorantis> yes
07:32:33 <sorantis> so ssh keys can be a good start
07:32:39 <joehuang> +1
07:32:50 <SAshish> fine
07:32:51 <joehuang> SSH key is user based
07:33:30 <joehuang> so need to allow user can also access the KB SSH key sync api
07:34:09 <SAshish> yes, the document needs to be updated w.r.t. ssh keys now
07:34:47 <joehuang> #info ssh keys can be a good start for resource sync.
07:35:00 <joehuang> to Ashish, yes
07:35:10 <joehuang> #action document update
07:35:10 <SAshish> will update and resend
07:36:35 <SAshish> once this is settled, will work on implementation
07:36:59 <joehuang> will review in time
07:37:29 <SAshish> cool
07:37:43 <joehuang> blueprint needs to update too in launchpad for newton release almost done
07:39:05 <SAshish> resource sync blueprint right?
07:39:16 <joehuang> all blueprints
07:39:26 <SAshish> oh, yes
07:39:31 <joehuang> some old blueprints are not updated during newton release
07:39:55 <sorantis> #action update kb blueprints with new release info
07:40:00 <SAshish> I guess Dimitri only can do that
07:40:01 <joehuang> #link https://blueprints.launchpad.net/kingbird
07:40:10 <sorantis> I’ll do that
07:40:11 <joehuang> each one can do that
07:40:35 <joehuang> it's good for bp owner to update the status of the blueprint
07:40:51 <SAshish> yeah, checked it. any body can do that
07:41:50 <joehuang> ok, so please update offline
07:43:51 <joehuang> would you prefer to discuss the SEG or Revisit Geographical Redundancy for the next topic
07:45:07 <sorantis> since the other opnfv teams will start their planning now/soon, I think we should let them know about the share keystone use case
07:45:15 <sorantis> First stop I suggest we make at Fuel
07:45:45 <joehuang> you mean Fuel installation to support shared KeyStone?
07:45:50 <sorantis> some folks from fuel already know about this requirement. we need to push it further
07:46:06 <SAshish> ssh keys also there can be synchronization problems right?
07:46:06 <joehuang> may we met them in Barcelona?
07:46:23 <sorantis> I think they will be there
07:46:45 <joehuang> to Ashish, all these are issues in multisite scenario:)
07:47:01 <joehuang> Dimitri, could you ping them, let's meet together?
07:47:20 <sorantis> yes, I’ll give it a try
07:47:45 <SAshish> all these scenarios are difficult to handle, I proposed an optional verify sync
07:47:48 <joehuang> In OPNFV summit in Berlin, some guys from Mirantis discussed with me about the keystone issues in multi-siet
07:48:22 <joehuang> so I think they will be interested in making Fuel works for multi-site
07:49:58 <joehuang> #info talk with Fuel in Barcelona on installation support
07:50:30 <sorantis> also, I propose we cancel the next week’s meeting
07:50:36 <joehuang> sure
07:51:07 <joehuang> #info next weekly meeting will be cancelled due to OpenStack summit
07:51:56 <joehuang> may be let's start from SSH key sync. and discuss other topics in next meeting?
07:52:19 <sorantis> ok
07:52:20 <SAshish> +1
07:52:31 <joehuang> thank you
07:52:38 <joehuang> #endmeeting