#opnfv-meeting: dovetail weekly meeting

Meeting started by hongbo_tian at 14:01:01 UTC (full logs).

Meeting summary

    1. Hongbo (hongbo_tian, 14:01:28)

  1. approval of the minutes (hongbo_tian, 14:03:41)
  2. Plugfest planning (ChrisPriceAB, 14:08:11)
    1. Hongbo outlines the objectives of the dovetail team at the Plugfest (ChrisPriceAB, 14:08:57)
    2. The dovetail tools dhoule be able to; run against a VIM&VNFi, verify the results, capture and record the evaluation. (ChrisPriceAB, 14:09:45)
    3. Leo asks if the objectives may be to high level. (ChrisPriceAB, 14:10:07)
    4. Hongbo suggest we ask participating teams if they would be willing to run the dovetail tests at the event. (ChrisPriceAB, 14:10:57)
    5. ACTION: Leo to check with the plugfest team to identify who will allow dovetail testing at the event (ChrisPriceAB, 14:11:44)
    6. Wenjing asks if we have a list of test cases that we would run. (ChrisPriceAB, 14:12:14)
    7. Hongbo answers that all functest and yardstick test cases should be able to be run by the tool. (ChrisPriceAB, 14:12:42)
    8. Bryan Sullivan (bryan_att, 14:13:23)
    9. Wenjong asks how many tests, an which test areas are to be considered for the dovetail test suite at the plugfest. (ChrisPriceAB, 14:13:36)
    10. different tests have various levels of functional verification completeness - we need to find those tests that set the bar we are looking for (bryan_att, 14:17:21)
    11. anyone proposing that a test shoudl qualify for dovetail (e.g. per the JIRA approach I described last week) should explain the level of verification supported by the test. but we also need to set some expectations in the dovetail project. (bryan_att, 14:18:32)
    12. on that point, I did not see any comment to the Kanban board I setup last time as noted on the meeting: https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=147&projectKey=DOVETAIL&selectedIssue=DOVETAIL-53 (bryan_att, 14:20:14)
    13. that was intended to help give us a process to move from the wiki to JIRA for assessment of tests proposed for the dovetail suite (bryan_att, 14:20:43)

  3. DoveTail scope, blueprint and methodology (ChrisPriceAB, 14:21:31)
    1. if the group agrees, we can proceed to add more tests from the wiki, but I would like to set some expectations on the description of the tests, e.g. per the point we just talked about - how does (or should) the test actually verify the function it's focused on? we need to define a template for tests submitted thru JIRA - and not just an outline, but (bryan_att, 14:23:01)
    2. IMO the focus should be on verifying the features that the SUT claims to support. In that case the scenario is irrelevant, except that the SUT provider will declare what features are included in the SUT. (bryan_att, 14:29:35)
    3. AGREED: the team agrees not to tie testing activities to "scenarios" but to associate testing with "feature sets" supported by OPNFV. (ChrisPriceAB, 14:35:24)
    4. bryan_att cautions against testing interfaces, unless we intend to validate existing implementations form our source comunities. (ChrisPriceAB, 14:37:29)
    5. wenjing answers that we intend to validate against inhereted/implemented interfaces. (ChrisPriceAB, 14:38:06)
    6. I suggest for the current release we do not focus on interfaces above the VIM, rather focus e.g. on the portability of the VNF packages as deployable through upper-MANO stack components. If the upper functions/interfaces crystalize consistently then we could focus on them for the future. But for D and probably E, we will not be ready to usefully (bryan_att, 14:41:33)
    7. ... validate any interfaces above the VIM, except where represented as data objects. (bryan_att, 14:42:03)
    8. bryan_att indicates that we need to work with the project PTL's and test projects to establish a plan for how we will test features in OPNFV. (ChrisPriceAB, 14:52:05)
    9. wenjing will share his presentation on methodology and will present it on the C&C call. (ChrisPriceAB, 14:59:48)

  4. AoB (ChrisPriceAB, 15:00:51)
    1. hongbo asks about needing to change the time of the cal, to be taken to the lists (ChrisPriceAB, 15:00:54)


Meeting ended at 15:00:59 UTC (full logs).

Action items

  1. Leo to check with the plugfest team to identify who will allow dovetail testing at the event


People present (lines said)

  1. ChrisPriceAB (25)
  2. bryan_att (11)
  3. collabot` (6)
  4. hongbo_tian (4)


Generated by MeetBot 0.1.4.