08:02:31 <joehuang> #startmeeting multisite
08:02:31 <collabot`> Meeting started Thu Dec  1 08:02:31 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:31 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:02:31 <collabot`> The meeting name has been set to 'multisite'
08:03:08 <joehuang> #topic rollcall
08:03:17 <joehuang> #info joehuang
08:03:21 <goutham_pratapa_> #info goutham
08:03:44 <sorantis> #info dimitri
08:04:25 <joehuang> since Dimitri's patch is WIP, so let's discuss Kingbird feature implementation
08:04:32 <joehuang> #topic Kingbird feature implementation
08:04:56 <joehuang> I have updated comment in the doc
08:05:00 <goutham_pratapa_> Keypair syncing  feature part is done working on the test-cases
08:05:15 <joehuang> great progress
08:05:34 <joehuang> goutham has one good proposal
08:05:37 <goutham_pratapa_> yea i have replied to that and gave a suggestion for the scenario "if user wants to sync all the keypairs"
08:06:02 <goutham_pratapa_> right now the following curl request are working http://hastebin.com/gimesatami.scala
08:07:09 <joehuang> Dimitri, your idea on Goutham's proposal?
08:07:44 <joehuang> sync one specified resource or all
08:08:29 <sorantis> yes, we’ve discussed thit
08:08:31 <sorantis> s
08:08:54 <sorantis> and I suggested to have the resource id in the query url itself
08:09:02 <goutham_pratapa_> yes
08:09:14 <goutham_pratapa_> that was actually dimitri's suggestion :)
08:09:19 <sorantis> it’s nice approach
08:09:25 <sorantis> no the idea was yours
08:09:29 <joehuang> yes, it's general pecan rest interface
08:09:48 <joehuang> thank you dimitri, and also goutham
08:09:56 <sorantis> Goutham don’t forget to put these curl examples in the doc
08:10:06 <goutham_pratapa_> sure dimitri
08:10:20 <joehuang> #action put these curl examples in the doc
08:10:36 <goutham_pratapa_> i think we can discuss about the KB cli guide and finalize the commands
08:11:07 <joehuang> yes, just want to discuss this
08:11:15 <joehuang> comments also given to this doc
08:11:19 <goutham_pratapa_> i have replied to your comments
08:11:42 <goutham_pratapa_> and changed accordingly
08:12:30 <joehuang> ok, it's very important that the tenant can view his own quota and usage
08:13:21 <goutham_pratapa_> yea then he can use "kingbird quota usage"
08:13:49 <goutham_pratapa_> --tenant option will be valid if and only if it is admin
08:14:48 <joehuang> yes, otherwise the tenant can only view his own quota usage
08:15:00 <joehuang> of course, there is another question
08:15:26 <joehuang> do we want to support hierarchy tenant quota
08:15:41 <goutham_pratapa_> yes i have a doubt about the nova-API version as well
08:15:50 <joehuang> of leave it as one to do list in the road map
08:16:06 <goutham_pratapa_> in my newton setup when i see the latest it is showing 2.25
08:16:06 <joehuang> please
08:16:22 <goutham_pratapa_> so i hardcoded that value with that it is working
08:16:31 <joehuang> have you updated the client package?
08:16:48 <goutham_pratapa_> exactly i want those details :)
08:16:57 <goutham_pratapa_> how to do that??
08:17:21 <joehuang> pip install --upgrade python-novaclient
08:17:26 <goutham_pratapa_> hmm
08:17:37 <joehuang> and pip install --upgrade python-openstackclient
08:18:04 <goutham_pratapa_> i have done this
08:18:15 <goutham_pratapa_> but ok will verify again
08:18:28 <joehuang> you can check the package version
08:18:35 <goutham_pratapa_> sure
08:19:21 <joehuang> pip show python-novaclient
08:19:30 <joehuang> and pip show python-openstackclient
08:19:37 <joehuang> to check the version of the clients
08:19:43 <goutham_pratapa_> sure
08:19:48 <sorantis> I want to share progress on our lab work
08:20:02 <joehuang> please, look forward on this
08:20:43 <sorantis> #info Ticket has been registered on INFRA https://jira.opnfv.org/browse/INFRA-38 .
08:21:19 <sorantis> the commit is practically ready from the code perspective. I will need to finalize one script and then debug on a working environment.
08:21:50 <sorantis> This may take some time as I still don’t have a working node with Fuel 10.0 (I need to know the updated config files structure)
08:22:00 <sorantis> so all in all we’re getting there
08:22:34 <joehuang> it takes time, already a great step to the result
08:22:54 <sorantis> one more thing
08:24:30 <sorantis> #info https://build.opnfv.org/ci/view/multisite/job/multisite-kingbird-virtual-daily-master/
08:24:48 <sorantis> this is the new jenkins jobs
08:25:34 <joehuang> Functest has not addressed the dependency conflict yet
08:26:25 <sorantis> yes, but it doesn’t matter at this point. We still need to invoke the scripts in each job. This is just a skeleton
08:29:00 <joehuang> Hellen/Jose gave up venv method, and is trying the container slicing/splitting
08:29:30 <joehuang> yes, at least currently it doesn't matter
08:30:33 <joehuang> good
08:30:51 <joehuang> #topic open discussion
08:31:13 <joehuang> Any topic from you
08:31:38 <sorantis> nope, all cought up
08:31:54 <joehuang> for the kingbird as one openstack official project
08:32:07 <sorantis> yes, definitely something to consider
08:32:23 <sorantis> but for now there are more pressing matters
08:32:39 <sorantis> I’ve save the links you provided, so will go over them when i get the chance
08:32:43 <sorantis> saved*
08:33:48 <joehuang> I think the one not meet OpenStack requirements is m-l discussion/meeting should be done in OpenStack, and all developement activities are visible in openstack community
08:34:42 <sorantis> but Kb is a bit special in this regard
08:34:57 <sorantis> it’s from OPNFV
08:35:07 <joehuang> we can discuss that if you have read all requirements and guideline(which is linked in that)
08:35:23 <sorantis> yes, let’s do that. I can only speculate at this point
08:35:31 <joehuang> ok
08:35:51 <joehuang> don't worry, it's still one official part of OPNFV, isn't it? :)
08:36:48 <joehuang> if no other topic, let's end the meeting early today
08:37:11 <sorantis> +1 I think we’re done
08:37:22 <goutham_pratapa_> done
08:37:30 <joehuang> thank you
08:37:34 <joehuang> #endmeeting