08:01:48 <joehuang> #startmeeting multisite
08:01:48 <collabot> Meeting started Thu Dec 15 08:01:48 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:48 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:48 <collabot> The meeting name has been set to 'multisite'
08:02:02 <joehuang> #topic rollcall
08:02:06 <joehuang> #info joehuang
08:02:11 <sorantis> #info dimitri
08:02:12 <goutham> #info goutham
08:02:26 <joehuang> #topic Kingbird feature development
08:02:54 <joehuang> hello, Goutham, is there any topic to dicssus for the feature development?
08:03:01 <goutham> resource_syncing is done with the test_cases currently refractoring it will commit by EOD
08:03:15 <goutham> i will commit by EOD **
08:03:25 <joehuang> so we can begin to review the patch soon
08:03:41 <goutham> sure.
08:03:54 <goutham> i think nova api version 2.37 is good enough
08:04:10 <joehuang> I remember that there is some bug for Nova/Cinder quota limit query
08:04:22 <joehuang> yes, Nova API 2.37 is good
08:05:37 <goutham> will update patch for the commit https://review.openstack.org/#/c/392140/ based on the commits
08:05:38 <joehuang> so we use a loop to calculate the quota usage
08:05:50 <goutham> comments**
08:06:31 <joehuang> #link https://bugs.launchpad.net/kingbird/+bug/1583967
08:06:44 <joehuang> #link https://bugs.launchpad.net/kingbird/+bug/1583965
08:06:54 <joehuang> it's Cinder/Neutron instead
08:07:09 <joehuang> the performance issue may impact production use
08:07:30 <goutham> yes we are using threads here
08:08:28 <joehuang> query all then use loop, the cinder/neutron should provide usage in the limit command
08:08:40 <joehuang> so no need to query all then calculate one by one
08:09:50 <goutham> ohkk i will look into these things after committing the code related to keypair
08:11:14 <joehuang> and Dimitri seems to register the bugs in Cinder/Neutron?
08:11:31 <joehuang> I don't remember
08:11:45 <joehuang> already report the bug
08:12:21 <sorantis> the bug in cinder has been fixed
08:12:39 <sorantis> I should check which version of cinder client got it merged
08:12:42 <joehuang> so we can update the code at least in cinder
08:13:54 <sorantis> https://review.openstack.org/#/c/314995/
08:13:57 <sorantis> yes
08:15:22 <joehuang> great, so we can update the code in kingbird for cinder part
08:16:16 <joehuang> Have you reported the bug in Neutron too?
08:17:22 <sorantis> no, no neutron. I don’t remember the reason though, but i had one :)
08:17:23 <joehuang> #action update the code in the quota usgae calculation for cinder part to enhance the performance
08:18:03 <joehuang> #link https://bugs.launchpad.net/kingbird/+bug/1583967
08:18:33 <joehuang> almost all basic objects in neutron are iterated
08:21:51 <joehuang> ok, check after the meeting to see if we need a bug report in neutron too
08:22:37 <sorantis> ok, let us know the progress
08:22:57 <joehuang> #action check to see whether to report the bug for quota usage retrievement in the neutron
08:23:30 <joehuang> #topic mutli-site deployment
08:23:52 <joehuang> Dimitri, how about the progress in multi-site deployment
08:24:28 <sorantis> the lab is being migrated now, so there’s still no nodes assigned to us unfortunately
08:25:35 <joehuang> ok
08:25:57 <joehuang> I am preparing general multi-region devstack environment in OpenStack infrastructure
08:26:28 <joehuang> after the patch is merged, then we can start a multi-region job if needed
08:27:00 <joehuang> #link https://review.openstack.org/#/c/409653/
08:27:01 <sorantis> good stuff
08:28:00 <joehuang> But it denpends on patch which was submitted by keystone team
08:28:07 <joehuang> to define the node's role
08:28:32 <joehuang> my patch can only be merged after that one was review and merged
08:29:01 <joehuang> there many projects need multi-region requirement
08:29:32 <sorantis> yes, that’s true
08:29:53 <sorantis> hopefully in the light of this, kingbird will become more noticeable
08:30:48 <joehuang> yes, but if we work mostly in OPNFV, may be it'll narrow the visibility of kingbird
08:32:21 <joehuang> so next topic?
08:32:39 <sorantis> no other things to bring up
08:32:48 <joehuang> #topic Revisit Geographical Redundancy
08:32:50 <sorantis> oh
08:32:54 <sorantis> one more thing
08:33:02 <joehuang> yes, it's in the queue for discussion
08:33:08 <sorantis> It’s getting close to the christmas
08:33:09 <joehuang> please
08:33:23 <joehuang> yes, how long for your holiday
08:33:38 <sorantis> I will be away until Jan 8th
08:33:48 <joehuang> from ?
08:34:15 <sorantis> Dec 21st
08:34:38 <joehuang> so you'll be on holiday next week
08:34:44 <joehuang> how about Goutham
08:34:51 <goutham> i will be there
08:34:55 <goutham> i will be available
08:35:21 <joehuang> You'll have no special christmas holiday
08:35:32 <joehuang> ?
08:35:34 <goutham> no nothing as such
08:35:41 <joehuang> understand
08:35:57 <joehuang> we don't have such a holiday too
08:36:19 <joehuang> In this case, we may move the topic until Dimitri come back from Jan
08:36:48 <joehuang> if no other topic, let's end the meeting
08:37:33 <sorantis> ok
08:37:41 <sorantis> see you next time!
08:37:55 <goutham> ok
08:37:58 <goutham> bye all
08:38:19 <joehuang> bye
08:38:23 <joehuang> #endmeetnig
08:38:34 <joehuang> have a nice holiday
08:38:41 <joehuang> #endmeeting