08:02:15 <joehuang> #startmeeting multisite
08:02:15 <collabot> Meeting started Thu Jan 19 08:02:15 2017 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:15 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:02:15 <collabot> The meeting name has been set to 'multisite'
08:03:01 <joehuang> hello
08:04:01 <joehuang> Helllo Goutham and Dimitri?
08:04:24 <goutham> hi
08:04:32 <joehuang> hi
08:04:52 <goutham> dimitri has to join i guess.
08:05:03 <joehuang> ok
08:05:56 <goutham> i have updated the tempest test_cases with python-clients
08:06:04 <goutham> i hope u saw a new commit :)
08:06:16 <goutham> i mean a new patch update ***8
08:07:17 <goutham> i have a doubt joe..
08:08:05 <joehuang> python-kingbirdclient has not been released yet, so the import may fail
08:08:36 <goutham> yess..
08:08:39 <joehuang> python-kingbirdlcient needs to be released for the tempest test to run
08:08:45 <goutham> yes
08:08:49 <goutham> that will be done soon
08:08:59 <goutham> but in delete request we cannot send body i think
08:09:29 <goutham> because we use requests and in requests there is no such thing like a body which can be sent right??
08:09:29 <joehuang> no body for delete request
08:09:55 <joehuang> empty body
08:10:43 <goutham> yes which means this curl request (please visit link) "https://hastebin.com/waxekutobe.bash" cannnot be performed
08:11:38 <joehuang> o, for quota delete, ashish implement it that single quota object could be deleted
08:11:39 <joehuang> so it's ok
08:12:40 <goutham> but using kingbird client we cannot send the body i think
08:12:55 <joehuang> should be able to do
08:13:01 <goutham> i have tried and failed
08:13:30 <goutham> we will be using requet.delete internally then how can we send??
08:13:32 <joehuang> otherwise only part of the deletion function will be supported by kingbird client
08:13:59 <sorantis> hi
08:14:09 <joehuang> hello, Dimitri
08:14:12 <goutham> actaully in nova and cinder there is a complete quota deletion for specified tenant but not a particular item deletion
08:14:15 <goutham> hi dimitri
08:14:23 <sorantis> hi guys
08:14:55 <joehuang> How about the multisite deployment environment
08:15:43 <sorantis> it’s ready
08:16:15 <sorantis> the nodes have been configured
08:16:34 <sorantis> request access to user.opnfvericsson.se
08:16:34 <joehuang> you mean hardware ready of multi-region OpenStack ready?
08:17:17 <joehuang> not able to access the user.opnfvericsson.se
08:17:37 <sorantis> mr will be ready also. I’m testing the scripts. there’s been a lot of changes in openstack client which means i need to rewrite the kb install scripts as well
08:17:52 <joehuang> yes
08:17:53 <sorantis> write a jira ticket on INFRA
08:18:12 <sorantis> Jose will get it fixed for you in no time
08:18:29 <sorantis> attach your public key
08:18:39 <joehuang> ok
08:19:21 <joehuang> #info Multi Region environment ready soon
08:20:11 <joehuang> currently Goutham is update the tempest to use kingbirdclient,
08:20:21 <joehuang> but kingbirdclient has not been released yet
08:21:12 <sorantis> yes, I know. I will release it as soon as all the commits are in
08:21:21 <goutham> Yes before dimitri releases that i would like to discuss about the single item deletion in kb-client
08:21:29 <sorantis> tag it with 0.0.1
08:22:02 <joehuang> Goutham just mentioned that deletion problem
08:22:21 <sorantis> yes, it is a problem :)
08:22:41 <joehuang> only delete all can be supported
08:23:27 <joehuang> even in Nova/Cinder, only delete all supported
08:23:27 <goutham> so i will remove that small peice of code and then the kb-client will be ready to release ..
08:23:37 <sorantis> yes, we need to change that
08:23:40 <sorantis> good catch
08:24:29 <goutham> i will make a commit very soon..
08:24:29 <joehuang> #info remove item level quota deletion
08:24:59 <joehuang> #action release python-kingbirdclient so that kingbird tempest can use it
08:25:45 <goutham> we need not change the server side code immediately. we will remove it once we are done with the keypair syncin part
08:25:47 <joehuang> it's very tight to add job tables
08:26:31 <joehuang> do you want to add that in Ocata release?
08:26:55 <goutham> yes.
08:27:05 <goutham> i will try hard to complete by that time..
08:28:42 <joehuang> Dimitri, your ideas?
08:30:21 <joehuang> And I'll be on holiday from Jan 25 ~ Feb.3
08:30:58 <goutham> ohh
08:31:31 <joehuang> Chinese spring festival
08:31:44 <goutham> great..
08:32:25 <goutham> but then we have to act fast then.. writing test_cases will eb
08:32:33 <sorantis> What is your estimate goutham?
08:33:15 <goutham> finalize the db structure and give me a 5 days time based on the progress can we decide??
08:34:04 <goutham> but i think we can do it... :)
08:34:10 <joehuang> you have to change the reponse for old commands, and test cases need to update too
08:34:52 <goutham> yes..
08:35:10 <sorantis> ok
08:35:17 <goutham> there are some challenges..
08:35:54 <joehuang> job_status in two tables?
08:36:30 <goutham> No one is sync_status which means keypair's sync status in that particular region..
08:36:44 <goutham> and the other is entire job status
08:37:01 <goutham> My idea is to extend this to multiple keypair sync as well
08:37:16 <goutham> so we have to sync status in two tables..
08:37:28 <goutham> two sync_status***
08:38:15 <joehuang> when the job will be purged?
08:38:26 <joehuang> otherwise the job table will grow bigger and bigger
08:38:36 <joehuang> or have to purge it manually?
08:38:47 <goutham> i think it has to be purged when a user deletes it manually..
08:39:22 <joehuang> a user or admin?
08:39:29 <goutham> user
08:39:39 <joehuang> I assume that only admin can purge the finished job
08:39:57 <joehuang> you mean user should have to purge the job by himself
08:40:42 <goutham> say if a user performed a job and he wants to view what resources he has synced in a particular job he must have the right to see.. what he has synced.
08:41:40 <goutham> keeping the deletion rights only with admin i dont think its a good idea
08:42:15 <joehuang> so you have to provide job management interface too
08:42:37 <joehuang> to list old jobs, delete old jobs
08:43:36 <goutham> actually i didnt get the last point
08:43:42 <goutham> we will list all the jobs.
08:43:57 <goutham> which are started or done by a particular user.
08:44:20 <sorantis> this can wait
08:44:59 <sorantis> job management is another feature
08:46:12 <goutham> hmm
08:48:17 <joehuang> sorry my link was broken
08:49:01 <joehuang> hello, would you chair the next two weekly meetings?
08:49:16 <joehuang> I'll be on holiday that time
08:49:16 <sorantis> i was saying that job management is a different feature
08:49:28 <sorantis> and can be postpone to next release
08:49:36 <joehuang> fine
08:50:01 <sorantis> I’ll coordinate with goutham and if there will be the need for a meeting, I’ll call for it
08:50:13 <joehuang> thank you Dimitri
08:50:13 <goutham> sure..
08:50:25 <goutham> So is the db structure ok to all??
08:50:45 <joehuang> job_status dupplicated
08:50:50 <joehuang> others ok
08:51:16 <goutham> one is region_sync_Status and the other is overall job_sync detail
08:51:42 <joehuang> in fact, job_status could be calculated through the sync_status of different region
08:51:48 <goutham> as discussed my idea is to extend this to multiple keypair as well
08:51:53 <joehuang> no need to store it in a special field
08:52:22 <joehuang> multiple keypair sync as one job or multiple jobs?
08:53:02 <goutham> so every keypair sync to every region status if synced then we update the row as "Success" and if failed we update the row as "failure" and then if we have one fail in that column for that job
08:53:03 <joehuang> the resource id is different for different keypair
08:54:17 <goutham> we update the job status as failure and the user can see why sync job ha failed by using kingbird keypair-sync status <job-id> which will return the details of the syncjob
08:54:38 <sorantis> +1
08:54:38 <goutham> has failed by using **
08:54:58 <goutham> multiple keypair sync as one single job
08:56:55 <joehuang> ok, it can be updated if we find some issue in the code
08:57:20 <goutham> yes..
08:57:31 <sorantis> running out of time
08:57:55 <goutham> ok then i will update status regularly then..
08:57:56 <joehuang> ok, discuss as needed offline
08:58:06 <goutham> via emails.
08:58:13 <joehuang> thank you attending the meeting
08:58:15 <goutham> bye all have a good day..
08:58:18 <joehuang> #endmeeting