#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 16:00:09 UTC (full logs).

Meeting summary

  1. Roll Call (fdegir, 16:00:14)
    1. Jack Morgan (jmorgan1, 16:01:12)
    2. Thaj (thaj, 16:01:22)
    3. Fatih Degirmenci (fdegir, 16:02:19)
    4. Chris Price (ChrisPriceAB, 16:02:31)
    5. GTM https://global.gotomeeting.com/join/819733085 (ChrisPriceAB, 16:03:38)
    6. Rudy (basic`, 16:03:55)

  2. Agenda Bashing (fdegir, 16:04:48)
    1. https://wiki.opnfv.org/display/INF/Infra+Working+Group (fdegir, 16:04:52)

  3. Handling INFRA JIRA Issues (fdegir, 16:05:14)
    1. fdegir proposes that Jira tickets should be closed if they are idle for a month or so (ChrisPriceAB, 16:07:23)
    2. the infra wg chair will take care of the infra Jira list during his/her tenure (ChrisPriceAB, 16:07:59)
    3. jackmorgan1 proposes a one week notice period should be provided to prompt action (ChrisPriceAB, 16:08:33)
    4. AGREED: The infra WG chair will track Jira tasks and should notify prior to closing tickets before a one month idle timeout period (ChrisPriceAB, 16:09:05)

  4. Pharos Architecture/Spec Change Request Process (fdegir, 16:09:24)
    1. https://wiki.opnfv.org/display/INF/Pharos+Architecture+Change+Request+Process (fdegir, 16:10:37)
    2. Everyone is welcomed to provide comments to change request process (fdegir, 16:11:33)

  5. Handling access requests to OPNFV resources located in LF Lab (fdegir, 16:11:47)
    1. OPNFV has 5 PODs in LF Lab (fdegir, 16:12:00)
    2. https://wiki.opnfv.org/display/pharos/Lf+Lab#LfLab-OPNFVCommunityMemberswithAccesstoOPNFVLFLab (fdegir, 16:14:30)
    3. THe above list contains the opnfv community members with the access to resources (fdegir, 16:14:45)
    4. The access requests to resources located in LF Lab should be submitted to INFRA JIRA project (fdegir, 16:15:44)
    5. If the access request is needed for emergency fixes, Infra WG Chair has authority to approve the request (fdegir, 16:16:03)
    6. ACTION: basic` to update the list on https://wiki.opnfv.org/display/pharos/Lf+Lab#LfLab-OPNFVCommunityMemberswithAccesstoOPNFVLFLab (fdegir, 16:16:48)
    7. AGREED: LF Lab resources will be handled via INFRA JIRA Project (fdegir, 16:17:05)

  6. Issues with huawei-pod1 (fdegir, 16:17:15)
    1. gsutil has been removed on huawei-pod1 jumphost without any advance notice (fdegir, 16:19:24)
    2. It is important to keep CI PODs in known state so the CI is not disturbed by changes done to jumphosts for example (fdegir, 16:22:09)
    3. This will become even more important when we move into dynamic POD allocation (fdegir, 16:24:15)
    4. An idea could be to move installers into VMs on jumphosts but this might not be possible for all the installers (fdegir, 16:25:09)
    5. Another idea is (re)provisioning jumphosts before each run (fdegir, 16:25:26)
    6. ACTION: bryan_att to check the possibility of moving JOID into a VM (fdegir, 16:26:43)
    7. ACTION: fdegir to check what Compass is doing (do they use VMs) (fdegir, 16:27:03)
    8. ACTION: jmorgan1 to check what Daisy is doing (do they use VMs) (fdegir, 16:27:22)

  7. OPNFV Cloud (fdegir, 16:27:45)
    1. General discussion regarding the possibility of providing an OPNFV Baremetal Deployment to ODL for provisioning VMs to use for ODL CI. (fdegir, 16:31:21)
    2. We will discuss this more coming weeks (fdegir, 16:33:36)

  8. Action Item Review (fdegir, 16:34:30)
    1. ACTION: jmorgan1 Follow up with JOID project on hardware resources request for Europe or North American based POD (fdegir, 16:34:58)
    2. ACTION: Documenting OPNFV Infra like how OpenStack does on ReadTheDocs (fdegir, 16:36:03)
    3. ACTION: jmorgan1 fdegir uli-k Present OPNFV Infra Roadmap to Dynamic CI (fdegir, 16:36:50)
    4. ACTION: jmorgan1 Julien Provide an example for POD descriptor file from ZTE labs (fdegir, 16:37:39)

  9. AOB (fdegir, 16:38:25)
    1. jmorgan1 talks about POD descriptor file and storing them in securedlab repo (fdegir, 16:38:48)
    2. Lab owners get access to securedlab by asking to become pharos-contributor (fdegir, 16:41:08)
    3. Lab owners create jenkins users for their labs and ask to get permissions for this user for securedlab repo (fdegir, 16:41:45)
    4. jmorgan1 will present a tool which is similar to Ironic (fdegir, 16:42:23)
    5. Intel will open source the tool (fdegir, 16:42:28)
    6. Moving installers to VMs can be a topic for plugfest/hackfest (fdegir, 16:45:07)
    7. ACTION: fdegir to create page for plugfest/hackfest planning (fdegir, 16:45:24)


Meeting ended at 16:46:17 UTC (full logs).

Action items

  1. basic` to update the list on https://wiki.opnfv.org/display/pharos/Lf+Lab#LfLab-OPNFVCommunityMemberswithAccesstoOPNFVLFLab
  2. bryan_att to check the possibility of moving JOID into a VM
  3. fdegir to check what Compass is doing (do they use VMs)
  4. jmorgan1 to check what Daisy is doing (do they use VMs)
  5. jmorgan1 Follow up with JOID project on hardware resources request for Europe or North American based POD
  6. Documenting OPNFV Infra like how OpenStack does on ReadTheDocs
  7. jmorgan1 fdegir uli-k Present OPNFV Infra Roadmap to Dynamic CI
  8. jmorgan1 Julien Provide an example for POD descriptor file from ZTE labs
  9. fdegir to create page for plugfest/hackfest planning


Action items, by person

  1. fdegir
    1. fdegir to check what Compass is doing (do they use VMs)
    2. jmorgan1 fdegir uli-k Present OPNFV Infra Roadmap to Dynamic CI
    3. fdegir to create page for plugfest/hackfest planning
  2. jmorgan1
    1. jmorgan1 to check what Daisy is doing (do they use VMs)
    2. jmorgan1 Follow up with JOID project on hardware resources request for Europe or North American based POD
    3. jmorgan1 fdegir uli-k Present OPNFV Infra Roadmap to Dynamic CI
    4. jmorgan1 Julien Provide an example for POD descriptor file from ZTE labs
  3. UNASSIGNED
    1. basic` to update the list on https://wiki.opnfv.org/display/pharos/Lf+Lab#LfLab-OPNFVCommunityMemberswithAccesstoOPNFVLFLab
    2. bryan_att to check the possibility of moving JOID into a VM
    3. Documenting OPNFV Infra like how OpenStack does on ReadTheDocs


People present (lines said)

  1. fdegir (46)
  2. ChrisPriceAB (7)
  3. collabot` (4)
  4. basic` (2)
  5. thaj (2)
  6. jmorgan1 (2)
  7. jose_lausuch (1)


Generated by MeetBot 0.1.4.