#opnfv-meeting: TC Technical Discussion

Meeting started by uli-k at 13:04:21 UTC (full logs).

Meeting summary

    1. Gotomeeting is up: 819-733-085 (uli-k, 13:05:17)
    2. rprakash (rprakash, 13:06:36)

  1. Multi-Access-Edge project (uli-k, 13:06:54)
    1. bryan_att introduces the project (uli-k, 13:07:17)
    2. Thaj (thaj, 13:07:44)
    3. The project is an update of the former CORD proposal (uli-k, 13:09:22)
    4. https://wiki.opnfv.org/display/PROJ/Multi-Access+Edge (dneary, 13:09:29)
    5. (Bryan) as has included several VNFs to use to test the access hardware for sveral edge deployment use cases (rprakash, 13:14:06)
    6. all this will be in lab and more labs to support diffrenet hardware to access OPNFV referrence platform (rprakash, 13:16:42)
    7. project intends to have hardwrae available for the summit (uli-k, 13:16:49)
    8. AT&T and Ericsson have signed up for participation (rprakash, 13:17:43)
    9. (Uli) is asking how will POD be described for new hardware for deployment scenario (rprakash, 13:18:25)
    10. (Bryan) will add descriptor to support extenions (rprakash, 13:20:28)
    11. (Bryan) eg, to add blueprint for residential access deployment will have all elements needed and saple VNFs to test the access to OPNFV platform (rprakash, 13:22:22)
    12. (Bryan) leverage CORD in a box and some of this which can meet 80% of functionality (rprakash, 13:25:21)
    13. (Radez) collaboration of producing VNF from Samplevnf and hardware are synergistic both have different goals with some overlaps (rprakash, 13:27:50)
    14. (Bryn) vnf will not be intended for commercial use and at the same time not limit them (rprakash, 13:29:30)
    15. (uli) all upstream projects mentioned like M-CORD, R-CORD, E-CORD will have Open osurces to use (rprakash, 13:31:43)
    16. (Bryan) More Hardware Vendors will be added as they join (rprakash, 13:34:12)
    17. (Uli) mentions pros and cons of MANO depedency on VNF packaging and oboardin (rprakash, 13:36:17)
    18. (Bryan) has added relation between MANO and VNF plus hardware through Blueprints in the project (rprakash, 13:37:42)
    19. (Bryan) VNFS and access hardware are not part of the release platform, may be some tweaks to Pharos documents, similarly to FUNCTEST, Performance, Dovetail and other OPNFV documentation (rprakash, 13:40:06)
    20. AGREED: The proposal can go to TSC creation review (uli-k, 13:42:23)

  2. Dovetail update (uli-k, 13:42:53)
    1. the dovetail testsuite document is now available in gerrit (uli-k, 13:44:20)
    2. thus the review can be done via gerrit. (uli-k, 13:44:51)
    3. Wenjing describes the process how to agree on testcases (uli-k, 13:46:07)
    4. bryan_att asks for examples (uli-k, 13:47:08)
    5. example https://wiki.opnfv.org/display/sdnvpn/SDNVPN+Testing#SDNVPNTesting-TestcompliancetemplateforDovetail 139 (Wenjing, 13:47:11)
    6. bryan_att suggests to use the test db (uli-k, 13:47:57)
    7. (Bryan) Do it right Do it once and to add structured and unstructured elements and populate some in test db rest in documents (rprakash, 13:49:45)
    8. https://gerrit.opnfv.org/gerrit/#/c/33317/ (Wenjing, 13:51:38)
    9. (wenjing/Bryan) both suggest and agree to keep header elements in test db and detailes in external document links (rprakash, 13:52:37)
    10. bryan_att suggests that dependencies are clearly documented (not just hidden in plain text) (uli-k, 13:53:28)
    11. Wenjing points out that this needs to be done by the tests (uli-k, 13:54:33)
    12. expmple page shown is SDN/VPN proejct main page (rprakash, 13:54:47)
    13. https://wiki.opnfv.org/display/sdnvpn/SDNVPN+Testing (rprakash, 13:54:53)
    14. (Bryan) As we approach testing more need to have some numbering sequence (rprakash, 13:55:39)
    15. (wenjing) the templates for test will be filled by projects and brough to Dovetail to just validate before bringing to Tech weekly meeting for review (rprakash, 13:57:37)
    16. (Uli) it is difficult to get time to validate due to lack of time (rprakash, 13:58:29)
    17. Wenjing will send this to the mailing list (uli-k, 13:59:40)
    18. (wenjing) That's the reason to follow the existing process of like project proposal approval for Test validation for Dovetail for Test cases froom Projects (rprakash, 13:59:58)

  3. AoB (uli-k, 14:00:28)
    1. next week discuss new proposal by Frank (uli-k, 14:00:43)
    2. ACTION: (winjing) to circulate details of test case validation to tech list/tsc etc (rprakash, 14:00:49)


Meeting ended at 14:01:07 UTC (full logs).

Action items

  1. (winjing) to circulate details of test case validation to tech list/tsc etc


People present (lines said)

  1. rprakash (26)
  2. uli-k (23)
  3. collabot (6)
  4. dneary (4)
  5. Wenjing (2)
  6. thaj (1)
  7. bryan_att (0)


Generated by MeetBot 0.1.4.