#opnfv-meeting: 2017 OPNFV orientation

Meeting started by rpaik at 05:16:18 UTC (full logs).

Meeting summary

    1. Dave Urschatz (CENGN) (durschatz, 05:16:22)
    2. Rick Penwarden (CENGN) (durschatz, 05:16:43)
    3. Ray Paik (rpaik, 05:16:44)
    4. primary channel is "opnfv-meeting" (dmcbride, 05:17:40)
    5. other channels dedicated to specific OPNFV projects (dmcbride, 05:17:58)
    6. there is also a dedicated channel for release meetings - "opnfv-release" (dmcbride, 05:18:52)
    7. webchat.freenode.net (bramwelt, 05:20:25)

  1. What is OPNFV? (dmcbride, 05:20:38)
    1. the idea of Network Function Virtualization (NFV) has been around for a while (dmcbride, 05:22:14)
    2. a lof of the work has been done in standards bodies, such as ETSI (dmcbride, 05:22:37)
    3. standards are great, but the industry needs an implementation (dmcbride, 05:23:04)
    4. many components have been developed in disparate Open Source projects (e.g. SDN, DPDK, VIM, etc.) (dmcbride, 05:24:48)
    5. we need something to pull all of these separate projects together. Thus OPNFV (dmcbride, 05:25:26)
    6. Three major principles: Integration, Testing, "Upstream First" (dmcbride, 05:26:05)
    7. Lots of upcoming co-located events happening in next couple of weeks with upstream projects (bramwelt, 05:26:42)

  2. Danube Overview (dmcbride, 05:30:57)
    1. 7 - 10 test projects (dmcbride, 05:31:17)
    2. many telco oriented projects, such as Service Function Chaining (SFC) (dmcbride, 05:31:52)

  3. release history (dmcbride, 05:32:21)
    1. Arno: June 4, 2015; Brahmaputra: March 1, 2016; Colorado: September 26, 2016; Danube: April 4, 2017 (bramwelt, 05:33:12)
    2. releases are named after rivers in alphabetical order, switching continents after each release (dmcbride, 05:33:15)
    3. recent releases have included about 40 projects, each (dmcbride, 05:35:32)

  4. Cross-community CI (XCI) (dmcbride, 05:38:16)
    1. sessions on XCI this week at the Summit. See the schedule. (dmcbride, 05:41:27)

  5. Testing (dmcbride, 05:41:33)
    1. Testing WG formed to collaborate on testing issues and create a testapi as a unified reporting interface (bramwelt, 05:44:02)
    2. there will be a panel on Monday that includes all of the test projects (see Summit schedule) (dmcbride, 05:44:13)
    3. http://testresults.opnfv.org/reporting/ (bramwelt, 05:44:28)
    4. there will also be several sessions on individual test projects (dmcbride, 05:44:43)
    5. testresults help provide insight to the release manager on scenario status (bramwelt, 05:46:25)

  6. Pharos Test Labs (dmcbride, 05:46:45)
    1. https://wiki.opnfv.org/display/pharos/Community+Labs (bramwelt, 05:49:03)
    2. more than 70 Pharos pods used for the Danube release (dmcbride, 05:50:53)
    3. Over 7 thousand deployments of OpenStack during the Danube release (bramwelt, 05:51:35)

  7. OPNFV members (dmcbride, 05:53:41)
  8. OPNFV projects (dmcbride, 05:54:14)
    1. each project has a wiki page at wiki.opnfv.org that provides relevant informatin for the project (dmcbride, 05:58:21)

  9. creating a new OPNFV project (dmcbride, 06:01:02)
    1. step 1 - create a proposal and allow for a 2 week review period (dmcbride, 06:01:53)
    2. step 2 - TSC review and vote (simple majority) (dmcbride, 06:02:25)

  10. OPNFV project lifecycle (dmcbride, 06:02:41)
    1. phases: proposal, incubation, mature, archived (dmcbride, 06:03:01)
    2. currently too many projects are in "incubation" stage. Attention to this issue has resulted in projects moving through graduation review (e.g. Functest) (dmcbride, 06:05:29)

  11. OPNFV community (dmcbride, 06:06:21)
    1. OPNFV is fortunate to have an active, engaged community (dmcbride, 06:06:53)
    2. the OPNFV Code of Conduct is a reflection of the community (dmcbride, 06:07:24)
    3. the CoC was generated from the bottom up, based on experience from early releases (dmcbride, 06:08:41)
    4. OPNFV is a worldwide community. It's important to remember English is not everyone's primary language and we should always give people the benefit of the daught. (bramwelt, 06:14:42)
    5. don't be embarassed about your typing skills. Ray typos messages all the time on IRC. (bramwelt, 06:16:36)

  12. meetings (dmcbride, 06:16:49)
    1. https://wiki.opnfv.org/display/meetings (dmcbride, 06:16:55)
    2. Several tools for meetings: IRC, GoToMeeting, Mailman, Etherpad (bramwelt, 06:18:01)

  13. Community Events (bramwelt, 06:18:17)
    1. https://wiki.opnfv.org/display/EVNT (dmcbride, 06:18:32)
    2. twice a year plugfest where the community works on interoperability (bramwelt, 06:19:00)
    3. hackfest co-located with plugfests (bramwelt, 06:19:10)
    4. both hackfest and plugfest are free (bramwelt, 06:19:33)

  14. Community Dashboard (bramwelt, 06:20:21)
    1. https://opnfv.biterg.io/ (bramwelt, 06:20:33)
    2. provides visibility into community contributions (bramwelt, 06:20:58)
    3. Contributions aren't restricted to code. Dashboard shows IRC, mailinglist, wiki, etc. (bramwelt, 06:22:38)

  15. Internship Program (bramwelt, 06:22:48)
    1. Lot of interesting internship projects happening in OPNFV (bramwelt, 06:23:49)

  16. OPNFV release process (rpaik, 06:25:53)
    1. dmcbride notes that in addition to major release (every 6 month) we have two minor/maintenance releases (rpaik, 06:28:18)
    2. OPNFV scenarios compose of installers, set of components, and a configuration (rpaik, 06:32:12)
    3. dmcbride walks through milestones for OPNFV release (rpaik, 06:33:04)

  17. Release Process Milestones (bramwelt, 06:38:45)
    1. Milestone 3 splitting into 3 phases (bramwelt, 06:39:57)
    2. Milestone 4 redefined around test frameworks being ready to support feature development (bramwelt, 06:42:22)
    3. Milestone 5 feature projects completed scenarios integations (bramwelt, 06:42:58)
    4. dmcbride walks through milestones 6-11, where 11 being the release (bramwelt, 06:44:45)
    5. there's also a new milestone exception process starting with Euphrates (rpaik, 06:46:51)

  18. OPNFV Marketing and PR Programs (bramwelt, 06:50:12)
    1. Brandon Wick and Jill Lovato introduce themselves to the community (rpaik, 06:52:56)
    2. Brandon gives an overview of the upcoming presentation (bramwelt, 06:53:51)
    3. They discuss the challenges of marketing/PR for an open source project (bramwelt, 06:54:58)
    4. Developers are the key demographics for marketing in open source community (rpaik, 06:55:34)
    5. Marking shouldn't be 'fluffy'. We should be telling the stories of OPNFV (bramwelt, 06:57:50)
    6. Role of marking is to rise above the noise (1MM+ github projects) and secure attention (bramwelt, 07:00:28)
    7. They explain the ways they do marketing/PR for OPNFV (bramwelt, 07:09:49)
    8. They explain ways the community can get involved: subscribe to marketing channels, getting involved, interfacing with ambassadors, joining meetups (bramwelt, 07:15:12)
    9. https://www.opnfv.org/community/user-groups OPNFV meetup group page (rpaik, 07:16:32)
    10. VOTE: Voted on "should we take a 15-minute break?" Results are, +1: 5 (rpaik, 07:23:48)
    11. ACTION: Brandon/Jill to post the marketing slides on the orientation wiki page (rpaik, 07:36:44)

  19. Developer tools in OPNFV (rpaik, 07:47:21)
    1. bramwelt walks through developers tools in OPNFV (e.g. git/gerritt/Jenkins/Jira/etc.) (rpaik, 07:48:19)
    2. hands-on/demonstration of tools such as Etherpad, wiki, etc. (rpaik, 08:01:49)
    3. https://lists.opnfv.org/mailman/listinfo list of OPNFV mailing lists (rpaik, 08:03:34)
    4. ACTION: bramwelt to add info/instructions on LFID in the OPNFV wiki home page (rpaik, 08:20:00)
    5. https://etherpad.opnfv.org/p/demo for those following along (basic`, 08:35:39)


Meeting ended at 08:50:56 UTC (full logs).

Action items

  1. Brandon/Jill to post the marketing slides on the orientation wiki page
  2. bramwelt to add info/instructions on LFID in the OPNFV wiki home page


Action items, by person

  1. bramwelt
    1. bramwelt to add info/instructions on LFID in the OPNFV wiki home page


People present (lines said)

  1. dmcbride (42)
  2. bramwelt (39)
  3. rpaik (24)
  4. collabot (13)
  5. durschatz (3)
  6. basic` (2)
  7. donaldh (1)


Generated by MeetBot 0.1.4.