15:00:16 <lhinds> #startmeeting Infra-WG
15:00:16 <collabot> Meeting started Mon Jul 24 15:00:16 2017 UTC.  The chair is lhinds. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:16 <collabot> The meeting name has been set to 'infra_wg'
15:00:25 <uli-k> #info Uli
15:00:43 <bramwelt> #info Trevor Bramwell
15:00:54 <aricg-> #info Aric Gardner
15:01:00 <tykeal> #info Andrew Grimberg
15:01:04 <rpaik> #info Ray Paik
15:01:24 <jose_lausuch> #info Jose Lausuch
15:01:51 <lhinds> #topic Agenda
15:02:12 <lhinds> #info jira demo to earlier slot in agenda
15:02:25 <lhinds> #topic Jira Demo
15:04:11 <lhinds> #info Brandi gave slides with an overview
15:04:18 <lhinds> #unfo
15:04:20 <lhinds> #undo
15:04:20 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x33d8250>
15:04:26 <lhinds> #info Brandy gave slides with an overview
15:06:36 <lhinds> #undo
15:06:36 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2f05e10>
15:07:41 <lhinds> #info Jira Demo: Brandy Hartley gave an overview with slides and Andrew Grimberg provided a demo
15:08:16 <lhinds> #info rpaik to post to the wiki (slides of jira proposal)
15:10:57 <mbeierl> #info Mark Beierl (IRC only)
15:22:48 <lhinds> #info Andrew Grimberg will make a recorded version of the jira demo
15:24:16 <jose_lausuch> mbeierl: ping
15:24:26 <lhinds> #topic Docker Multi Images per Project
15:24:40 <lhinds> #info docker hub to build docker images
15:24:53 <lhinds> #info jose_lausuch hub may not be best approach
15:25:05 <mbeierl> jose_lausuch: pong  - IRC only :(
15:25:42 <lhinds> #info arch64 dockerfiles are another limitation
15:26:18 <lhinds> #info jose_lausuch recommends we abandon idea, for those that still wish to use, a free account can be made and LF releng can trigger build
15:27:50 <aricg-> #info https://gerrit.opnfv.org/gerrit/#/c/37285/
15:28:18 <aricg-> This is my patch that follows fdegir's recommendation
15:28:44 <lhinds> #info jose_lausuch : Dockerfile should be in project repo, agreement?
15:30:01 <mbeierl> #info +1 on OPNFV hosted build
15:31:48 <jose_lausuch> mbeierl: what do you mean by opnfv hosted build?
15:31:59 <rpaik> btw, the Jira sync presentation is now posted on the wiki at https://wiki.opnfv.org/download/attachments/6819987/OPFNV%20Jira%20Sync%20proposals.pdf?version=1&modificationDate=1500910273768&api=v2
15:32:02 <mbeierl> jose_lausuch: part of releng, not on docker hub
15:32:16 <lhinds> rpaik: please hash info that link
15:32:40 <jose_lausuch> mbeierl: ok, but now we are discussing about where to store the build scripts
15:32:45 <jose_lausuch> project repos or releng?
15:32:51 <rpaik> #info https://wiki.opnfv.org/download/attachments/6819987/OPFNV%20Jira%20Sync%20proposals.pdf?version=1&modificationDate=1500910273768&api=v2 Jira sync proposals
15:33:21 <mbeierl> jose_lausuch: not in GTM, so I was just replying to lhinds comment
15:33:56 <mbeierl> jose_lausuch: I prefer that the creation of ENV VARs, etc, is all done through releng, but the actual dockerfile has to be in the project repo
15:34:12 <mbeierl> otherwise, I cannot do a local, developer docker run
15:35:41 <jose_lausuch> https://git.opnfv.org/functest/tree/build.sh
15:36:29 <mbeierl> jose_lausuch: how is that called?  The docker hub credentials need to be present in order for the push to happen.  Is that part of releng, or where do the credentials get injected?
15:37:01 <mbeierl> also, what about tags for releases?  How does that happen?
15:37:07 <mbeierl> or is that a different script?
15:38:32 <lhinds> #info tbramwell, move forward with both
15:42:23 <lhinds> #action aricg- will work with mbeierl to allow multiple Dockerbuilds in related scripts.
15:42:47 <lhinds> #topic LaaS
15:44:42 <jose_lausuch> mbeierl: the arg/tags for releases should be part of releng
15:44:55 <jose_lausuch> mbeierl: we agreed that we can keep both mechanisms, generic build scripts in releng for docker builds
15:45:05 <jose_lausuch> mbeierl: and project specific scripts for those who need it
15:45:16 <mbeierl> jose_lausuch: sure, but how do project specific build tags happen?
15:47:19 <lhinds> #topic LaaS
15:47:23 <lhinds> #link https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-July/017128.html
15:48:50 <lhinds> #topic ONAP and OPNFV Lab Sharing
15:48:57 <bryan_att> #link resources for ONAP deploy https://www.irccloud.com/pastebin/CY5ZPVPv/
15:49:35 <lhinds> #topic Feedback on splitting up releng repository
15:49:53 <lhinds> #action tbramwell will send something out to tech-discuss
15:50:08 <lhinds> #topic dev pod data support
15:50:45 <lhinds> #inf durschatz opened jira ticket for jose_lausuch
15:52:27 <lhinds> #info resourced needed to implement
15:52:33 <lhinds> #undo
15:52:33 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x34b5690>
15:52:36 <lhinds> #info resource needed to implement
15:54:39 <lhinds> #info jose_lausuch short term will introduce intern Max
15:57:18 <lhinds> #info gabriel_yuyang requested help from infra group; https://jira.opnfv.org/browse/INFRA-154?src=confmacro - one pod needed
15:58:26 <lhinds> #action aricg- to look at the ticket
15:58:31 <lhinds> #topic what is the time frame?
15:58:46 <lhinds> #info gabriel_yuyang before E release.
15:59:18 <lhinds> #info gabriel_yuyang which installers want to test (discussion)?
16:00:47 <lhinds> #endmeeting