16:00:54 <fdegir> #startmeeting Infra WG Weekly Meeting
16:00:54 <collabot> Meeting started Mon Dec 11 16:00:54 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:54 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:54 <collabot> The meeting name has been set to 'infra_wg_weekly_meeting'
16:01:59 <fdegir> #topic Rollcall
16:02:11 <jmorgan1> #info Jack Morgan
16:02:18 <bramwelt> #info Trevor Bramwell
16:03:39 <fdegir> #topic Committer list per repo
16:05:06 <jmorgan1> #link https://docs.openstack.org/infra/system-config/project.html#teams
16:05:08 <fdegir> #info The proposal has been sent to opnfv-tech-discuss mailing list as well
16:06:32 <fdegir> #topic Meetings coming weeks
16:07:13 <fdegir> #info Upcoming Infra WG Meetings on December 18th, 25th, January 1st
16:07:48 <fdegir> #info December 25th and January 1st meetings will be cancelled
16:07:57 <fdegir> #info December 18th meeting will be held
16:09:10 <fdegir> #action fdegir to check with lhinds regarding Infra WG Meeting chair
16:09:28 <fdegir> #action fdegir to remind the next chair regarding going back to original start time, 15:00UTC
16:09:47 <fdegir> #topic Follow up decisions from Plugfest
16:10:09 <fdegir> #info jmorgan1 to send an email about plugfest discussions regarding PDF
16:10:19 <fdegir> #info The template to use is the one in pharos repo
16:10:38 <fdegir> #info Network configuration details will be moved to IDF and work with IDF will continue
16:10:57 <fdegir> #info PDF version number needs to be added
16:11:38 <fdegir> #undo
16:11:38 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2aea350>
16:13:03 <fdegir> #info Version number will be added to PDF template and this will be inherited into PDFs for the PODs
16:13:51 <fdegir> #info The proposed version is 2 digit versioning; x.y
16:15:00 <fdegir> #info IDF and SDF need similar versioning and they need to match to each other
16:19:48 <fdegir> #action bramwelt to create repo and start working on it
16:22:38 <fdegir> #info Other things to remember are configuring gsutil and docker credentials
16:23:38 <fdegir> #action jmorgan1 to pass the names of the slaves connected from Intel lab for removal
16:26:07 <fdegir> #agree Automatically remove Jenkins slaves that have been offline for 6 months or more
16:26:32 <fdegir> #undo
16:26:32 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2e44550>
16:26:57 <fdegir> #agree Automatically remove Jenkins slaves that have been offline for 4 months or more
16:27:03 <fdegir> #action aricg to remove the slaves offline for 4 months or more
16:28:39 <fdegir> #topic Release Automation
16:28:55 <fdegir> #link https://etherpad.opnfv.org/p/release-automation
16:29:33 <fdegir> #link https://github.com/openstack/releases/tree/master/deliverables
16:33:57 <fdegir> #link https://github.com/openstack/releases
16:36:29 <fdegir> #info Create a release repo and 1 folder per release and 1 yaml file per project under release folder
16:38:26 <fdegir> #info It would be beneficial to look at the schema used by OpenStack Release Team and come with a proposal
16:39:02 <fdegir> #info releng/releases/fraser/<project>.yaml
16:40:40 <fdegir> #action dmcbride to look at the schema used by OpenStack and come up with a simplified proposal for OPNFV
16:40:57 <fdegir> #info Euphrates can be sample project to try the schema out
16:41:00 <fdegir> #undo
16:41:00 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ee0690>
16:41:04 <fdegir> #info Euphrates can be sample release to try the schema out
16:41:39 <fdegir> #topic Action Item Review
16:42:46 <fdegir> #info OPEN: Follow up the use of #lf-releng and send notification to opnfv-tech-discuss
16:43:46 <aricg> https://epir.at/2016/06/26/redirecting-freenode-channels/
16:44:45 <fdegir> #action bramwelt to talk to zxiiro about redirection details
16:45:04 <fdegir> #info OPEN: Investigate configuring the default path for Jenkins consistently/globally
16:45:43 <fdegir> #info OPEN: Propose new committers for Pharos for review - ai moved to jmorgan1
16:47:04 <fdegir> #info OPEN: Clean-up none-active pharos committer
16:48:36 <fdegir> #action jmorgan1 to talk to BII for moving lab/pod config to pharos
16:49:19 <fdegir> #info OPEN: Think about how to automate build server/vPOD configuration
16:50:17 <fdegir> #action dmcbride to start conversation around defining the test requirements for gating scenarios for the release
16:50:47 <fdegir> #info OPEN: Decide how to handle Pharos/HW Infra documentation
16:50:55 <fdegir> #info OPEN: Move SDF from Octopus to Pharos repo
16:51:34 <fdegir> #info OPEN: Review the no of PODs installers have - aghenda item for the next meetint
16:51:45 <bramwelt> #link https://gerrit.opnfv.org/gerrit/#/c/48287/
16:51:52 <fdegir> #info OPEN : Update documents on CI POD requirements ^
16:52:54 <fdegir> #info DONE: schedule a Plugfest discussion on logging facilities
16:53:16 <zxiiro> fdegir: I plan on re-igniting that discussion in the new year.
16:53:23 <fdegir> #info bramwelt will follow this up in mailing list
16:53:25 <zxiiro> re: freenode redirecting of channels.
16:53:27 <fdegir> zxiiro: thanks
16:53:43 <aricg> zxiiro: we want our gerrit bot.. :(
16:53:56 <aricg> new patchsets/
16:54:31 <aricg> probably ten per day avg
16:54:53 <fdegir> #info The conversation around Pharos spec refresh will continue during new year
16:55:35 <zxiiro> We'll probably need 2 channels  then one for discussion and one for bots (or the existing one can continue to exist and just inform humans to use the lf-releng one for questions).
16:55:47 <fdegir> #info Pharos spec refresh will be discussed during the Infra WG meeting
16:58:20 <fdegir> #endmeeting