#opnfv-meeting: Infra WG Meeting

Meeting started by fdegir at 16:02:53 UTC (full logs).

Meeting summary

    1. Joe Kidder (joekidder, 16:04:15)
    2. Aric Gardner (aricg, 16:04:16)
    3. David McBride (dmcbride, 16:04:30)
    4. Fatih Degirmenci (fdegir, 16:04:31)
    5. Tianwei Wu (hw_wutianwei, 16:04:45)
    6. Agenda - https://wiki.opnfv.org/display/INF/Infra+Working+Group (jmorgan1, 16:04:56)
    7. David spoke with OpenStack Release project about topic - they use CI to judge if something needs to be release or not (jmorgan1, 16:09:13)
    8. In order for basic promotion to work, we must ensure when we test scenarios, we only change the scenario (fdegir, 16:10:54)
    9. Meaning that everything else should be frozen; test fw/cases, infra, etc (fdegir, 16:11:10)
    10. Apart from this, we need a way to find out which scenario is impacted by certain change in order to run test that scenario (fdegir, 16:11:31)
    11. CI Evolution was proposed/approved long before XCI was even created (fdegir, 16:11:48)
    12. And due to us failing to make CI Evolution real, we started XCI to show that that's the way (fdegir, 16:12:15)
    13. A basic schemet could be (fdegir, 16:13:17)
    14. - patchset verification: healthcheck (fdegir, 16:13:30)
    15. - post merge: smoke (?) (fdegir, 16:13:41)
    16. - daily: functest + yardstick (fdegir, 16:13:49)
    17. - weekly: performance/stress/etc. (fdegir, 16:14:02)
    18. Each of these stages promoting scenarios to the next one or demoting (fdegir, 16:14:23)
    19. Test WG should come up with the scope for the test loops; what tests should be used where (fdegir, 16:15:11)
    20. Promotion is not only for scenarios; test projects should also have promotion to enable certain test cases that are used for testing scenarios (fdegir, 16:16:11)
    21. Pharos Spec etherpad - https://etherpad.opnfv.org/p/Pharos_Specification2.0 (jmorgan1, 16:19:10)
    22. Compass: https://build.opnfv.org/ci/label/compass-baremetal/ (fdegir, 16:23:37)
    23. Fuel: https://build.opnfv.org/ci/label/fuel-baremetal/ (fdegir, 16:23:47)
    24. Joid: https://build.opnfv.org/ci/label/joid-baremetal/ (fdegir, 16:23:56)
    25. Daisy: https://build.opnfv.org/ci/label/daisy-baremetal/ (fdegir, 16:24:05)
    26. Apex: https://build.opnfv.org/ci/label/apex-baremetal-master/ and https://build.opnfv.org/ci/label/apex-baremetal-euphrates/ (fdegir, 16:24:27)
    27. MCP/Fuel (fdegir, 16:25:00)
    28. Armband: https://build.opnfv.org/ci/label/armband-baremetal/ (bramwelt, 16:25:23)
    29. huawei-pod12 will connect jenkins this week (hw_wutianwei, 16:26:42)
    30. each installer has two CI POD except Compass which has three and Fuel which has two POD per arch (jmorgan1, 16:30:45)
    31. discussion on patch - https://gerrit.opnfv.org/gerrit/#/c/48755 (jmorgan1, 16:31:54)
    32. who owns making sure a CI POD is listed in the test DB? (jmorgan1, 16:34:09)
    33. once a resource is approved as CI project, adding the permission to push results to test DB should be done by Test WG (jmorgan1, 16:35:54)
    34. ACTION: bramwelt will work on documenting the process for future releases (jmorgan1, 16:36:47)
    35. INFRA-195 request for StorPerf POD - looking for baremetal POD (jmorgan1, 16:40:56)
    36. will look at this after the holidays to help StorPerf project find hardware resources (jmorgan1, 16:42:00)
    37. https://gerrit.opnfv.org/gerrit/#/c/48413/ (bramwelt, 16:43:27)
    38. ACTION: bramwelt to work with LF Releng to resolve this discussion (jmorgan1, 16:46:29)
    39. bramwelt suggests use Jenkins as the default (jmorgan1, 16:59:09)
    40. jmorgan1 thinks that if Jenkins is used then Jenkins needs to be better monitored for accuracy (jmorgan1, 17:00:31)
    41. Reminder that we won't be meeting next two weeks and next meeting is January 9th (jmorgan1, 17:02:03)
    42. Reminder that we won't be meeting next two weeks and next meeting is January 8th (jmorgan1, 17:02:35)


Meeting ended at 17:03:26 UTC (full logs).

Action items

  1. bramwelt will work on documenting the process for future releases
  2. bramwelt to work with LF Releng to resolve this discussion


Action items, by person

  1. bramwelt
    1. bramwelt will work on documenting the process for future releases
    2. bramwelt to work with LF Releng to resolve this discussion


People present (lines said)

  1. fdegir (37)
  2. jmorgan1 (26)
  3. collabot (3)
  4. dmcbride (3)
  5. aricg (2)
  6. bramwelt (2)
  7. hw_wutianwei (2)
  8. joekidder (1)


Generated by MeetBot 0.1.4.