#opnfv-meeting: barometer

Meeting started by mrunge at 17:04:22 UTC (full logs).

Meeting summary

  1. attendees (efoley, 17:05:49)
    1. efoley (efoley, 17:05:59)
    2. mrunge (mrunge, 17:06:06)
    3. Al Mortion (acmacm, 17:06:35)
    4. Pierre Lynch (acmacm, 17:06:55)
    5. Jabir (efoley, 17:07:18)

  2. FOSDEM (efoley, 17:08:08)
    1. efoley and kkepka attended fosdem and presented in the SDN devroom (efoley, 17:09:17)
    2. https://fosdem.org/2020/schedule/event/do_you_really_see_whats_happening_on_your_nfv_infra/ (efoley, 17:09:39)
    3. there were some questions about cloudifying collectd (efoley, 17:10:17)
    4. question: were there any volunteers to work on collectd? (efoley, 17:11:33)
    5. hopefully after the meet-up, when there is a roadmap (efoley, 17:12:23)

  3. Collectd CI (efoley, 17:12:40)
    1. kkepka shared a proposal for the CI (efoley, 17:13:29)
    2. this is a WIP and will be a working document to gather information and collaborate (efoley, 17:13:59)
    3. CI will should build collectd artifacts, open questions remain about where we will host the built packages (efoley, 17:15:40)
    4. statics analysis jobs are planned too (efoley, 17:15:56)
    5. This could include performance testing in the future (efoley, 17:16:25)
    6. Chat where you can join the discussion: https://docs.google.com/presentation/d/1eJT1iIviUxekuFyQMifsM0nqRxJzfN51H3agKCXSUHM (acmacm, 17:17:29)
    7. the presentation included an overview of current testing infra (efoley, 17:18:19)
    8. some other communities already run shared functional test in third party CIs, without the need for public infrastructure -- multiple CIs can run tests on private hardware and report to collectd github (efoley, 17:19:51)
    9. travis could be used for building packages and posting them to github, and to trigger nightly jobs (efoley, 17:21:25)
    10. some SUSE infra could be used too. (efoley, 17:21:47)
    11. Centralising the set of tests, and running a "standard" may require some trade-offs vs private CIs that are currently running tests (efoley, 17:24:07)
    12. there was a suggestion that we provide a place to host the logs from third party CIs; this would require some funding or dinated infra (efoley, 17:25:32)
    13. Discussion of LF CI/CD Evolution (In Prague) https://wiki.lfnetworking.org/pages/viewpage.action?spaceKey=~mbeierl&title=OPNFV+Prague+Highlight+Reel#OPNFVPragueHighlightReel-CI/CDEvolution(TrevorBramwell) (acmacm, 17:28:06)
    14. ACTION: sunkuranganath to look at criteria for joining LF (efoley, 17:39:34)
    15. ACTION: mrunge to look at criteria for joining apache foundation (efoley, 17:39:49)

  4. code review (efoley, 17:40:31)
    1. https://gerrit.opnfv.org/gerrit/#/c/barometer/+/69491/ (efoley, 17:40:36)
    2. patch looks okay, and the issue might be due to random CI failures (efoley, 17:43:14)
    3. patch is being rechecked (efoley, 17:43:28)
    4. ACTION: efoley to follow-up if it fails again (efoley, 17:43:38)

  5. AoB (efoley, 17:43:56)
    1. acm and sunkuranganath discuss how to collect vm stall metrics. (efoley, 17:46:41)
    2. ACTION: sunkuranganath to check how this can be gathered; possibly available from virt or pmu (efoley, 17:47:35)
    3. acm invites everyone to review the vsperf requested metrics list (efoley, 17:48:30)

  6. CFPs (efoley, 17:50:51)
    1. CFP is closed for ONES NA (efoley, 17:51:16)
    2. CFP is open for open source summit NA (efoley, 17:51:40)
    3. https://events.linuxfoundation.org/open-source-summit-north-america/ (mrunge, 17:52:11)
    4. plynch submitted to ONES on MANO testing work (efoley, 17:52:22)
    5. https://events.linuxfoundation.org/open-source-summit-north-america/ (efoley, 17:52:47)
    6. https://events.linuxfoundation.org/open-source-summit-europe/ (mrunge, 17:53:17)
    7. https://events.linuxfoundation.org/open-source-summit-europe/program/cfp/ (mrunge, 17:53:32)
    8. open source summit is in Dublin this year (efoley, 17:53:46)
    9. https://events.linuxfoundation.org/open-source-summit-europe/ (efoley, 17:53:59)
    10. https://events.linuxfoundation.org/open-source-summit-europe/program/cfp/ (efoley, 17:54:08)
    11. sunkuranganath had a CFP for ONES which can be resubmitted for OSS NA (efoley, 17:55:55)

  7. iruya release (efoley, 17:58:25)
    1. ACTION: efoley to check on release status (efoley, 17:58:34)
    2. ACTION: efoley check on plans for point releases (efoley, 17:58:50)


Meeting ended at 18:02:03 UTC (full logs).

Action items

  1. sunkuranganath to look at criteria for joining LF
  2. mrunge to look at criteria for joining apache foundation
  3. efoley to follow-up if it fails again
  4. sunkuranganath to check how this can be gathered; possibly available from virt or pmu
  5. efoley to check on release status
  6. efoley check on plans for point releases


Action items, by person

  1. efoley
    1. efoley to follow-up if it fails again
    2. efoley to check on release status
    3. efoley check on plans for point releases
  2. mrunge
    1. mrunge to look at criteria for joining apache foundation
  3. sunkuranganath
    1. sunkuranganath to look at criteria for joining LF
    2. sunkuranganath to check how this can be gathered; possibly available from virt or pmu


People present (lines said)

  1. efoley (45)
  2. mrunge (8)
  3. collabot` (6)
  4. acmacm (4)
  5. sunkuranganath (1)
  6. kkepka (0)


Generated by MeetBot 0.1.4.