#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (March 7th 2016)

Meeting started by mdgray at 13:01:14 UTC (full logs).

Meeting summary

  1. Roll Call (mdgray, 13:01:21)
    1. Mark Gray (mdgray, 13:01:24)
    2. Billy O'Mahony (billyoma, 13:01:39)
    3. Simona Coppola (Simona_, 13:01:48)

  2. Agenda (mdgray, 13:05:14)
    1. https://etherpad.opnfv.org/p/ovsnfv-meet (mdgray, 13:05:16)

  3. C-Release Planning (mdgray, 13:06:20)
    1. Draft C-Release backlog is on Wiki (mdgray, 13:08:43)
    2. Simona will send out an e-mail with the details (mdgray, 13:10:08)
    3. ACTION: Everyone: Review the backlog to give any feedback. (mdgray, 13:10:51)
    4. ACTION: Tom: Update the Apex feature list with key backlog items and to fix any mistakes. (mdgray, 13:11:21)
    5. Tom Herbert (tfherbert, 13:12:40)
    6. Release C milestone 1 is tomorrow (mdgray, 13:15:48)
    7. Simona will drive this with feedback from committers (mdgray, 13:16:23)
    8. .. and contributers (mdgray, 13:17:34)
    9. Debra Scott has left Linux Foundation and OPNFV - may change a few things around release planning. (mdgray, 13:18:14)

  4. Priority Path through OVS based on Requirements (Lead: Al Morton - 45 minutes) (mdgray, 13:18:39)
    1. sorry to see Debra go. (tfherbert, 13:18:41)
    2. Al presenting slides. Mark will put them up on the wiki. (mdgray, 13:20:01)
    3. https://wiki.opnfv.org/_media/qos_mechanisms.pdf (mdgray, 13:26:46)
    4. Al is outlining the current standards related to QoS (mdgray, 13:27:29)
    5. This highlights the need for QoS (mdgray, 13:27:48)
    6. Many of the requirements are for service quality i.e. end-to-end (mdgray, 13:28:31)
    7. The eventual allocation to a virtual switch would depend on other equipment in the path, speed of light, etc (mdgray, 13:30:09)
    8. Two class prioritization should make sense initially (mdgray, 13:38:21)
    9. Initial implementation should focus on this. (mdgray, 13:39:03)
    10. Further work could expand on this (mdgray, 13:39:18)
    11. We can assume that traffic is already marked (mdgray, 13:40:23)
    12. We need flexibility as to which field in the packet contains the priority information (mdgray, 13:41:31)
    13. This could be programmed in a protocol oblivious way (mdgray, 13:42:50)
    14. Need to map this to a priority as handled by the switch (mdgray, 13:43:30)
    15. Tom noted that other vswitches have this type of functionality (mdgray, 13:47:06)
    16. OVS architecture will make this tricky (mdgray, 13:49:25)
    17. Al has outlined some observations previously made (mdgray, 13:49:37)
    18. Is OpenFlow control required? (mdgray, 13:54:40)
    19. Perhaps we should do a smaller prototype first? (mdgray, 13:54:56)
    20. Similar control interface in OpenFlow for Packet_In messages (mdgray, 13:57:28)
    21. Plan to follow up on this discussion at Hackfest (look for Al, Billy and Tom having heated discussion in front of a whiteboard!) (mdgray, 14:00:53)
    22. This needs to be formally documented. If no one else volunteers, Mark can do this. (mdgray, 14:01:56)
    23. Need vsperf tests to show the benefit of this (mdgray, 14:02:13)


Meeting ended at 14:02:28 UTC (full logs).

Action items

  1. Everyone: Review the backlog to give any feedback.
  2. Tom: Update the Apex feature list with key backlog items and to fix any mistakes.


People present (lines said)

  1. mdgray (41)
  2. tfherbert (6)
  3. collabot` (4)
  4. Paul_ (1)
  5. Simona_ (1)
  6. billyoma (1)


Generated by MeetBot 0.1.4.