15:02:13 <morgan_orange> #startmeeting xci-onap
15:02:13 <collabot_> Meeting started Fri Jun  1 15:02:13 2018 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:13 <collabot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:13 <collabot_> The meeting name has been set to 'xci_onap'
15:02:35 <fdegir> jmorgan1: electrocucaracha: hola
15:02:55 <electrocucaracha> fdegir: almost there
15:03:14 <David_Orange> #info David Blaisonneua
15:03:24 <jmorgan1> #info Jack Morgan
15:03:37 <electrocucaracha> # Victor Morales
15:03:44 <fdegir> #info Fatih Degirmenci
15:03:58 <frankbrockners> #info Frank Brockners
15:04:15 <morgan_orange> #info Morgan Richomme
15:04:23 <morgan_orange> #topic goal
15:04:41 <hwoarang> #info Markos Chandras
15:04:51 <morgan_orange> #info the intention is to deploy ONAP from master using OOM on XCI K8S scenarios and perform appropriate tests
15:04:57 <morgan_orange> #info Fatih suggests to start with virtual deployments. This is needed anyways in order to support the development of the scenario in XCI. We have resources with enough CPU/RAM in XCI. (88CPUs/256G RAM)
15:05:09 <morgan_orange> #info fdegir introduces xci
15:05:55 <morgan_orange> #info ONAP master branch is the working branch...does not really work
15:07:09 <morgan_orange> #info XCI aims to give feedback to upstream community
15:08:13 <morgan_orange> #topic Short introduction on Orange CI chain for ONAP
15:08:28 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/kubespray_automatic_installation
15:08:35 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/onap_oom_automatic_installation
15:09:11 <morgan_orange> #info amdocs is contiusouly deploy ONAP using OOM (every 3h)
15:10:35 <morgan_orange> #info there is also a jenkins chain managed by LF
15:10:41 <morgan_orange> #link https://jenkins.onap.org/job/lab-aws-beijing-oom-deploy/
15:11:02 <morgan_orange> #link https://jenkins.onap.org/job/lab-tlab-beijing-oom-deploy/
15:11:26 <morgan_orange> #info deployment jobs moved from internal gitlab to gitlab.com yesterday
15:11:45 <morgan_orange> #info pipeline not fully working now (adaptation needed)
15:12:41 <morgan_orange> #info sylvain details current Orange gitlab pipelien for OOM deployement on top of K8S also automatically deployed using kubespray
15:14:43 <morgan_orange> #info 2 healtcheck at the end of the installation: 1st basic => all pods must be running, 2nd => robot healthcheck
15:20:47 <morgan_orange> #topic resources
15:21:07 <morgan_orange> #info in Orange we are using pdf, idf files (as definied by OPNFV)
15:21:46 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/kubespray_automatic_installation/blob/master/vars/pdf.yaml
15:22:03 <morgan_orange> #info used to define the infra
15:22:42 <morgan_orange> #info nb of workers is not optimized and different by AMdocs or ATT ...you can play on the number of workers / RAM
15:23:31 <morgan_orange> #info David_Orange working on kubespray deployement Bare Metal
15:28:58 <morgan_orange> #info question fdegir: kubernetes deployement and oom deployement are 2 independent ansible roles
15:29:56 <morgan_orange> #info question frankbrockners: question on NFS => perisitentn volume would be available on Casambla. Meanwhile NFS is needed to have a shared folder accros the workers
15:30:26 <morgan_orange> #info NFS is setup in auto-oom , part of the ansible role (if not present, we create it)
15:32:22 <morgan_orange> #info question on K8S networking plugin => Sylvain we are using Calico but we should not care..any networking solution should be OK, we just need the connectivity
15:34:00 <morgan_orange> #info k8S scenario => 5 possible networking plugins
15:34:37 <morgan_orange> #info good opportunity to see if networking plugin lead to issues
15:35:00 <morgan_orange> #info for the K8S installation => ranger is the OOM recommended installer , Orange is using kubespray
15:39:44 <morgan_orange> #info organization
15:39:59 <morgan_orange> #info ODL => they maintain ODL role within ODL repo
15:40:23 <morgan_orange> #info it would it make sense to host ONAP role in ONAP
15:41:50 <morgan_orange> #info ONAP there is an integration repo in ONAP => could make sense to create a directory here
15:42:41 <morgan_orange> #info several ways to automate the ONAP deployment: LF, Garry, Michael, Sylvain..
15:43:30 <morgan_orange> #action sylvain, michael, Gary + LF => discuss this topic during next ONAP dev event
15:44:11 <morgan_orange> #info CD must be refactored (for the moment docker build only once a day)
15:48:58 <morgan_orange> #info CI/CD startegy to be precised. Meanwhile possibility to use Orange public gitlab role to try.
15:49:12 <fdegir> can we use an etherpad to keep notes rather than mails?
15:49:14 <fdegir> like --> https://etherpad.opnfv.org/p/xci-oom
15:50:14 <morgan_orange> #info let's use an etherpad to exchange on this
15:50:23 <morgan_orange> #link https://etherpad.opnfv.org/p/xci-oom
15:51:37 <morgan_orange> #endmeeting