08:02:15 <yujunz> #startmeeting qtip
08:02:15 <collabot`> Meeting started Mon Nov  7 08:02:15 2016 UTC.  The chair is yujunz. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:15 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:02:15 <collabot`> The meeting name has been set to 'qtip'
08:02:29 <Julien-zte> #link https://oasis.sandstorm.io/shared/YOztpuHEHseDi9xxhABc57Pm3rAHE-OWTyMgk4cQ3z9
08:02:33 <yujunz> #topic roll call
08:02:36 <yujunz> #info Yujun Zhang
08:02:44 <SerenaFeng> #info SerenaFeng
08:02:49 <zhihui> #info zhihui
08:03:10 <Julien-zte> #info Julien
08:03:23 <yujunz> #topic action followup
08:03:40 <yujunz> #info AP @Taseer to test and update kibana playbook
08:04:10 <yujunz> Taseer is not online. Anybody has tried out the playbook?
08:04:28 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/23939/
08:05:24 <yujunz> This reminds us to create a unit test for the playbook.
08:05:26 <yujunz> #link https://jira.opnfv.org/browse/QTIP-143
08:05:36 <yujunz> We may address it in next sprint
08:06:11 <yujunz> #info AP @zhifeng provide details on the ELK setup playbook
08:06:18 <yujunz> This is a duplication with last AP
08:06:47 <yujunz> I will close it
08:07:10 <Julien-zte> #action zhifeng provide details on the ELK setup playbook
08:07:15 <yujunz> #info AP #done @yujunz provide an example of using vagrant in unit test
08:07:20 <yujunz> #undo
08:07:20 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x227e050>
08:07:25 <yujunz> This is a review
08:07:28 <yujunz> not new action
08:08:01 <yujunz> To test playbook, we may use vagrant to setup a local vm
08:08:48 <yujunz> #link https://www.vagrantup.com/
08:09:04 <Julien-zte> yes, we can use it to perform some test in ci or local env
08:09:16 <yujunz> Example for testing ansible-pyenv
08:09:24 <yujunz> #link https://github.com/dirn/ansible-pyenv/tree/master/tests
08:09:55 <yujunz> At least we should ensure the playbook contains no syntax error
08:10:08 <yujunz> Then we may test the functionality in next step.
08:10:27 <Julien-zte> agree
08:10:36 <yujunz> #link https://github.com/dirn/ansible-pyenv/blob/master/.travis.yml
08:10:48 <yujunz> This is the test script of ansible-pyenv
08:11:17 <yujunz> #info AP @zhihui to do some research on dovetail on how to consume test data from YardStick
08:11:23 <yujunz> zhihui, any progress?
08:11:35 <zhihui> not start yet.
08:11:49 <yujunz> And plan?
08:12:23 <zhihui> I am preparing for opnfv Aisa meetup. So I would start this task next week.
08:12:33 <yujunz> OK.
08:12:38 <yujunz> @zhihui to do some research on dovetail on how to consume test data from YardStick next week
08:12:38 <collabot`> yujunz: Error: "zhihui" is not a valid command.
08:12:44 <yujunz> #action @zhihui to do some research on dovetail on how to consume test data from YardStick next week
08:13:17 <yujunz> #topic Should CLI be installed and run from host or container?
08:13:27 <yujunz> We had an offline discussion about it.
08:13:49 <yujunz> The basic conclusion is that docker shell lacks many interactive features and may not be friendly to user
08:14:20 <yujunz> So the CLI would be a host tool
08:14:35 <yujunz> It may communicate with qtip instance via RESTful api
08:14:51 <SerenaFeng> what do you mean by that?
08:15:04 <Julien-zte> we should provide a install tool to install cli in any location, either in host or vm?
08:15:06 <SerenaFeng> communicate with qtip instance via RESTful api>
08:15:17 <yujunz> The cli is installed to host
08:15:29 <yujunz> The suite and perftest are run in the container
08:15:32 <Julien-zte> which host?
08:15:41 <yujunz> user
08:15:46 <yujunz> Your desktop
08:15:59 <Julien-zte> it's better that we can provide a offline tool to install
08:16:06 <SerenaFeng> too difficult
08:16:22 <SerenaFeng> I think that is not CLI
08:16:23 <Julien-zte> it will be easier for qtip user to have a try or use
08:16:31 <yujunz> Imagine you need two qtip server to complete a test
08:16:40 <yujunz> A test between two location
08:16:48 <Julien-zte> just like Openstack cli, which can be installed by pkg tools
08:17:00 <yujunz> This can not be done within one container
08:17:06 <SerenaFeng> I think that will complex our work
08:17:17 <yujunz> Yes, it would be like openstack cli
08:17:18 <SerenaFeng> frendly is our goal, but not only our goal
08:17:21 <yujunz> running cli in container does not look good
08:17:35 <yujunz> Why you see it difficult?
08:18:01 <Julien-zte> if we can use config files, the cli can switch between different qtip servers.
08:18:04 <yujunz> It would share the same underlying module as RESTful api
08:18:18 <yujunz> Yes, switching between servers is also a benefit
08:18:35 <yujunz> A cli tool in container does not look so useful to me
08:19:03 <yujunz> Docker instance works best as a daemon
08:19:17 <yujunz> not an interactive workspace
08:19:31 <yujunz> Please correct me if it is wrong. In fact, I haven't use docker a lot.
08:20:07 <Julien-zte> maybe we can create a task to prepare installer script
08:20:16 <yujunz> Already in progress
08:20:31 <Julien-zte> that's good
08:20:48 <yujunz> #link https://jira.opnfv.org/browse/QTIP-137
08:21:24 <yujunz> Finally, qtip will consist of qtip-cli, qtip-api, qtip-dashboard and etc
08:21:57 <yujunz> FYI, we have a new domain
08:21:59 <yujunz> #link qtip.io
08:22:20 <yujunz> Currently it is empty
08:23:00 <yujunz> We'll deploy all qtip services under this domain. Benchmark as Service :-)
08:23:40 <yujunz> SerenaFeng we can discuss the CLI solution in detail on Wednesday's standup meeting
08:23:54 <SerenaFeng> I just think we need to focus on the main work, performance/qpi a lot
08:24:07 <SerenaFeng> for now there's no progress on the main work
08:24:15 <SerenaFeng> ok
08:24:36 <yujunz> #topic active sprint followup
08:24:38 <yujunz> #link https://jira.opnfv.org/secure/RapidBoard.jspa?projectKey=QTIP&rapidView=135
08:25:17 <yujunz> 6 closed, 5 in progress and 4 to do
08:25:20 <yujunz> ^ 3 to do
08:25:41 <yujunz> We have one week to go.
08:25:55 <yujunz> zhihui I want to check the progress on QTIP-131
08:26:27 <yujunz> #link https://jira.opnfv.org/browse/QTIP-131
08:26:49 <zhihui> the rest part is directory test_case and tests
08:27:20 <Julien-zte> others are finished zhihui?
08:27:40 <zhihui> Yes, finished and already merged.
08:28:34 <zhihui> I plan to finish the rest part in next two days.
08:28:44 <yujunz> Great! Thanks
08:29:05 <yujunz> #topic Update during last week
08:29:21 <yujunz> #link https://jira.opnfv.org/issues/?filter=11198
08:29:54 <yujunz> QTIP is quite active thanks to everyone
08:30:26 <yujunz> You may see a strong pulse in opnfv github mirror
08:30:29 <yujunz> #link https://github.com/opnfv
08:31:32 <yujunz> Some new tickets about documentation and unit test are open
08:31:58 <yujunz> We will discuss about the content of sprint QTIP-D3 next meeting.
08:32:13 <yujunz> #topic AoB
08:32:39 <yujunz> Anything else you want to talk about? Anything
08:33:27 <SerenaFeng> nope from my side
08:33:43 * yujunz saw Taseer online
08:34:08 <yujunz> We just talked about whether we should run cli on host or container.
08:34:08 <Taseer> yes I am here
08:34:22 <yujunz> You may check the meeting log and we can continue discussion in mailing list
08:34:41 <Taseer> ok sure.
08:35:17 <yujunz> We are just about to close the meeting. Anything particular topic you want to raise?
08:36:16 <Taseer> No not much. Just wanted to confirm if I had completed the action item from last time.
08:36:31 <Taseer> Is the ELK playbook working ?
08:36:58 <yujunz> I didn't test it. I think we shall create a unit test to answer this question :-)
08:37:14 <Taseer> ok. Thank you.
08:37:29 <yujunz> I think that's all for today. Thanks all
08:37:31 <yujunz> #endmeeting