07:35:47 <yujunz> #startmeeting qtip
07:35:47 <collabot> Meeting started Mon Dec 26 07:35:47 2016 UTC.  The chair is yujunz. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:35:47 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:35:47 <collabot> The meeting name has been set to 'qtip'
07:35:54 <yujunz> agenda today
07:36:01 <yujunz> #link https://etherpad.opnfv.org/p/qtip-meetings-2016-12-26
07:36:07 <yujunz> #topic rollcall
07:36:08 <yujunz> #info yujunz
07:36:25 <zhihui_> #info zhihui
07:36:36 <yujunz> #topic action followup
07:36:37 <akhilbatra> #info akhilbatra
07:36:54 <yujunz> #info AP @zhihui to investigate how to detect yardstick finishing
07:37:00 <yujunz> Any update zhihui_
07:38:50 <yujunz> ping zhihui_
07:38:51 <zhihui_> Due to Xmas, yardstick contributor from US is on holiday, so kubi suggested delay the second discussion meeting.
07:39:43 <yujunz> OK, so we shall postpone it to next meeting, which is in 2017?
07:40:14 <zhihui_> And refer to the etherpad, I will post a proposal about integration this week.
07:40:29 <yujunz> #action zhihui to investigate how to detect yardstick finishing after xmas and new year holiday
07:40:30 <yujunz> OK
07:40:55 <yujunz> I shall re-add this action also
07:41:02 <zhihui_> I am not sure about the exact time for next meeting.
07:41:16 <yujunz> #action zhihui_ to propose  design specification of yardstick integration
07:42:08 <yujunz> #topic QTIP-D5 planning
07:42:33 <yujunz> What do you plan for QTIP-D5 zhihui_ akhilbatra ?
07:43:03 <akhilbatra> Hope to start working on api :)
07:43:46 <zhihui_> From me, one is to implement qtip integration in yardstick.
07:44:02 <yujunz> Thanks akhilbatra you can start it any time. What do you think could be delivered in 3 weeks?
07:44:26 <zhihui_> The other is to implement the new framwork in qtip
07:44:40 <yujunz> zhihui_ you mean the compute QPI?
07:44:54 <zhihui_> Yes, compute QPI
07:45:02 <akhilbatra> i will read the swagger codegen and implement the framework setup
07:45:13 <zhihui_> Of course, parts of compute QPI.
07:45:37 <yujunz> How much progress do you think could be made in next 3 weeks? taking your holiday break into consideration
07:45:42 <yujunz> zhihui_
07:46:27 <yujunz> OK, akhilbatra please create tasks in JIRA under the API epic
07:46:32 <zhihui_> oh, I forget the hoilday,
07:47:18 <zhihui_> I have to say, 1 week~
07:47:51 <akhilbatra> ok i will add it after discussing with Serena
07:47:59 <yujunz> Yes, what will you put in priority in the short 1 week? zhihui_
07:48:22 <yujunz> Sounds good akhilbatra
07:48:24 <zhihui_> I will finish the proposal of qtip integration.
07:48:49 <yujunz> I'll start the sprint tomorrow. So you can propose it first and review with SerenaFe_
07:49:30 <SerenaFe_> I should see we should clarify the requirements first
07:49:31 <yujunz> Good, zhihui_ please update the task in JIRA or create it if not existed yet
07:49:37 <akhilbatra> Ok
07:49:44 <yujunz> That could be one task SerenaFe_
07:50:08 <yujunz> A requirement document, see qtip-cli for reference
07:50:11 <zhihui_> yujunz, Ok, after meeting, I will create a jira ticket
07:50:21 <SerenaFe_> yes, that's what I mean
07:50:46 <yujunz> It's on our google docs, named qtip-public in case you missed it.
07:51:05 <SerenaFe_> I will share it with akhilbatra
07:51:31 <yujunz> I think akhilbatra has access, do you?
07:52:20 <akhilbatra> yes you shared drive folder. I will recheck
07:52:57 <yujunz> #link https://drive.google.com/drive/u/0/folders/0B541CgjKBG6lSlFLYVBEWklRWGs
07:53:09 <akhilbatra> Yes i have
07:53:31 <yujunz> On my side, I will work on collector and reporter
07:53:34 <yujunz> Hopefully we shall have a PoC after this sprint.
07:54:42 <yujunz> If time allowed, I will also work on server deployment playbooks. Try to make our framework as completely as possible.
07:55:12 <yujunz> #action all create JIRA tasks for sprint QTIP-D5
07:55:34 <yujunz> #topic architecture and design evolution
07:55:56 <yujunz> There was some change in architecture and design, I'll give a brief report here.
07:56:05 <yujunz> #link https://wiki.opnfv.org/display/qtip/Architecture
07:56:40 <yujunz> I've put in API in the solo mode.
07:57:13 <yujunz> In solo mode, API is close to CLI. It talks to the QTIP core modules and expose interface to applications.
07:57:31 <yujunz> while CLI expose interface to user under console
07:58:13 <yujunz> The other changes are trivial. I think I renamed the infra to benchmark hub
07:58:42 <yujunz> It is a collection of benchmark results from qtip runs
07:59:02 <yujunz> #link https://wiki.opnfv.org/display/qtip/Design
07:59:31 <yujunz> Terms are updated
08:00:05 <yujunz> I've explained a bit in google hangout group to Taseer
08:00:48 <yujunz> Maybe I should create a design specification for it.
08:00:56 <yujunz> See also https://wiki.opnfv.org/display/qtip/FAQ
08:01:05 <yujunz> #link https://wiki.opnfv.org/display/qtip/FAQ
08:01:34 <yujunz> If you have further questions, please ask in mailing list or any other channel you prefer.
08:01:59 <yujunz> Any immediate question?
08:02:51 <yujunz> #action yujunz create a design specification on the architecture and design evolution
08:03:13 <yujunz> #topic CLI progress in QTIP-D4
08:03:36 <yujunz> Taseer should be in an exam at the moment, I'll debrief for hime
08:03:52 <yujunz> He finishes requirements engineering
08:04:21 <yujunz> #info Taseer implemented CLI TestPlan (renamed to Plan)
08:04:37 <yujunz> #info Taseer added unit test for CLI module
08:05:05 <yujunz> #info Taseer starts re-writing the design specification of CLI
08:05:12 <yujunz> #link https://goo.gl/vOCpPL
08:05:46 <yujunz> #info ansible module will be moved to plan
08:06:18 <yujunz> This is not in CLI scope, so maybe I'll help on it and leave the CLI interface to Taseer.
08:06:25 <yujunz> Will talk to him after meeting
08:07:53 <yujunz> #topic active sprint followup
08:07:55 <yujunz> #link https://jira.opnfv.org/secure/RapidBoard.jspa?projectKey=QTIP&rapidView=135
08:08:12 <yujunz> Please update your task status today, zhihui_ SerenaFe_
08:08:31 <yujunz> I will close the sprint tomorrow
08:08:33 <SerenaFe_> no task assign to me I think :)
08:08:49 <SerenaFe_> finish them all
08:09:01 <yujunz> Well done :-)
08:09:11 <yujunz> #topic CI status
08:09:18 <yujunz> #link https://build.opnfv.org/ci/view/qtip/
08:09:37 <yujunz> Mostly red...
08:09:57 <yujunz> The daily job is blocked by fuel installer, I can understand
08:10:10 <yujunz> What's going on with qtip-verify-master?
08:10:15 <yujunz> Any idea, zhihui_
08:11:11 <yujunz> It seems just a failure of some patchset
08:11:21 <SerenaFe_> I think it is because something wrong with CI env's network
08:11:31 <yujunz> Taseer hasn't rebase it to the new arch
08:11:44 <yujunz> So please speed up in reviewing the patch, zhihui_
08:11:50 <yujunz> Otherwise we shall get blocked.
08:12:04 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/26309/
08:13:40 <yujunz> #link https://build.opnfv.org/ci/job/qtip-verify-master/712/console
08:13:42 <zhihui_> Ok, I will review the patch soon
08:14:24 <yujunz> #topic new tasks in JIRA
08:14:32 <yujunz> #link https://jira.opnfv.org/issues/?filter=11198
08:15:31 <yujunz> I created a new task about exception handling
08:15:38 <yujunz> And a low priority task of creating QTIP logo
08:17:31 <yujunz> #topic AoB
08:17:39 <yujunz> #info new intern project created
08:17:43 <yujunz> It seems an old news?
08:18:37 <yujunz> #info another student has contact us showing his interest in qtip-api server
08:18:53 <yujunz> #info shuttding down qtip-desk in Tuesday
08:19:31 <yujunz> I've sent out the mail to inform all users. Please make sure you don't have important data on it, zhihui_ SerenaFe_
08:19:50 <SerenaFe_> nope from my side
08:19:57 <zhihui_> me too
08:19:59 <yujunz> Any other updates?
08:21:40 <yujunz> No? Then I shall close the meeting now.
08:21:43 <yujunz> Thank you all
08:22:20 <yujunz> Next week will be new year holiday
08:22:48 <yujunz> #info next meeting will be on Jan 9, 2017
08:22:52 <yujunz> Happy new year all
08:23:02 <yujunz> #endmeeting