07:32:21 <yujunz> #startmeeting qtip
07:32:21 <collabot`> Meeting started Mon Mar  6 07:32:21 2017 UTC.  The chair is yujunz. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:32:21 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:32:21 <collabot`> The meeting name has been set to 'qtip'
07:32:29 <yujunz> #topic roll call
07:32:33 <yujunz> #info Yujun Zhang
07:32:39 <akhilbatra> #info akhilbatra
07:33:06 <Taseer> #info Taseer
07:33:46 <yujunz> Agenda for today
07:33:47 <yujunz> #link https://etherpad.opnfv.org/p/qtip-meetings-2017-03-06
07:35:09 <yujunz> #topic Action followup
07:35:19 <yujunz> #info AP1 all review api requirement and comment https://goo.gl/UrFzlR
07:35:28 <yujunz> Have you done it, SerenaFeng?
07:35:35 <SerenaFeng> nope
07:35:51 <yujunz> OK, when do you plan to do it?
07:36:31 <SerenaFeng> I planed this morning, but occupied by a job interview
07:36:37 <SerenaFeng> I will do it after the meeting
07:37:09 <yujunz> Good, thanks.
07:37:13 <yujunz> #info AP2 all make proposals for OPNFV Summit Beijing before Mar 27th https://etherpad.opnfv.org/p/qtip-opnfv-summit-beijing
07:37:47 <yujunz> There is some rumor that Linux Foundation may invite interns to the summit
07:37:59 <akhilbatra> Or one can directly review this patch https://gerrit.opnfv.org/gerrit/#/c/29815/4
07:37:59 <akhilbatra> It is adhering the requirements
07:38:11 <yujunz> So you two can make proposal of some talks also, akhilbatra Taseer
07:38:24 <SerenaFeng> Yes, but I don't whether all the interns will be invited
07:38:34 <akhilbatra> We can? :)
07:38:43 <yujunz> It is not confirmed
07:38:46 <yujunz> But possible
07:38:47 <akhilbatra> ok
07:38:57 <SerenaFeng> I don't know, it depends on LF
07:39:36 <yujunz> I think if your proposal is accepted. The chance of getting invited will increase significantly
07:40:42 <yujunz> #topic Status update from the team
07:40:43 <Taseer> But we can attend, even if we don't give talks ?
07:40:46 <akhilbatra> talk proposal should be on  the work we are doing or something else
07:40:49 <akhilbatra> ?
07:41:09 <yujunz> The work you are doing
07:41:13 <yujunz> Or the work you are going to do
07:41:31 <yujunz> Or something that would be interested by the community
07:41:38 <akhilbatra> ok thanks
07:42:06 <yujunz> The non-speaker need to pay the ticket
07:42:17 <yujunz> The speakers are sponsored by LF
07:42:26 <yujunz> For interns, I'm not sure
07:42:30 <Taseer> Okay
07:42:34 <yujunz> It is the first time I get this rumor
07:42:35 <SerenaFeng> the rule are for us
07:43:08 <SerenaFeng> for the intern, if he/she is invited the OPNFV will pay his/her accomodation/transport and tickets
07:43:18 <yujunz> Thanks for the information
07:44:15 <yujunz> Who go first on status update?
07:44:16 <SerenaFeng> OPNFV plan to do but not decide yet
07:45:39 <yujunz> On my part, I was cleaning up the code for Danube release
07:46:14 <yujunz> And for the missing runner module, I have planned to execute collector and reporter directly in ansible playbook
07:46:40 <yujunz> Hard code them for this release
07:46:56 <yujunz> zhihui_ Taseer could you work together to make it work?
07:47:09 <zhihui_> ok.
07:47:12 <zhihui_> I implement ansible_driver and rework env.py. Please feel free to review my patches.
07:47:17 <yujunz> Thank you.
07:47:21 <yujunz> Who's next?
07:48:03 <SerenaFeng> no work from my side :) :(
07:48:09 <akhilbatra> I have implemented basic prototype of api.
07:48:09 <akhilbatra> request and response parameters have to be worked on now
07:48:23 <yujunz> Great
07:48:39 <yujunz> Have you prepare also the document and test, akhilbatra
07:48:52 <zhihui_> On my local env, I can tirgger ansible driver to execute dhrystone test.
07:50:22 <yujunz> Great. The key mission is to make the framework "complete". We can expand to more api and test in next release
07:50:26 <zhihui_> I plan to refactor the rest of compute test case. Then we can let qtip daily ci job  to run these test.
07:50:32 <akhilbatra> document I will do.
07:50:32 <akhilbatra> I dont intend to make whole test coverage right now.
07:50:32 <akhilbatra> because right now all responses are `Not implemented` right now.
07:50:32 <akhilbatra> one test will suffice to see if api is running.
07:51:09 <yujunz> OK, when I say test, I mean give some sample on how api will be tested
07:51:16 <yujunz> The coverage is less important in Danube release
07:51:33 <akhilbatra> ok will do that :)
07:51:35 <zhihui_> About unit test, can we finish it after the code freeze.
07:51:58 <yujunz> OK, thanks
07:52:08 <yujunz> #topic Danube release status update https://etherpad.opnfv.org/p/qtip-danube
07:52:50 <yujunz> All, please update status on the page now and back to IRC when you have done
07:57:33 <yujunz> OK, let's continue
07:57:59 <yujunz> I cancelled the tasks about async jobs and native runners
07:58:14 <yujunz> We are thinking about implement qtip as ansible module.
07:58:42 <yujunz> Because Ansible has everything we need as a runner, and we don't want to re-invent wheels
07:59:44 <yujunz> qtip-cli will be kept as the user interface in console. It's like qtip runs ansible, ansible uses qtip modules
07:59:56 <yujunz> We'll see how to do it in release E
08:00:39 <yujunz> #topic active sprint followup https://jira.opnfv.org/secure/RapidBoard.jspa?projectKey=QTIP&rapidView=135
08:01:28 <yujunz> You may update the JIRA tickets now and come back to the IRC meeting after 5 minutes
08:01:58 <yujunz> It seems we haven't got used to update them in daily work yet. Let's do it on meeting instead :-)
08:04:22 <zhihui_> It also seems I didn't create jira ticket for my works.
08:05:27 <yujunz> OK, let's continue
08:05:42 <yujunz> #topic CI status https://build.opnfv.org/ci/view/qtip/
08:06:00 <yujunz> pod3 is down, zhihui_?
08:06:19 <zhihui_> Zte pods met problems when running "docker pull"
08:06:46 <yujunz> Is anybody handling this issue now?
08:06:51 <zhihui_> me
08:07:09 <yujunz> Thanks, we shall revisit next week
08:07:24 <zhihui_> Julien build the local docker cache
08:07:29 <yujunz> #topic new tasks in JIRA https://jira.opnfv.org/issues/?filter=11198
08:07:38 <zhihui_> build -> built
08:07:49 <yujunz> OK, I saw the ticket about it now
08:08:03 <yujunz> #link https://jira.opnfv.org/browse/QTIP-219
08:08:26 <yujunz> #topic AoB
08:08:31 <zhihui_> After updating docker, this is solved now.
08:08:50 <yujunz> So pod3 is recovered?
08:09:04 <zhihui_> yes
08:09:26 <yujunz> Great. When will be next execution
08:09:51 <zhihui_> tomorrow morning.
08:09:58 <yujunz> I see
08:10:08 <yujunz> #info MS7 stable branch on Mar 10th https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-March/015342.html
08:10:29 <yujunz> I think we shall branch until the deadline
08:10:51 <yujunz> It will be created by gerrit admin
08:11:14 <yujunz> Before that, I may block new features which are not in our danube plan.
08:11:27 <yujunz> So don't be surprised if you get -2 on some submit :-)
08:11:46 <zhihui_> haha~
08:11:49 <SerenaFeng> I prefer to use -1
08:12:01 <yujunz> Openstack uses -2 for blocking
08:12:06 <SerenaFeng> -2 is too harsh
08:12:09 <yujunz> I will comment so it won't be so rude
08:12:09 <zhihui_> so famous -1 will become to famous -2?
08:13:22 <yujunz> #link https://review.openstack.org/#/c/423084/
08:13:25 <akhilbatra> In my current patch I have included basic mapping and response details for async jobs which are now part of E release.
08:13:25 <akhilbatra> Shall I keep serving them as Non implemented or It qualifies for -2 now?
08:13:26 <yujunz> See example here
08:13:42 <yujunz> "Proceedural -2 for freeze.  If you wish to request an exemption please submit an email to openstack-dev with the starting subject line of '[FFE][requirements]' with the reasoning behind your request."
08:14:22 <yujunz> I'll check the patch later.
08:14:30 <SerenaFeng> I should we do with cli and api
08:14:32 <akhilbatra> ok thanks
08:14:41 <SerenaFeng> I don't think they can catch up before that
08:14:45 <yujunz> It is just procedural -2. Don't get discouraged on it. Nothing serious
08:15:42 <yujunz> #info license tool in qtip/third-party/License
08:15:55 <yujunz> All code and configuration file need license header
08:16:20 <yujunz> You may use a third party tool to check it before you submit a patch to gerrit for review
08:16:32 <yujunz> There is README in it. It should be easy to use
08:16:50 <yujunz> #info intern project review: qtip-cli 2nd period next week
08:17:09 <yujunz> Taseer will send invitation for 2nd period review of qtip-cli next week
08:17:30 <yujunz> #action Taseer to send invitation of qtip-cli 2nd review next week
08:17:41 <yujunz> Alright, anything else?
08:18:19 <yujunz> Nope?
08:18:32 <zhihui_> nope from me
08:18:55 <yujunz> Thank you all, bye
08:18:57 <yujunz> #endmeeting