14:32:48 <ChrisPriceAB> #startmeeting Brahmaputra Daily Standup
14:32:48 <collabot`> Meeting started Mon Mar  7 14:32:48 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:48 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:32:48 <collabot`> The meeting name has been set to 'brahmaputra_daily_standup'
14:32:51 <ChrisPriceAB> #topic rol call
14:32:55 <ChrisPriceAB> #topic roll call
14:32:58 <radez> #info Dan Radez
14:33:03 <ChrisPriceAB> #info Chris Price
14:33:08 <bin_> #info Bin Hu
14:33:17 <ashyoung> #info Ashlee Young
14:33:40 <HKirksey> #info Heather Kirksey
14:33:48 <narindergupta1> #info Narinder Gupta
14:34:18 <ChrisPriceAB> ok, so let's get rolling info in as you arrive moving topics.
14:34:36 <ChrisPriceAB> #topic brahmaputra.2.0 schedule
14:34:48 <ChrisPriceAB> #link https://etherpad.opnfv.org/p/steps_to_brahmaputra current plan for 2.0
14:35:17 <ChrisPriceAB> #info I would like to review the dates on the etherpad and make sure they make sense for us acording to our current plan
14:35:53 <ChrisPriceAB> #info specifically March 20 end of day. scenario freezes:  here we close the scope for 2.0
14:36:23 <ChrisPriceAB> #info and a final release date of March 28
14:36:37 <ChrisPriceAB> Any concerns, comments questions or can we lock that in as our plan?
14:37:08 <ChrisPriceAB> going once, twice...
14:37:12 <ChrisPriceAB> ok, moving on
14:37:12 <bin_> +1
14:37:27 <ChrisPriceAB> #topic scenario status updates
14:37:30 <ashyoung> Yes
14:37:48 <ChrisPriceAB> alphabetically Apex update?
14:38:07 <radez> we're in the same place, I don't forsee us making any progress before this release data
14:38:13 <ashyoung> Even though we've said we'll roll out with documenting the issue...
14:38:28 <ashyoung> We aren't sure if there's an overlap with ODL too
14:38:35 <radez> the things that need to be fixed with ONOS and ODL L3 are about the same issue and anre probably not going to get fixed before end of march
14:38:43 <radez> things work but we can't verify
14:38:52 <ashyoung> What Dan said :)
14:39:01 <radez> we have ODL HA in the pip
14:39:01 <ChrisPriceAB> :)
14:39:03 <radez> *pipe
14:39:11 <radez> probablky land in the next day or two in B
14:39:20 <radez> other than that we probably won't have much movement on anything else
14:39:29 <radez> everythign else will move to be targeted to C
14:39:30 <ChrisPriceAB> #info ongoing issues around ONOS and ODL test case execution not progressing.
14:39:34 <ashyoung> I think documenting is fine, but we should document the whole situation and I also think we need to look at it cross community
14:39:44 <ashyoung> Bingo!
14:40:03 <ChrisPriceAB> Have we been able to identify if the issue is in the driver and not in the controllers?
14:40:10 <ashyoung> We have ways to solve it, but need to ensure we don't break something in the process
14:40:34 <joekidder_> #info Joe Kidder
14:40:35 <radez> ashyoung: I just talk to one of our ODL guys and he said he's pretty sure that they're just sending everything to the gateway too
14:40:38 <radez> but same deal
14:40:46 <radez> they want to be sure they don't break anything
14:40:48 <ashyoung> Yep
14:41:06 <radez> ChrisPriceAB: it's the controllers that just need updates to handle local subnet traffic
14:41:13 <radez> by not sending it to the gateway
14:41:14 <ChrisPriceAB> do we have tickets on these?  Can we info the Jira ref's in as persistent issues?
14:41:44 <radez> not really, they're upstream issues
14:41:46 <ChrisPriceAB> ok, thanks radez.  For ODL SR1 we have 6 days left for patching.  Do we have an upstream fault report we can point at?
14:42:05 <radez> if we do I don't have links to them
14:42:36 <ChrisPriceAB> ashyoung, do we have a ticket on ONOS for this (even if unresolved and no planned delivery date)
14:42:42 <ashyoung> no
14:42:51 <ashyoung> Don't think it's an issue like that
14:43:24 <ashyoung> They both will work with local subnet traffic, but I'm being told it's something in how we have the setup
14:43:36 <ashyoung> So we have a disagreement to resolve
14:43:53 <radez> agreed
14:43:56 <ChrisPriceAB> Ok...
14:44:10 <ashyoung> Again, we're working on it for both
14:44:30 <ashyoung> If there is a bug in the controllers, we'll file appropriate tickets there
14:44:52 <ashyoung> We have opened up the debugging to more than just our local teams
14:45:10 <ChrisPriceAB> Would be nice to have an issue tracker to make this a little more visible.  Config/Code/Lab may all be part of the prblem but it would be nice to be able to point to a Jira ticket or two on this issue
14:45:43 <ashyoung> I think it's pretty visible via the failed tests
14:45:58 <ashyoung> It's in my face each day :)
14:46:04 <ChrisPriceAB> agreed, the fact that there is an issue is pretty obvious.  :)
14:46:29 <ChrisPriceAB> the potential solution and workaround is not so easy to track as we are all working independantly.
14:46:35 <ashyoung> As I mentioned in previous meetings, it's not nice to just cast blame that someone has a bug without verifying it
14:46:41 <ashyoung> Agreed
14:47:00 <ashyoung> But we aren't sure if the current work arounds are good, which is what we're trying to verify
14:47:15 <ashyoung> Sorry
14:47:43 <ashyoung> Once we have a good resolution, we'll test across both controllers and then update folks
14:47:45 <ChrisPriceAB> Agreed, but letäs open a Jira ticket on the ODL and ONOS integration and we can keep it updated with items as we find them out.  Not as a method of casting blame but as a point to share information.
14:47:56 <ashyoung> I don't have a problem with that
14:48:09 <ashyoung> Want me to do that?
14:48:15 <ChrisPriceAB> can action you ash?  yes plz
14:48:20 <ashyoung> You bet
14:48:34 <ChrisPriceAB> #action ashyoung to open a Jira ticket to track the ODL/ONOS integration issues.
14:49:11 <ChrisPriceAB> cool and let's share that with all parties, the more eyes the shallower the issue becomes.  (one hopes)
14:49:20 <ashyoung> Agreed
14:49:53 <ChrisPriceAB> Ok, so aside from the ODL/ONOS integration issues, where are we on SFC/BGP/OVS/KVM/OCL scenarios?
14:50:07 <ChrisPriceAB> anyone have an update?
14:50:22 <ChrisPriceAB> Or... Who do I have to hunt down to get updates.  :)
14:50:39 <narindergupta1> ChrisPriceAB: we are till debugginh OCL
14:51:19 <narindergupta1> and ONOS not much progress without the gateway MAC on intel and orange labs still trying to get that information.
14:51:29 <ChrisPriceAB> thanks narindergupta1: are we deploying but not passing tests or still getting the deploy of upstream components together?
14:52:05 <narindergupta1> ChrisPriceAB: deployment wise not issue with vping is not passing and onos team informed me that need gatway MAC
14:52:15 <narindergupta1> to get it register with their controller
14:52:27 <ChrisPriceAB> #info OCL testing still underway, narindergupta1 is debugging the lastest deployment.  vPing is not passing.
14:52:53 <ChrisPriceAB> on the topic of the gateway MAC, are we going to need every deployment to be pre-coded with the local gateway MAC?
14:53:12 <narindergupta1> ChrisPriceAB: yes thats the requirement from onos controller.
14:53:52 <narindergupta1> as with ODL and OVS we can use the gateway IP but not with ONOS
14:54:14 <ChrisPriceAB> ok.  something to look into for C I guess.
14:54:53 <narindergupta1> for JOID it is config option which can be set post deployment as well.
14:55:06 <ChrisPriceAB> Thansk guys, anything else to share on JOID, Apex, Compass.  (I will hunt the Fuel team down for future stand-up meetings)
14:56:05 <ashyoung> narindergupta1 : Can't we just get the MAC based on the IP?
14:56:05 <ChrisPriceAB> #info for JOID the solution to the GW/MAC requirement has been put in place as a deployment configuration options.
14:56:55 <narindergupta1> ashyoung: in intel and orange pod ping to gateway ip is blacoked
14:57:01 <narindergupta1> so ARP does not work.
14:57:19 <ashyoung> narindergupta1: got it
14:57:33 <narindergupta1> but in case we have labs where it is not blocked then it will configure as part of deploymenty
14:58:18 <ChrisPriceAB> Ok thanks All.  Let's reconvene tomorrow.  I'll wrangle the test and Fuel teams to the meeting.
14:58:30 <ChrisPriceAB> last items, issues or comments before we close?
14:58:36 <ashyoung> thanks!
14:59:29 <ChrisPriceAB> Ok, thanks all.  Ping me if there is anything you need me to work with, otherwise let's try and  progress.
14:59:34 <ChrisPriceAB> #endmeeting