15:02:46 <dmcbride> #startmeeting OPNFV Colorado Release
15:02:46 <collabot> Meeting started Tue Sep  6 15:02:46 2016 UTC.  The chair is dmcbride. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:46 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:46 <collabot> The meeting name has been set to 'opnfv_colorado_release'
15:02:53 <dmcbride> #topic roll call
15:03:04 <frankbrockners> #info Frank Brockners
15:03:06 <ChrisPriceAB> #info Chris Price
15:03:16 <dali`> #info Dan Lilliehorn (Enea/ARMBand)
15:03:31 <bin_> #info Bin Hu
15:03:47 <florind> #info Florin Dumitrascu (Enea)
15:04:18 <bryan_att> #info Bryan Sullivan
15:04:20 <bin_> I am on another internal meeting, so IRC only, and stay in and out
15:04:30 <kubi001> #info kubi
15:05:14 <StuartMackie> #info Stuart Mackie
15:07:36 <jmorgan1> #info Jack Morgan (Pharos)
15:09:02 <Greg_E_> #info Greg Elkinbard
15:09:13 <morgan_orange> #info Morgan Richomme
15:09:27 <dmcbride> #topic #topic Open Daylight
15:09:44 <frankbrockners> https://www.irccloud.com/pastebin/ZcXhlh98/
15:10:01 <narindergupta> Gupta
15:10:15 <narindergupta> #info Narinder Gupta
15:10:39 <dmcbride> #info ODL project is having problems with the Boron release
15:10:55 <dmcbride> #info Boron is required to support SFC
15:12:27 <sofiawallin> #info Sofia Wallin
15:12:58 <ChrisPriceAB> I'm not sure ODL is having problems, but they will likely be pushing their final release out to next week.
15:13:48 <dmcbride> #info @frankbrockners says that FDS will be using ODL Boron for Colorado 1.0
15:14:32 <dmcbride> #info scenarios not using ODL for HA
15:15:36 <rprakash_> #info ODL HA will be tested in Rel C2.0 and does not exist in C1.0
15:15:53 <dmcbride> #info @ChrisPriceAB wants to make sure that SDN controller application with regard to HA must be documented in release notes and scenario documentation
15:16:42 * ChrisPriceAB is struggling with hotel wifi, not able to follow but it sounds like I agree mostly. :)
15:17:23 <jmorgan1> ChrisPriceAB: Frank is saying that all componets should be HA when the scenario name includes HA
15:17:23 <dmcbride> #info @DanSmithEricsson raises concern about scenario names using HA
15:17:51 * bryan_att wishes GTM had a speech-to-text bot we could link to IRC
15:18:11 <dmcbride> #info should scenarios include "HA" if not all components are HA-capable
15:18:41 <ChrisPriceAB> I disagree, at this stage.  HA means the scenario, if there is a limitation for that document it.
15:18:53 <bryan_att> at least we should identify exceptions to HA in the scenario description - but we do not need to change the names
15:19:27 <ChrisPriceAB> OpenStack is one component of a scenario, not the entirety.
15:20:25 <dmcbride> #info @bryan_att asserts that we should not change names, we should just document exceptions
15:21:02 <ChrisPriceAB> +1 bryan_att
15:21:41 <morgan_orange> today we have for instance os-nosdn-nofeature-ha and os-odl_l2-nofeature-ha, it should be .......... os_ha-nosdn_ha-feature and os_ha-odl_l2_noha-nofeature....?
15:23:04 <dmcbride> #topic documentation
15:23:26 <rprakash_> #Morgan agreed we need to seperate OS ha and SDN ha
15:24:06 <dmcbride> #info @sofiawallin reports good progress with documentation
15:27:46 <dmcbride> #info @sofiawallin has heard from all projects now except for Prediction
15:28:24 <dmcbride> #info @frankbrockners raises issue about access to rendered documentation
15:29:16 <dmcbride> #info @frankbrockners also wants to be able to setup own environment to render documentation instead of waiting for CI
15:30:19 <dmcbride> #info discussed last week in the Infra meeting.  Documentation is integrated with CI.  Need better access to rendered artifacts
15:30:48 <dmcbride> #action @sofiawallin document how to access rendered documentation
15:31:12 <dmcbride> #action @sofiawallin document method for local rendering
15:31:45 <bryan_att> http://artifacts.opnfv.org/opnfvdocs/colorado/configurationguide-single/index.html
15:32:03 <rprakash_> morgan suggested for ubuntu use rst to pdf  tool to test before updating and Frank said that may not render as OPNFV does
15:32:04 <dmcbride> #link http://artifacts.opnfv.org/opnfvdocs/colorado/configurationguide-single/index.html
15:32:26 <morgan_orange> https://apps.ubuntu.com/cat/applications/precise/retext/
15:32:46 <ChrisPriceAB> maybe we need to clean up the repo and artifacts page
15:34:11 <dmcbride> #topic Colorado 2.0 and 3.0 planning
15:34:43 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Colorado+2.0+and+3.0
15:38:16 <sofiawallin> ChrisPriceAB: action for the docs team I guess...
15:38:25 <rprakash_> Jira cleanup means any fature that is assigned to clorado 1,2,3 that are not meeting timelines can be pushed to release D or re tagged to appropriately to reflect changes
15:40:48 <ChrisPriceAB> I tend to agree with Frank.  Moving forward let's keep published  milestones to gating, not removing the Jira like tasks but having a project plan associated with achieving that to cover those things.
15:40:48 <ChrisPriceAB> 5:39 PM We can gate on having Jira tasks in place early then use behavior rather than milestones to maintain the tool.  (report on it rather than gate on it)
15:42:35 <rprakash_> Any tags can be used for tracking the activity in Jira, as long as they are not part of release related
15:45:41 <ljlamers> #info Larry Lamers
15:46:28 <ChrisPriceAB> decline to comment
15:47:19 <dmcbride> #info Jira cleanup is not gating, so pull it from the schedule
15:47:19 <ChrisPriceAB> I would like to see it tied into the "scenario promotion" process and "tst score metric" rather than just a "this feels like a good time to do it" as we do today
15:47:54 <ChrisPriceAB> So maybe I would prefer to postpone the discussion and have it planned simillar to our eventual Colorado solution for now
15:48:06 <dmcbride> #topic D-release planning
15:48:47 <dmcbride> #info @frankbrockners says that we should have a "window" for stable branch as we did with Colorado
15:49:06 * ChrisPriceAB has to run off to work. Will look for minutes and mailing list topics. Let's make sure we are as inclusive as possible leading up to the TSC call next week. (if we want to stamp it down)
15:49:18 <dmcbride> #info also, remove Jira cleanup, as with Col 2.0 & 3.0 schedule
15:49:24 <narindergupta> dmcbride, just an info that intel pod5 have a break down and there is no elecritiy in pod
15:49:52 <dmcbride> narindergupta: sounds bad!
15:49:58 <narindergupta> so none of joid scenarios are tested currently and it is almost 3 days until the last last
15:50:01 <rprakash_> #like to review scenario
15:50:15 <narindergupta> jack mentioned that it should be back today but you never know
15:50:55 <ChrisPriceAB> some projects want to start next release work at least a month before we release.  I thinkn we need to get to the next level of detail and solve these issues rather than try to find the right place to swing a large hammer
15:51:59 <ChrisPriceAB> private == personally governed and not a community resource
15:52:15 <narindergupta> ve now
15:53:17 <bryan_att> not sure I see the value of any policy on private repos until we have discussed the issue and implications of making a policy, at length
15:54:56 <bryan_att> there are good reasons to use github as a repo in the short or even long term. It's an upstream resource. I look at any non-OPNFV repo as an upstream resource. It's up to the projects to use those resources appropriately. If OPNFV wants to consider what is appropriate, I am open to the discussion.
15:56:27 <jmorgan1> dmcbride: intel is doing work on its UPS and the campus which hosts the Intel Lab has been down all weekend, not just Intel POD 5/6
15:56:38 <jmorgan1> dmcbride: it should be back online today
16:07:54 <dmcbride> #endmeeting