03:30:15 <dmcbride_> #startmeeting OPNFV APAC Release meeting
03:30:15 <collabot`> Meeting started Wed Feb 22 03:30:15 2017 UTC.  The chair is dmcbride_. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:30:15 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
03:30:15 <collabot`> The meeting name has been set to 'opnfv_apac_release_meeting'
03:30:25 <dmcbride_> #topic roll call
03:30:30 <dmcbride_> #info David McBride
03:30:35 <fuqiao> #info fuqiao
03:30:39 <kubi001> #info kubi(yardstick)
03:30:50 <huzhj> #info Zhijiang
03:31:23 <chigang> #info Justin
03:31:38 <gabriel_yuyang> #info gabriel.yu
03:32:03 <dmcbride_> #topic housekeeping
03:32:31 <dmcbride_> #info in case you missed it, agenda and minutes may be found here vv
03:32:37 <dmcbride_> #link https://wiki.opnfv.org/pages/viewpage.action?pageId=8690599
03:33:10 <dmcbride_> my plan today is to discuss MS6 and MS7
03:33:23 <dmcbride_> does anyone have additional topics that they would like to discuss?
03:33:49 <dmcbride_> ok - let's launch into MS6
03:33:57 <dmcbride_> #topic MS6
03:34:18 <dmcbride_> #info date was last Friday (Feb 17)
03:34:42 <dmcbride_> any comments about MS6?  Good? Bad? Confusing?
03:35:02 <chigang> just a question, what time stable branch will be create?
03:35:44 <dmcbride_> the window for stable branch is now open, so projects are free to generate their branch any time between now and MS7 (March 10)
03:35:53 <chigang> #info chigang ask a question what time stable branch will be create?
03:36:08 <chigang> dmcbride_: thanks
03:36:08 <fuqiao> hi, david. one question, we only need to upload placeholder for the doc, including the index. rst file and the rst file with document title, right? what if we need to modify pictures. is it ok for us to upload other pictures in the doc
03:36:21 <dmcbride_> #info the window for stable branch is now open, so projects are free to generate their branch any time between now and MS7 (March 10)
03:36:41 <dmcbride_> fuqiao: yes, absolutely
03:36:51 <fuqiao> thanks
03:37:18 <dmcbride_> the point of the prelim doc requirement was to get the learning curve out of the way earlier in the process
03:37:31 <dmcbride_> with Colorado, there was confusion about where to put documentation
03:37:51 <dmcbride_> the idea is for everyone to get through that phase NOW, instead of toward the end of the release cycle
03:37:58 <dmcbride_> does that make sense?
03:38:05 <fuqiao> make sense to me
03:38:25 <kubi001> dmcbride_: I received a email from sofia, she said testing projects didn't do the right way with the Documentation
03:38:38 <kubi001> dmcbride_: so we need to fix the issue soon
03:38:44 <dmcbride_> so, you are free to update the documentation as necessary until the documentation milestone in March
03:39:19 <dmcbride_> #info kubi001 reports that sofia is requesting that test projects adjust their documentation
03:39:36 <dmcbride_> kubi001: do you understand what you need to do?  Is it clear?
03:40:32 <kubi001> dmcbride_: yes, it is clear now
03:40:40 <yuyang_gabriel> Sofia inform testing project to put testing docs in /doc/test
03:40:45 <dmcbride_> ok - how about test case implementation?  Any problems?
03:41:34 <kubi001> dmcbride_:  I saw jose send a email about the MS6 test case status, so I would like to summary the test case status from Yardstick with a email
03:41:36 <fuqiao> dmcbride_: when is the documentation milestone deadline?
03:42:11 <dmcbride_> kubi001: we'll discuss compliance assessment in a moment
03:43:09 <dmcbride_> #link https://wiki.opnfv.org/display/SWREL/Danube
03:43:18 <dmcbride_> #info ^^ Danube schedule
03:43:47 <dmcbride_> #info fuqiao asks when is the Documentation milestone
03:44:14 <dmcbride_> #info according to the Danube schedule (see link above), Documentation is due with MS10 on March 24
03:44:38 <fuqiao> thanks!
03:44:48 <dmcbride_> ok - so let's discuss assessment for MS6
03:45:08 <dmcbride_> we discussed assessment during the main release meeting earlier today
03:46:20 <dmcbride_> #info MS6 - test case implementation - projects will send a list of commits for their test case implementation, including the commit to enable testing in the Functest repo, as well as commits for their test cases in the project repo
03:47:09 <dmcbride_> #info assessment will focus on Functest, since it is the baseline default framework for testing
03:48:02 <dmcbride_> #info MS6 - preliminary documentation - projects will send a link to their preliminary documentation
03:48:19 <kubi001> dmcbride_: there are some feature projects test cases which are run in yardstick repo
03:48:28 <dmcbride_> I will be sending an email tomorrow requesting this information
03:48:38 <yuyang_gabriel> For other testing project, do we need to send a list the Jenkins jobs to you?
03:48:51 <dmcbride_> kubi001: yes, understood
03:48:54 <kubi001> dmcbride_: such as KVM, HA,
03:49:28 <dmcbride_> kubi001: the thought is that all projects run functest, while only some projects run yardstick and other test frameworks
03:49:53 <dmcbride_> kubi001: the intent is NOT to verify all testing, but just to verify the minimum testing in functest
03:50:31 <dmcbride_> kubi001: this is obviously imperfect, but seems like a reasonable tradeoff given resource limitations
03:51:22 <dmcbride_> ok - does anyone have questions about the compliance assessment for MS6?
03:51:34 <dmcbride_> watch for my email tomorrow
03:52:08 <kubi001> dmcbride_: the basic idea for the feature test case is that  functional test run with functest, and performance test run with yardstick or other performance test projects
03:52:44 <dmcbride_> kubi001: yes, understood
03:53:02 <kubi001> dmcbride_: if a feature project only want to verify the functional with the test,  so that would make sense to focus on functest
03:53:57 <dmcbride_> kubi001: right - I don't have the bandwidth to verify all testing that all projects intend to do, so I focus on the common denominator, which is functest
03:54:51 <kubi001> dmcbride_: since some projects (like KVM) , they are focus on performance,  so I don't know whether they will pass the MS6 if they only run their test case with yardstick
03:55:37 <dmcbride_> kubi001: that's something I was wondering about, whether there are any projects that do not use functest, but do use other test frameworks
03:56:04 <dmcbride_> so, KVM does not use functest?
03:56:14 <kubi001> dmcbride_: I guess, yes, KVM and HA should like this
03:57:10 <dmcbride_> I guess what I could say is, send me the commits for your implementation of functest.  If you do not use functest, then send me the links for the framework that you do use.
03:57:58 <dmcbride_> #topic MS7 - stable branch
03:58:00 <kubi001> there are also some test case run with yardstick from IPV6, Parser, SFC  Team, but they also implement the test case in functest
03:58:26 <yuyang_gabriel> dmcbride_ testing projects also have their own tests to validate the platform, apart from feature projects
03:58:52 <dmcbride_> yuyang_gabriel: that is a very good point
03:59:14 <kubi001> dmcbride_:  I think some internal test cases which we implement in testing projects also should be reported
03:59:37 <dmcbride_> #undo
03:59:37 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2462a50>
04:00:05 <dmcbride_> #info yuyang_gabriel says that testing projects also have their own tests to validate the platform, apart from feature projects
04:00:58 <dmcbride_> kubi001: ok - I will request that info from the test projects
04:01:25 <dmcbride_> #info kubi001 says I think some internal test cases which we implement in testing projects also should be reported
04:01:45 <dmcbride_> #action dmcbride to request commits for internal test cases from test projects
04:02:23 <dmcbride_> ok - let's talk about the stable release milestone
04:02:30 <dmcbride_> #topic MS7 - stable release
04:03:11 <dmcbride_> #info projects may create a stable branch, when they are ready, between now and MS7 (March 10)
04:03:45 <dmcbride_> #info branching instructions have not yet been posted for Danube, yet
04:03:54 <dmcbride_> #info however, they should be similar to Colorado
04:04:06 <dmcbride_> #info I have an action to post those instructions this week
04:04:19 <dmcbride_> any questions about MS7?
04:05:00 <chigang> that is clear for me
04:05:00 <kubi001> not from me
04:05:07 <dmcbride_> ok - great
04:05:19 <dmcbride_> just a couple of closing comments
04:05:23 <dmcbride_> #topic AoB
04:05:51 <dmcbride_> #info if you are considering a new project, please get your proposal in as soon as possible
04:06:51 <dmcbride_> #info also, be aware that there is an email thread on the mailing list discussing the "E" release schedule.  Please free to comment on that thread, or send me a separate mail, if you have thoughts/comments
04:07:22 <dmcbride_> #info the TSC will likely vote on the schedule 2 - 3 weeks from now
04:08:07 <dmcbride_> #link https://wiki.opnfv.org/display/SWREL/E-River
04:08:22 <dmcbride_> #info ^^ draft schedule for "E" release
04:08:36 <dmcbride_> ok - time to wrap this up
04:08:47 <dmcbride_> anything else that anyone would like to bring up?
04:09:23 <dmcbride_> ok - if you think of anything, please email me
04:09:35 <dmcbride_> thanks, everyone, for attending this week
04:09:43 <kubi001> dmcbride_: thanks
04:09:45 <huzhj> Thanks
04:09:50 <dmcbride_> I think that this meeting is working well so far
04:09:52 <yuyang_gabriel> Thanks dmcbride_
04:09:59 <dmcbride_> let me know if you would like any changes
04:10:06 <chigang> dmcbride_: thanks
04:10:08 <dmcbride_> ok - have a great day
04:10:14 <kubi001> bye
04:10:15 <dmcbride_> #endmeeting