#opnfv-release: OPNFV release

Meeting started by dmcbride at 16:00:03 UTC (full logs).

Meeting summary

  1. roll call (dmcbride, 16:00:10)
    1. David McBride (dmcbride, 16:00:15)
    2. Bryan Sullivan (bryan_att, 16:01:29)
    3. Stuart Mackie (StuartMackie, 16:03:23)
    4. Serg Melikyan (sergmelikyan, 16:03:30)
    5. Morgan Richomme (morgan_orange, 16:04:05)
    6. Tim Rozet (trozet, 16:04:12)
    7. Trevor Cooper (trevor_intel, 16:04:19)
    8. Jose Lausuch (jose_lausuch, 16:04:34)
    9. Georg Kunz (georgk, 16:05:37)
    10. Maryam Tahhan (mtahhan, 16:06:05)

  2. MS6 (dmcbride, 16:08:22)
    1. https://wiki.opnfv.org/display/SWREL/Milestone+Compliance+for+Danube (dmcbride, 16:08:29)
    2. https://wiki.opnfv.org/display/DOC/Documentation+Guide (jose_lausuch, 16:11:52)
    3. will proposed documentation changes be rolled out for Danube, or for the E-release? (dmcbride, 16:13:35)
    4. ACTION: morgan_orange summarize proposal for testing section to be shared by mail with Sofia and community (morgan_orange, 16:31:51)

  3. MS7 - stable branch (dmcbride, 16:35:15)
    1. MS7 (March 10) closes the window (dmcbride, 16:36:30)
    2. https://wiki.opnfv.org/display/SWREL/Git+Tagging+Instructions+for+Danube (dmcbride, 16:37:46)
    3. git tagging instructions for Danube ^^ (dmcbride, 16:38:04)

  4. versioning (dmcbride, 16:44:32)
    1. suggest changing format of versioning (dmcbride, 16:46:05)
    2. for example, Colorado.1.0 would become 3.1.0-colorado (dmcbride, 16:47:01)
    3. 3.1.0 == 3.1.0-colorado (dmcbride, 16:48:09)
    4. follows conventional major.minor.patch labeling scheme (dmcbride, 16:48:36)
    5. ACTION: dmcbride to research how other upstream components do labeling (dmcbride, 16:50:45)
    6. https://releases.openstack.org/ (jmorgan1, 16:51:35)
    7. Bin points out that OpenStack simply uses a three digit label (dmcbride, 16:52:37)

  5. test milestones (dmcbride, 16:54:56)
    1. https://releases.openstack.org/ocata/ (bh526r, 16:55:05)
    2. jose_lausuch1 suggests "framework ready" (dmcbride, 16:55:16)
    3. See the version numbering in OpenStack Ocata release (bh526r, 16:55:31)
    4. jose_lausuch1 says this MS should fall before test case implementation (MS6) (dmcbride, 16:56:35)
    5. https://www.python.org/dev/peps/pep-0440/ (bh526r, 16:56:56)
    6. The above defines tagging format (bh526r, 16:57:05)
    7. e.g. 1.0.0, 1.0.0rc2, 3.0.5rc1 etc (bh526r, 16:57:37)
    8. trevor_intel says that test projects should follow feature release MSs as much as possible (dmcbride, 17:00:48)
    9. feature projects have dependencies on test projects (i.e. test framework must be integrated and functional in order for feature projects to implement and execute test cases in CI that use that framework) (dmcbride, 17:04:49)


Meeting ended at 17:05:07 UTC (full logs).

Action items

  1. morgan_orange summarize proposal for testing section to be shared by mail with Sofia and community
  2. dmcbride to research how other upstream components do labeling


Action items, by person

  1. dmcbride
    1. dmcbride to research how other upstream components do labeling
  2. morgan_orange
    1. morgan_orange summarize proposal for testing section to be shared by mail with Sofia and community


People present (lines said)

  1. dmcbride (24)
  2. bh526r (5)
  3. collabot` (3)
  4. mtahhan (2)
  5. morgan_orange (2)
  6. jose_lausuch (2)
  7. trevor_intel (1)
  8. bryan_att (1)
  9. trozet (1)
  10. StuartMackie (1)
  11. sergmelikyan (1)
  12. georgk (1)
  13. jose_lausuch1 (1)
  14. jmorgan1 (1)


Generated by MeetBot 0.1.4.