16:00:03 <dmcbride> #startmeeting OPNFV release
16:00:03 <collabot`> Meeting started Tue Feb 28 16:00:03 2017 UTC.  The chair is dmcbride. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:03 <collabot`> The meeting name has been set to 'opnfv_release'
16:00:10 <dmcbride> #topic roll call
16:00:15 <dmcbride> #info David McBride
16:01:29 <bryan_att> #info Bryan Sullivan
16:03:23 <StuartMackie> #info Stuart Mackie
16:03:30 <sergmelikyan> #info Serg Melikyan
16:04:05 <morgan_orange> #info Morgan Richomme
16:04:12 <trozet> #info Tim Rozet
16:04:19 <trevor_intel> #info Trevor Cooper
16:04:34 <jose_lausuch> #info Jose Lausuch
16:05:37 <georgk> #info Georg Kunz
16:06:05 <mtahhan> #info Maryam Tahhan
16:06:09 <mtahhan> available on IRC only today
16:08:22 <dmcbride> #topic MS6
16:08:29 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Milestone+Compliance+for+Danube
16:11:52 <jose_lausuch> #link https://wiki.opnfv.org/display/DOC/Documentation+Guide
16:13:35 <dmcbride> #info will proposed documentation changes be rolled out for Danube, or for the E-release?
16:31:51 <morgan_orange> #action morgan_orange summarize proposal for testing section to be shared by mail with Sofia and community
16:35:15 <dmcbride> #topic MS7 - stable branch
16:36:30 <dmcbride> #info MS7 (March 10) closes the window
16:37:46 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Git+Tagging+Instructions+for+Danube
16:38:04 <dmcbride> #info git tagging instructions for Danube ^^
16:44:32 <dmcbride> #topic versioning
16:46:05 <dmcbride> #info suggest changing format of versioning
16:46:11 <jose_lausuch1> jmorgan1: colorado.1.0 vs  3.1.0-colorado
16:47:01 <dmcbride> #info for example, Colorado.1.0 would become 3.1.0-colorado
16:48:09 <dmcbride> #info 3.1.0 == 3.1.0-colorado
16:48:36 <dmcbride> #info follows conventional major.minor.patch labeling scheme
16:50:45 <dmcbride> #action dmcbride to research how other upstream components do labeling
16:51:35 <jmorgan1> #link https://releases.openstack.org/
16:52:37 <dmcbride> #info Bin points out that OpenStack simply uses a three digit label
16:54:56 <dmcbride> #topic test milestones
16:55:05 <bh526r> #link https://releases.openstack.org/ocata/
16:55:16 <dmcbride> #info jose_lausuch1 suggests "framework ready"
16:55:31 <bh526r> #info See the version numbering in OpenStack Ocata release
16:56:35 <dmcbride> #info jose_lausuch1 says this MS should fall before test case implementation (MS6)
16:56:56 <bh526r> #link https://www.python.org/dev/peps/pep-0440/
16:57:05 <bh526r> #info The above defines tagging format
16:57:29 <dmcbride> thanks bh526r
16:57:37 <bh526r> #info e.g. 1.0.0, 1.0.0rc2, 3.0.5rc1 etc
17:00:48 <dmcbride> #info trevor_intel says that test projects should follow feature release MSs as much as possible
17:04:49 <dmcbride> #info feature projects have dependencies on test projects (i.e. test framework must be integrated and functional in order for feature projects to implement and execute test cases in CI that use that framework)
17:05:07 <dmcbride> #endmeeting