15:02:37 <dmcbride> #startmeeting OPNFV release
15:02:37 <collabot`> Meeting started Tue Apr 11 15:02:37 2017 UTC.  The chair is dmcbride. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:37 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:37 <collabot`> The meeting name has been set to 'opnfv_release'
15:02:45 <dmcbride> #topic roll call
15:02:49 <dmcbride> #info David McBride
15:06:39 <dmcbride> #chair tallgren
15:06:39 <collabot`> Current chairs: dmcbride tallgren
15:06:54 <jose_lausuch> #info Jose Lausuch
15:06:58 <Greg_E_> #info Greg Elkinbard
15:07:05 <tallgren> #info Tapio Tallgren
15:07:07 <StuartMackie> #info Stuart Mackie
15:07:43 <rpaik> #info Ray Paik
15:07:55 <dmcbride> #chair rpaik
15:07:55 <collabot`> Current chairs: dmcbride rpaik tallgren
15:08:26 <rpaik> doesn't look like everyone has the correct GTM link
15:08:33 <sofiawallin> #info Sofia Wallin
15:09:05 <Greg_E_> https://www.gotomeeting.com/join/775124285
15:09:45 <rpaik> I also posted on #opnfv-meeting
15:10:51 <tallgren> #topic Milestone 1 - release planning
15:11:28 <dmcbride> #info still lacking a release template
15:11:36 <rpaik> #info dmcbride notes that release plan template maybe something that is needed
15:11:48 <dmcbride> #info HKirksey asks whether we need a release template
15:12:22 <dmcbride> #info perhaps a template is useful for new projects, but less necessary for more experienced projects
15:14:14 <tallgren> #info dneary asks whether joining the release is a worthwhile goals for many projects
15:16:10 <rpaik> #info frankbrockners notes that template would be helpful for those that are new to the community and would be good to factor in project types (e.g. testing, development, etc.)
15:17:45 <trevor_intel_> #info Trevor Cooper
15:18:43 <rpaik> #info jmorgan1 notes that it would be helpful to have Jira tickets associates with items in the release plan
15:19:34 <dmcbride> #info bryan_att cautions against putting too much effort into creating a template
15:22:07 <tallgren> #info The resource needs of project should be known earlier in the cycle
15:22:47 <tallgren> #fdegir points out that the release needs must be followed during the release cycle
15:22:54 <tallgren> #undo
15:22:54 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2251890>
15:23:01 <tallgren> #info fdegir points out that the release needs must be followed during the release cycle
15:23:53 <dmcbride> #info fdegir points out the need to refresh CI resource req throughout the release cycle
15:24:39 <tallgren> #topic Milestone 2 - Communicate test requirements
15:26:16 <rpaik> #info dmcbride notes that he plans to simplify questions for MS2 (test case requirements)
15:34:10 <tallgren> #info There were problems in testing Kubernetes but jose_lausuch points out that the test frameworks are being extended to include it
15:34:25 <bryan_att> #info Bryan Sullivan
15:36:57 <bryan_att> #info re the last point we should add or strengthen project plan checks in which the project clarifies how their scope is covered by feature tests (e.g. Tempest or other), and if that coverage is incomplete (we're not bored yet) they include plans to make progress toward better coverage in the release.
15:40:10 <bryan_att> #info we should get the installer projects to give a little more detail as to what the issue was with Danube/Newton late readiness, so we can know whether the issue is likely to continue and what if anything we can do to improve the situation and de-risk future readiness for feature project development/testing.
15:41:06 <bryan_att> #info e.g. the issue may be resources, upstream dependency/cadence issues, issues not expected to repeat (e.g. major lab move), ...
15:41:13 <rpaik> #info radez asks if MS3 & MS4 could be collapsed
15:41:41 <tallgren> #info Discussion about whether installer milestone should be earlier than the test framework milestone
15:42:45 <dmcbride> #info bryan_att asks whether installer projects could do a retrospective on openstack integration experience in Danube
15:43:01 <bryan_att> #info in general the approach we (AT&T) recommend and will pursue is to focus development effort on trunk for the current upstream release at all times, so we are not impeded; and to focus development effort on generic upstream environments that are not impacted by the installer integration schedule.
15:44:18 <bryan_att> #info as we are also proposing a new installer project (Armada), we will be a test subject for that (somewhat) ambitious (but ultimately crucial IMO) goal.
15:44:46 <rpaik> #action dmcbride to schedule a session on installer integration during the Plugfest in a few weeks
15:45:58 <tallgren> #topic Milestone 4 - Infrastructure Updates Completed
15:48:43 <tallgren> #info dmbride proposes including "Test framework ready" to milestone 4
15:50:08 <rpaik> #info MS4 is when installers need to pass smoke test with nosdn scenarios
15:50:44 <tallgren> #topic Milestone 5 - Scenario integration and Feature Freeze
15:53:53 <tallgren> #topic Milestone 6 - Test Case Implementation
15:59:03 <tallgren> #info Discussion between bryan_att and dmcbride about hiring an intern to automate the Milestone 6 compliance check
16:00:00 <rpaik> #info discussion on utilizing test dashboard information for MS6 compliance verification
16:00:52 <bryan_att> #info the verification that something is happening (e.g. feature project integration and successful test executions) is mine-able, so PTLs should not have to provide this information directly.
16:02:27 <dmcbride> #info we ran out of time at slide 10.  We will resume the retrospective at next week's release meeting.
16:02:33 <dmcbride> #endmeeting