#opnfv-sfc: OPNFV SFC weekly meeting: August 2, 2015

Meeting started by ebrjohn at 14:02:55 UTC (full logs).

Meeting summary

    1. Chris (on IRC only) (ChrisPriceAB, 14:03:26)
    2. ebrjohn Brady Johnson (ebrjohn, 14:04:27)
    3. Bryan Sullivan (bryan_att, 14:04:44)
    4. Tim Rozet (trozet, 14:04:45)
    5. Serge Manning (SergeM, 14:04:48)
    6. sridhar_ram Sridhar Ramaswamy (sridhar_ram, 14:04:49)
    7. Andre Fredette (afredette, 14:04:59)
    8. Nicolas Bouthors (bouthors, 14:05:00)
    9. Dan Radez (radez, 14:05:05)
    10. Brady will update the wiki for the AIs - 3 ongoing (bryan_att, 14:05:59)
    11. Provide input to scripts is ongoing (bryan_att, 14:06:30)
    12. 2nd is NSH-aware service functions (Paul); products are in development, looking for an image the project can use if possible (bryan_att, 14:07:24)
    13. 3rd (Uri) to investigate VNFM test driver (no update right now) (bryan_att, 14:08:19)
    14. Sridhar from the Tacker project is here (bryan_att, 14:09:13)
    15. Interested in bringing Tacker to this project, and moving up to NVFO (bryan_att, 14:09:37)
    16. looking at bringing Tim's github work into the Tacker repo, to instantiate VNFs and use the API to chain them; in future all VNFs will be written in TOSCA (bryan_att, 14:10:50)
    17. current approach is fine given that the TOSCA forwarding graph work is not completed (bryan_att, 14:11:18)
    18. ebrjohn: what about the dependencies between projects (bryan_att, 14:11:50)
    19. sridhar_ram: (describes the stack) there is a general top API with ODL as one mechanism; a clear path down currently (bryan_att, 14:13:19)
    20. ebrjohn: concerned about any cyclic dependencies (bryan_att, 14:13:40)
    21. sridhar_ram: will bring a diagram to discuss (bryan_att, 14:14:05)
    22. trozet: can we have more than one option to spec the chain (bryan_att, 14:15:39)
    23. https://github.com/openstack/networking-sfc/blob/master/doc/source/api.rst (trozet, 14:16:18)
    24. neutron SFC spec (trozet, 14:16:26)
    25. rprakash: we should focus this on the neutron APIs with passing parameters as needed; any MANO component could drive this not just Tacker; a more appropriate way but left to the team (bryan_att, 14:16:59)
    26. ebrjohn: should we move to bi-weekly meetings (bryan_att, 14:18:22)
    27. rprakash: weekly is needed until the C milestone (bryan_att, 14:18:49)
    28. bryan_att: agree (bryan_att, 14:18:57)
    29. ebrjohn: can create openstack vxlan ports first (bryan_att, 14:20:10)
    30. (colleague explains the issue) (bryan_att, 14:21:17)
    31. ACTION: ferenc will send a document explaining the results (ebrjohn, 14:23:14)
    32. trozet: you can't add a vxlan port in neutron - it requires code changes (bryan_att, 14:24:09)
    33. iben: does this need a new feature? (bryan_att, 14:24:25)
    34. ebrjohn: ferenc is working on that in the lab; issue may be using vxlan ports for another purpose than tenant separation (bryan_att, 14:24:58)
    35. edwarnicke: the problem is how ODL using forwarding tags; we are looking for hackarounds; but could someone address the root cause? (bryan_att, 14:25:47)
    36. ebrjohn: we are looing at patches to OVS to fix the root cause (bryan_att, 14:26:06)
    37. edwarnicke: we need avoid a pile of hackarounds (bryan_att, 14:26:27)
    38. edwarnicke: we need a push/pop of vxlan headers via openflow; it's a pure OVS issue (bryan_att, 14:28:17)
    39. ebrjohn: add to slides that Sam has started (bryan_att, 14:29:08)
    40. edwarnicke: the slides sent to the listr describe the need for a push/pop in openflow for vxlan (bryan_att, 14:29:54)
    41. ebrjohn: we have an arch doc; we should add this to it (bryan_att, 14:30:10)
    42. ebrjohn: we have this in a google doc now (bryan_att, 14:30:42)
    43. bryan_att: I can help put this in git as soon as its ready so we can use the OPNFV toolchain (which we should be using) (bryan_att, 14:31:06)
    44. https://docs.google.com/document/d/1aoKYiExPtzyt3whETszeGh9neSKk2FpqxhgbGa0dkG0/edit OPNFV SFC Arch doc (ebrjohn, 14:31:31)
    45. iben: we are looking to pass the virtual NIC into the VM, bypassing OVS; would that be a workaround? (bryan_att, 14:31:36)
    46. (calls for more description of the idea) (bryan_att, 14:31:56)
    47. ACTION: edwarnicke will add the actual path a packet will take from SFF to SF (ebrjohn, 14:32:01)
    48. iben: SR-IOV as an example passes traffic straight to the VMs; OVS would be in the VM rather than the hypervisor (bryan_att, 14:32:33)
    49. edwarnicke: various questions come to mind but not looking at that as an option (bryan_att, 14:32:56)
    50. sriov for openstack kilo https://wiki.openstack.org/wiki/SR-IOV-Passthrough-For-Networking (iben, 14:33:15)
    51. rprakash: that prevents control/data plane separation (bryan_att, 14:33:16)
    52. trozet: can we get someone to work on the rool cause (push/pop) in OVS? (bryan_att, 14:33:36)
    53. ebrjohn: that would be great; but need to coordinate with NSH patch upstreaming (bryan_att, 14:34:14)
    54. paulq: existing patches are ready to go any day; they are done (bryan_att, 14:34:28)
    55. ebrjohn: OVS is picky; can just make it easier by coordinating? (bryan_att, 14:34:59)
    56. alagalah: that's not so easy (bryan_att, 14:35:18)
    57. rprakash: (describes an issue with OVS and SFC) (bryan_att, 14:36:22)
    58. (comments about IETF drafts and implementations) (bryan_att, 14:39:44)
    59. bryan_att: re drafts, we have one about MPLS based SFC; we need to ensure a common model and support in OpenStack for the various SFC methods OPNFV will support (bryan_att, 14:40:19)
    60. ebrjohn: need volunteers to help trozet in his implementation in Tacker (bryan_att, 14:41:00)
    61. ebrjohn: need more members helping out (bryan_att, 14:41:28)
    62. rprakash: will help (bryan_att, 14:41:56)
    63. bryan_att: is the work on github? (bryan_att, 14:42:22)
    64. trozet: need to define a spec first for input to OpenStack (bryan_att, 14:42:37)
    65. trozet: looking for help with code and spec; code is currently in github but will move to OpenStack as soon as the spec is accepted (bryan_att, 14:43:36)
    66. https://github.com/trozet/tacker/tree/SFC (trozet, 14:43:44)
    67. https://github.com/trozet/python-tackerclient/tree/SFC (trozet, 14:43:59)
    68. bryan_att: we will also help to the extent we can (bryan_att, 14:44:02)
    69. https://github.com/trozet/tacker-horizon/tree/SFC (trozet, 14:44:14)
    70. https://github.com/trozet/sfc-random/blob/master/tacker_sfc_walkthrough.txt (trozet, 14:44:28)
    71. ebrjohn: haven't looked deeply into the installer discussion (bryan_att, 14:44:50)
    72. bryan_att: we have to ensure the max support for SFC by not focusing all effort on a single installer (bryan_att, 14:46:16)
    73. trozet: engage with genesis project and put requirement on the installers (bryan_att, 14:46:59)
    74. bryan_att: that process is new to me but sounds OK - we need to ensure that it's shared with all projects (bryan_att, 14:48:19)
    75. iben: concerned about the impact to installers having to support all projects (bryan_att, 14:48:50)
    76. trozet: if an installer is part of B release then it needs to support all requirements agreed in genesis (bryan_att, 14:49:17)
    77. iben: how do we address project-specific needs; likely need to work in parallel in some cases (bryan_att, 14:50:11)
    78. ebrjohn: we need a special version of OVS with NSH patches; will that cause a problem with genesis? (bryan_att, 14:50:40)
    79. trozet: there are other examples of similar requjirements; it needs to be sent to genesis (bryan_att, 14:51:11)
    80. trozet: there is a generic guideline for now; send an email to the genesis alias and a requirement in Jira; genesis will then vote on it as a requirement (bryan_att, 14:53:05)
    81. ACTION: trozet to send out genesis wiki guidelines (ebrjohn, 14:53:22)
    82. bryan_att: we need to know how this requirement relates to the C milestone (bryan_att, 14:54:01)
    83. ebrjohn: how do we choose an installer if generis can't support our requirements for B (bryan_att, 14:54:34)
    84. iben: you can use your own scripts for now (bryan_att, 14:54:55)
    85. iben: need to show a working setup in a lab; that will lead to a gap assessment in genesis (bryan_att, 14:55:28)
    86. ebrjohn: installation of SFC in the E/// lab will be brought to the meeting next week as an example (bryan_att, 14:57:19)
    87. trozet: devstack just needs the right features and tacker to openstack (bryan_att, 14:57:37)
    88. ebrjohn: will get action points and wiki updated (bryan_att, 14:58:22)


Meeting ended at 15:48:51 UTC (full logs).

Action items

  1. ferenc will send a document explaining the results
  2. edwarnicke will add the actual path a packet will take from SFF to SF
  3. trozet to send out genesis wiki guidelines


Action items, by person

  1. trozet
    1. trozet to send out genesis wiki guidelines
  2. UNASSIGNED
    1. ferenc will send a document explaining the results
    2. edwarnicke will add the actual path a packet will take from SFF to SF


People present (lines said)

  1. bryan_att (85)
  2. ethfci (12)
  3. ebrjohn (10)
  4. trozet (7)
  5. iben (6)
  6. fbl (6)
  7. ChrisPriceAB (5)
  8. collabot (4)
  9. alagalah (2)
  10. SergeM (1)
  11. rprakash (1)
  12. sridhar_ram (1)
  13. radez (1)
  14. bouthors (1)
  15. afredette (1)


Generated by MeetBot 0.1.4.