#opnfv-sfc: OPNFV SFC weekly meeting

Meeting started by ebrjohn at 14:03:44 UTC (full logs).

Meeting summary

    1. Tim Rozet (trozet, 14:04:36)
    2. Chris Price (IRC only) (ChrisPriceAB, 14:04:55)
    3. ebrjohn Brady Johnson (ebrjohn, 14:06:03)
    4. rprakash (rprakash, 14:06:18)
    5. Bryan Sullivan (bryan_att, 14:06:27)
    6. pcarver Paul Carver AT&T (pcarver, 14:06:35)
    7. sridhar_ram Sridhar Ramaswamy (Tacker) (sridhar_ram, 14:06:46)
    8. yuyang (yuyang, 14:07:49)
    9. iben rodriguez spirent (iben__, 14:07:52)
    10. Eric Multanen (snackewm, 14:08:07)
    11. will take notes (rprakash, 14:08:35)
    12. https://www.ietf.org/meeting/94/ IETF 94 hackfest (ebrjohn, 14:09:06)
    13. OPNFV SFC does not need more than normal installation (rprakash, 14:11:32)
    14. except for two dependencies Tacker and specific type of OVS (rprakash, 14:12:12)
    15. Paul Quin not available leaving NSH item open for now (rprakash, 14:12:57)
    16. add to agenda starting aVM with VXLAN (rprakash, 14:14:03)
    17. Ference on SFC Architecture (rprakash, 14:15:03)
    18. Ferenc is showing how OpenStack starts a VM with vxlan (ebrjohn, 14:15:37)
    19. https://docs.google.com/presentation/d/1MRlvs-49PO2ZrYJdZ1UVAdl5FYPSUCTd-PR2lCkiPtQ/edit#slide=id.gc7f034de0_0_29 How OpenStack starts a VM with vxlan (ebrjohn, 14:17:03)
    20. Control & Data plane with management and overlay plan networks (rprakash, 14:17:35)
    21. currently using IP/MPLS header and when NSH ready OVS is available will swicthn over to the same (rprakash, 14:25:34)
    22. OpenStack uses creates network for tenant isolation using VXLAN that may conflict with ODLwas the question (rprakash, 14:27:59)
    23. ODL uses for vm on host to another vm on to another through br-int through tun and thus uses different VNI from Tenant allocated by Openstack and hus avoiding conflict (rprakash, 14:30:22)
    24. will need to be verified and or live with this limitation for ghis release (rprakash, 14:30:58)
    25. sridhar can you pound in the link? (rprakash, 14:33:21)
    26. https://docs.google.com/presentation/d/18AGaiysVgHOd_fIHVpObMO7zUkMjJGOQ98CUwkxU1xo/edit?usp=sharing (sridhar_ram, 14:35:01)
    27. function without NSH will need code change what Sam had presented using VRM (rprakash, 14:35:33)
    28. Dan has started simple scripts to bring VM inside Openstack using intercepting service function and send it to ODL which Takcer will us in short term (rprakash, 14:39:01)
    29. This will help flush out the flows to test using Tacker (rprakash, 14:40:12)
    30. slide 5 on Tacker slides shows the SFC API being used through RESTful API (rprakash, 14:42:58)
    31. Few people from Yardstick reached out for testing and wanted to know about Infra to ensure that they get ready for testing (rprakash, 14:44:42)
    32. Basic Pharos setup of 3 or 5 nodes should suffice no need for HA for now (rprakash, 14:47:04)
    33. NSH release being OVS 2,5 is a concern and not Openstack dependencies or changes (rprakash, 14:49:33)
    34. ACTION: Hose to send email to list for starting efforts for testing sfc (rprakash, 14:50:40)
    35. ACTION: Joseto send email to list for starting efforts for testing sfc (rprakash, 14:51:08)
    36. what kid of tests are available now? (rprakash, 14:51:30)
    37. currently only Tempest is used thus only a Platform API level plus some for ODL Robo (rprakash, 14:52:44)
    38. Func_Test uses Robo and thus needs only scenerios like VM creating , chaining etc to help testing (rprakash, 14:54:12)
    39. SF C will be an intresting use case for Func_Test (rprakash, 14:54:56)
    40. where does the test start which lab and transitions to which lab? (rprakash, 14:55:40)
    41. LF lab and Ericsson Lab or any community lab and in end JJB will rn SFC from LF (rprakash, 14:56:56)
    42. Jira Entry needs to be completed for B release and so high level story needs some enry for meeting Milestone (rprakash, 14:58:38)
    43. ACTION: Brady Get started on JIRA. Make it a topic on next week's meeting agenda. (ebrjohn, 14:59:14)
    44. its Iben (rprakash, 15:00:02)
    45. ACTION: an irc meeting or ether pad entry will help close the gap for Jira entry (rprakash, 15:01:14)


Meeting ended at 15:01:55 UTC (full logs).

Action items

  1. Hose to send email to list for starting efforts for testing sfc
  2. Joseto send email to list for starting efforts for testing sfc
  3. Brady Get started on JIRA. Make it a topic on next week's meeting agenda.
  4. an irc meeting or ether pad entry will help close the gap for Jira entry


People present (lines said)

  1. rprakash (34)
  2. ebrjohn (12)
  3. collabot (5)
  4. iben__ (3)
  5. sridhar_ram (3)
  6. ChrisPriceAB (3)
  7. yuyang (2)
  8. ethfci (1)
  9. bryan_att (1)
  10. pcarver (1)
  11. snackewm (1)
  12. trozet (1)


Generated by MeetBot 0.1.4.