#opnfv-sfc: SFC weekly meeting, September 23, 2015

Meeting started by ebrjohn at 14:04:09 UTC (full logs).

Meeting summary

    1. yuyang (yuyang, 14:04:37)
    2. ebrjohn Brady Johnson (ebrjohn, 14:04:40)
    3. rprakash (rprakash, 14:05:04)
    4. Tim Rozet (trozet, 14:05:44)
    5. nbouthors (nbouthors, 14:05:50)
    6. Ana Cunha (anac1, 14:05:57)
    7. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-September/005307.html Agenda (ebrjohn, 14:06:02)
    8. https://wiki.opnfv.org/service_function_chaining#pending_action_items_from_previous_meetings Pending Action Items (ebrjohn, 14:06:26)
    9. Serge Manning (SergeM, 14:06:50)
    10. https://docs.google.com/presentation/d/1GEt8Vi6hQL9kOk-nowxr3o9aE_VYoe5zljz8MyQtdgw/edit#slide=id.ga24bea9f8_0_19 OPNFV SFC Brahmaputra Release Planning (ebrjohn, 14:10:34)
    11. acgion item left on the adding sub-tasks to Jira (rprakash, 14:10:35)
    12. refer document planning in Jira and psprint planning (rprakash, 14:11:30)
    13. sprint plan for C1,C2,C3 is each 3 weeks (rprakash, 14:12:16)
    14. Milestone D Feture Freeze Dec 1 (rprakash, 14:14:23)
    15. milestne D Dec 1 (rprakash, 14:14:40)
    16. spint planning starts with rlease pan , feature API/Freez coding and testing (rprakash, 14:18:02)
    17. AGREED: The OPNFV SFC community agrees to the sprint definitions and their durations as outlined here: https://docs.google.com/presentation/d/1GEt8Vi6hQL9kOk-nowxr3o9aE_VYoe5zljz8MyQtdgw/edit#slide=id.gc95187d09_0_1 (ebrjohn, 14:18:23)
    18. https://jira.opnfv.org/browse/SFC-1?jql=project%20%3D%20SFC%20AND%20resolution%20%3D%20Unresolved%20AND%20issuetype%20%3D%20Epic%20ORDER%20BY%20priority%20DESC OPNFV SFC Epics (ebrjohn, 14:19:59)
    19. added SFC1-5 edipcs/stories (rprakash, 14:20:24)
    20. additional sub-tasks SFC-12-15istallation scripts (rprakash, 14:22:39)
    21. kraf in ODL subtask includes GBP (rprakash, 14:23:38)
    22. CLI for ODl (rprakash, 14:24:27)
    23. rprakash, We could potentially leverage some of OPNFV PolicyTest too... we are moving our (soon to be merged) GBPSFC CSIT environment into OPNFV as part of PolicyTest (alagalah, 14:26:02)
    24. ODL bundles to install in Berrylium will be taken later but will be part of post-install (rprakash, 14:26:42)
    25. SFC-4 is the use case and most ipmportnat driver (rprakash, 14:27:54)
    26. Larry Lamers (VMware) (ljlamers_, 14:30:00)
    27. Block http in SF1 and Block ssh in SF2 in chain with 3 Flow classification is what we need to do (rprakash, 14:30:19)
    28. there may be blocks in NSH we will see hpw to overcome that (rprakash, 14:31:13)
    29. SFC-9 (static install - ODL config static ) Min use case story (rprakash, 14:32:33)
    30. SFC-10 use case with VNFMGR simulated with communication to Openstack (rprakash, 14:33:16)
    31. SFC-11 use case with Tacker based (rprakash, 14:33:43)
    32. Keith Burns is getting PolicyTest into SFC and may need co-ordination (rprakash, 14:36:57)
    33. we are working with Fuc_Test and Yardstick to get the SFC testing co-ordinated (rprakash, 14:37:59)
    34. corretcion Func_Test (rprakash, 14:38:21)
    35. ACTION: add a use case test to the Use Case Epic (ebrjohn, 14:40:59)
    36. SFC-5 is a single create the necessary testing may not suffice, so test u nder each use cae make sense (rprakash, 14:41:09)
    37. ACTION: Bruce Johnson to review the test and update (rprakash, 14:42:49)
    38. sample test case is client 1,2,3 will (http,ssh) allow/disallow cobminations (rprakash, 14:43:48)
    39. Yardstick framework to use or use Func_test tools like Robot/Rally etc (rprakash, 14:44:54)
    40. seems need some discussion between Yardstick and Func_test (rprakash, 14:48:19)
    41. Jose & Ana to discuss and get some inputs for test plan for 3 use cases (rprakash, 14:51:18)
    42. ACTION: anac1 Send an email to the SFC list to get information about the OPNFV SFC Brahmaputra testing scope (ebrjohn, 14:52:21)
    43. send any changes to mailing list before the Milestone-C deadline (rprakash, 14:58:20)
    44. OCt 11 SDN world congress Brian to presen ODL SFC & OPNFV SFC and ODL Armoury with Mathew Innocyte, plus SFC demo (rprakash, 15:00:03)


Meeting ended at 15:01:16 UTC (full logs).

Action items

  1. add a use case test to the Use Case Epic
  2. Bruce Johnson to review the test and update
  3. anac1 Send an email to the SFC list to get information about the OPNFV SFC Brahmaputra testing scope


Action items, by person

  1. anac1
    1. anac1 Send an email to the SFC list to get information about the OPNFV SFC Brahmaputra testing scope
  2. UNASSIGNED
    1. add a use case test to the Use Case Epic
    2. Bruce Johnson to review the test and update


People present (lines said)

  1. rprakash (35)
  2. ebrjohn (13)
  3. collabot (3)
  4. alagalah (3)
  5. yuyang (1)
  6. SergeM (1)
  7. anac1 (1)
  8. nbouthors (1)
  9. mbound (1)
  10. trozet (1)
  11. ljlamers_ (1)


Generated by MeetBot 0.1.4.