15:00:31 <ebrjohn> #startmeeting weekly OPNFV SFC meeting
15:00:31 <collabot> Meeting started Wed Dec 14 15:00:31 2016 UTC.  The chair is ebrjohn. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:31 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:31 <collabot> The meeting name has been set to 'weekly_opnfv_sfc_meeting'
15:00:46 <ebrjohn> #info Brady Johnson
15:01:10 <Vijayendra> #info Vijayendra Radhakrishna
15:01:30 <jvidal> #info Juan Vidal
15:01:42 <geopar> #info George Paraskevopoulos
15:01:46 <ljlamers_> #info Larry Lamers
15:01:55 <ebrjohn> #link https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-December/014104.html meeting agenda
15:02:54 <ebrjohn> #topic ETSI PlugTest
15:03:08 <ebrjohn> #link http://www.etsi.org/news-events/events/1104-1st-nfv-plugtests ETSI PlugTest
15:03:46 <ebrjohn> #info Will be held in Madrid, Spain January 2017
15:03:54 <ebrjohn> #info we will deploy at least one server with OPNFV SFC and make it available for MANO providers to test with SFC
15:05:00 <ebrjohn> #topic Testing different topologies
15:05:19 <ebrjohn> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2016-December/002477.html Yesterday Manuel reported this problem
15:05:31 <ebrjohn> #info netvirt only creates classification rules on compute nodes where there are SFs.
15:06:11 <ebrjohn> #info Classification rules should probably be created on every compute. Or at least everywhere there's a VM of any type.
15:06:30 <ebrjohn> #info We need to make sure we cover additional possibly problematic topologies and/or configurations
15:06:59 <juanmafg> #info Juanma Fernandez
15:07:15 <geopar> #link https://jira.opnfv.org/browse/SFC-63
15:07:23 <ebrjohn> #info example: Everything on the same compute node: client, SFF, SF, server. I believe this is the first case ever tested.
15:08:10 <ebrjohn> #info example: Classifier and SFF on different compute nodes. This is the problem reported above by Manuel
15:08:21 <ebrjohn> #info example: SFs on different compute nodes
15:08:31 <ebrjohn> #info example: 3 SFs on 2 compute nodes, packets have to go from computeA to computeB and back to computeA
15:10:49 <ebrjohn> #info geopar 2 SFs on the same chain or 2 SFs on different chains
15:11:46 <ebrjohn> #info we already have a test for symmetric service chains
15:12:16 <ebrjohn> #action ebrjohn to make sure these scenarios are covered in our test plan
15:12:40 <ebrjohn> #topic Stateful character of the tests
15:12:53 <ebrjohn> #info apparantly the tests arent completely torn down after being run, which could cause problems or hide problems for subsequent tests
15:13:24 <priya> 2 SFs with differnet service functions
15:13:30 <ebrjohn> #info By torn down, I mean: classifiers deleted, all [RSPs, SFPs, SFCs, SFFs, SFs] deleted, SF VMs removed
15:15:37 <ebrjohn> #info seems like not all flows are deleted when SFC config deleted
15:16:04 <ebrjohn> #info if this is the case, then its an ODL SFC bug that we need to get fixed
15:16:23 <ebrjohn> #info juanmafg asks if some of the flows are from security groups that Manuel manually creates
15:17:56 <ebrjohn> #info geopar suggests we can cycle through the different test cases, one per day
15:18:48 <ebrjohn> #info ebrjohn suggests to use this as a work-around until we get all flows deleted in ODL
15:19:40 <geopar> #action geopar: send a mail to netvirt-dev / sfc-dev about cleanup
15:19:57 <ebrjohn> priya: I think you meant 2 SFs with 2 service chains... I already covered that above
15:20:13 <priya> ebrjohn, yeah
15:20:27 <ebrjohn> #info geopar will send an email tomorrow about ODL flow cleanup
15:23:01 <ebrjohn> #info juanmafg asks if we also delete floating IPs
15:23:15 <ebrjohn> #info ebrjohn not sure, but thinks it should be checked and also deleted
15:23:25 <ebrjohn> #topic AOB (Any Other Business)
15:24:02 <ebrjohn> #info geopar asks when do we want to move to Tacker upstream
15:25:12 <ebrjohn> #info ebrjohn is not sure when, but it mainly depends on the impacts involved, mainly if upstream Tacker is using Networking SFC
15:27:20 <ebrjohn> #action ebrjohn to ask Tim Rozet what's involved with switching to Tacker upstream
15:28:27 <Vijayendra> Are we gonna test these testcases planned on ovs + dpdk also?
15:28:58 <ebrjohn> Vijayendra: good question
15:30:19 <ebrjohn> #info Vijayendra says Fuel already has a plugin for OVS+dpdk+NSH
15:31:05 <ebrjohn> #info Vijayendra suggests using the same test cases for DPDK
15:32:03 <ebrjohn> #info Vijayendra says he would be willing to help contribute to DPDK testing
15:32:53 <ebrjohn> #action ebrjohn to check when the ODL SFC DPDK patch was added and if its in Boron
15:35:07 <ebrjohn> #info ebrjohn thinks the ODL SFC DPDK patch has already been included in Boron SR1
15:37:03 <ebrjohn> #info OVS 2.6.1 with NSH from Yi Yang has been tested by Manuel and George and it seems to be working
15:37:36 <ebrjohn> #info Manuel got the VXLAN tunnel port problem fixed in OVS 2.6.1
15:38:21 <ebrjohn> #endmeeting