10:01:21 <morgan_orange> #startmeeting functest weekly oct 27th
10:01:21 <collabot> Meeting started Tue Oct 27 10:01:21 2015 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:01:21 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:01:21 <collabot> The meeting name has been set to 'functest_weekly_oct_27th'
10:01:28 <morgan_orange> #info Morgan Richomme
10:01:34 <juhak> #info Juha Kosonen
10:01:40 <jose_lausuch> #info Jose Lausuch
10:01:49 <Valentin_Orange> #info Valentin Boucher
10:01:50 <jose_lausuch> I hope we have more participants than last week (only me)
10:01:51 <jose_lausuch> :)
10:02:32 <morgan_orange> I saw that (read the minutes)
10:02:45 <morgan_orange> #info agenda: https://wiki.opnfv.org/functest_meeting
10:02:57 <morgan_orange> #topic agenda bashing and action points
10:03:43 <morgan_orange> #info action point still to be completed (presentation for the summit)
10:03:53 <jose_lausuch> yes
10:04:00 <morgan_orange> #info pres started, i will send an updtae today or tomorrow (deadline 30th)
10:04:02 <jose_lausuch> i have a question here
10:04:24 <jose_lausuch> it has to be presented in pdf and 19:9
10:04:38 <jose_lausuch> is the javascript thing already usable?
10:05:07 <morgan_orange> it has not been merged and i am not sure it will
10:05:16 <morgan_orange> v=but I think it can be used if we want..
10:05:34 <viktor_nokia> #info Viktor Tikkanen
10:05:37 <jose_lausuch> I was thinking of doing it for now in powerpoint... since I got the template to use
10:05:46 <morgan_orange> what do you prefer ppt template or reveal format?
10:05:58 <jose_lausuch> I prefer reveal
10:06:04 <jose_lausuch> but its about time to do it
10:06:15 <jose_lausuch> maybe it takes longer in reveal? Since we have to get used
10:06:19 <jose_lausuch> and also adapt the tempates
10:06:21 <jose_lausuch> icons, and so on
10:06:29 <morgan_orange> it is pretty quick in reveal
10:06:40 <morgan_orange> the longest part is to get the picture you want to display
10:06:53 <morgan_orange> in html or markdown it is very quick to do
10:06:54 <jose_lausuch> it has to be converted to pdf inn the end
10:07:04 <morgan_orange> yes and reveal is not perfect for that
10:07:16 <morgan_orange> but we could also host the pres on a web server
10:07:19 <jose_lausuch> I saw :)
10:07:27 <morgan_orange> ok let's powerpointize for the moment
10:07:41 <jose_lausuch> I will use ppoint for functest in depth
10:07:48 <jose_lausuch> maybe we can try the other presentation we have in reveal
10:07:54 <morgan_orange> ok
10:08:05 <morgan_orange> I already started the reveal one on the dashboard
10:08:08 <jose_lausuch> ok
10:08:18 <morgan_orange> #topic Sprint2
10:08:38 <morgan_orange> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59&useStoredSettings=true
10:08:58 <morgan_orange> #info 9 days remaining (basically the end of this sprint will take place during the design summit
10:09:02 <jose_lausuch> pbandzi_: ping
10:09:08 <pbandzi_> pong
10:09:22 <jose_lausuch> hi
10:09:23 <jose_lausuch> https://jira.opnfv.org/browse/FUNCTEST-80
10:09:26 <jose_lausuch> do you agree with this?
10:09:32 <jose_lausuch> can you have a look later?
10:09:40 <morgan_orange> are you all Ok with the tasks assigned to you?
10:10:29 <jose_lausuch> yes
10:10:42 <jose_lausuch> there are a lot of tasks still not started
10:10:42 <pbandzi_> jose_lausuch: I'll look at it
10:10:46 <jose_lausuch> thanks pbandzi_
10:10:47 <morgan_orange> juhak: viktor_nokia pbandzi_ quinglong
10:10:50 <jose_lausuch> viktor_nokia: https://jira.opnfv.org/browse/FUNCTEST-72
10:11:00 <viktor_nokia> from my side there is no progress with FUNCTEST-72 (refactor tempest)
10:11:02 <jose_lausuch> can we discuss this later?
10:11:06 <viktor_nokia> OK
10:11:27 <jose_lausuch> morgan_orange: can we still create epics?
10:11:33 <morgan_orange> yes
10:11:34 <jose_lausuch> there are some tasks that are not included in an epic
10:11:42 <jose_lausuch> for example there is no epic for docker
10:11:44 <morgan_orange> and I must rename them
10:11:53 <morgan_orange> FUNCTEST_X is  not very explicit
10:11:59 <juhak> no progess with FUNCTEST-71 either
10:11:59 <jose_lausuch> :)
10:12:00 <morgan_orange> but we can create new ones
10:12:31 <morgan_orange> juhak: any progress/question regarding for https://jira.opnfv.org/browse/FUNCTEST-71 ?
10:13:07 <juhak> no progress yet
10:13:14 <morgan_orange> pbandzi_: still Ok to look at the robot based testcases we could import from ODL?
10:13:25 <morgan_orange> I just opened the github pages
10:13:33 <morgan_orange> there are quiete a lot of tests
10:13:52 <morgan_orange> #action morgan_orange rename epics to be more explicit
10:14:19 <pbandzi_> morgan_orange: still ok - i have it on my todo list :)
10:14:22 <morgan_orange> #info Jose added new tasks (dockerization + running functest offline)
10:14:23 <jose_lausuch> I can give you a hand with that morgan_orange
10:15:35 <morgan_orange> ok cool  pbandzi_, do not hesitate (as you are also buzy by the management of LF infra) of we need additional resources to address this selection (from ODL project)
10:15:47 <jose_lausuch> pbandzi_: I will create a task to take the IPs and ports from the config_functest.yaml file
10:16:02 <jose_lausuch> #info docker wiki updated https://wiki.opnfv.org/functest_docker
10:16:13 <morgan_orange> last week Quinglong said that he was able to run the tests on Huawei platform
10:16:21 <morgan_orange> so regarding the board
10:16:26 <jose_lausuch> #info possible now to run only a set of tests [vping,odl,tempest,rally] instead of all of them
10:16:28 <morgan_orange> I am confident for this sprint
10:16:57 <morgan_orange> #info on vIMS soon (working with Valentin_Orange today), we were able to deploy cloudify and met a timeout issue
10:17:52 <morgan_orange> any question on Sprint 2?
10:17:57 <jose_lausuch> morgan_orange: can you info the latests news about the dashboard ?
10:18:05 <jose_lausuch> discussionswith marion
10:18:07 <morgan_orange> yes
10:18:17 <morgan_orange> #info test collection API has been updated
10:18:51 <morgan_orange> #info a new method called dashboard has been added
10:19:18 <morgan_orange> #info this method retrieved "dashboard ready" data and will be used by LF web team in charge of the test dashboard
10:20:00 <morgan_orange> #info for the moment we defined 2 testcases "dashboard ready"
10:20:01 <morgan_orange> #link http://213.77.62.197/dashboard?project=functest&case=Tempest
10:20:07 <morgan_orange> #link http://213.77.62.197/dashboard?project=functest&case=vPing
10:20:33 <morgan_orange> #info for each testcase you can use filter (installer, version, pod, time )
10:20:40 <jose_lausuch> great
10:20:59 <morgan_orange> #link http://213.77.62.197/dashboard?project=functest&case=vPing&installer=fuel&version=master&pod=opnfv-jump-2
10:21:25 <morgan_orange> #info we store the results only once (the raw results of the tests)
10:21:53 <morgan_orange> #info then in releng through a method called functest2Dashboard.py we post processed the raw results to provide dashboard ready graphs
10:22:07 <jose_lausuch> ok
10:22:12 <morgan_orange> #link https://wiki.opnfv.org/collection_of_test_results
10:22:35 <jose_lausuch> it is well explained
10:22:40 <jose_lausuch> thanks for that wiki
10:22:47 <morgan_orange> pbandzi_: for odl you may use the APi to push the results of the tests as they are today
10:23:14 <pbandzi_> ok
10:23:18 <morgan_orange> then I could add a method in functest2Dashboard that will graph duration of the test = f(time) and nb test run/nb test failed  = f(time)
10:23:19 <morgan_orange> ...
10:23:39 <morgan_orange> #info Guy Rodrigue worked on an automatic doc (swagger like)
10:23:46 <morgan_orange> because wiki are difficult to maintain
10:24:04 <morgan_orange> #info we planned to work with Valentin_Orange to provide suwh results for vIMS testcase
10:24:39 <morgan_orange> #info LF foundation announced a version of the dashboard on the 9th of November
10:25:11 <morgan_orange> #info presentation planned during the summit
10:25:37 <morgan_orange> #info yardstick contributor shall also work on its yardstick2Dashboard.py file
10:25:45 <morgan_orange> ok with the dashboard?
10:26:12 <jose_lausuch> yes
10:26:16 <morgan_orange> there are still work (authentication, migration to target DB ...) but it is already possible to play with the APi and get dashboard ready info
10:26:17 <jose_lausuch> good work there
10:26:27 <jose_lausuch> fair enough
10:26:34 <jose_lausuch> I had an idea
10:26:41 <jose_lausuch> that we could use, all the test projects
10:26:45 <jose_lausuch> that report results
10:27:06 <jose_lausuch> when calling the script to run test X, we could add a flag to tell the script to report the results to the DB
10:27:12 <jose_lausuch> default=no
10:27:35 <morgan_orange> i think that you already implemented it? through the -r option when running tempest of vPing?
10:27:37 <jose_lausuch> we need to add it as an option
10:27:39 <morgan_orange> you mean a global option?
10:27:45 <jose_lausuch> for all the scripts
10:28:01 <morgan_orange> ok yes we could add such parameters
10:28:13 <jose_lausuch> in functest it is easy, but all should take it into account
10:28:18 <jose_lausuch> yardstick also
10:28:21 <morgan_orange> ok with default =no as theoretically the results shall be pushed from Pharos labs...
10:28:39 <morgan_orange> good transition to next point
10:29:13 <jose_lausuch> ok
10:29:15 <morgan_orange> #action jose_lausuch add a flag to tell the script to report the results to the DB and tell other test projects (info to share during the summit)
10:29:32 <jose_lausuch> :)
10:29:33 <morgan_orange> #topic   Running Functest in CI in new platforms
10:30:06 <morgan_orange> I am confident for Sprint 2, but I feel some concern for post Sprint 2 and especially with the integration of the feature tests and the CI
10:30:21 <morgan_orange> so far we run automatically our tests only on LF POD2 (now fuel Master)
10:30:31 <morgan_orange> BTW there is an issue regarding CI
10:31:00 <morgan_orange> https://build.opnfv.org/ci/view/functest/job/functest-fuel-master/
10:31:20 <morgan_orange> #action morgan_orange jose_lausuch look why CI is now failing on LF POD 2 (manual run of the container is OK)
10:31:28 <jose_lausuch> some problems with docker
10:31:32 <jose_lausuch> I'll take a look
10:31:37 <jose_lausuch> start.sh does not exist any more
10:31:42 <jose_lausuch> I will report it as a bug
10:31:50 <morgan_orange> I think it is important to ask Pharos resources
10:32:24 <morgan_orange> we need at least as many labs as installers assuming that their configuration may change (SDN controllers, specific OVS or KVM tuning to support feature tests)
10:32:53 <morgan_orange> fdegir: and trevor are working hard to provide a consisten view of the available resources
10:33:12 <jose_lausuch> thats inmportant
10:33:16 <morgan_orange> but we should now be able to run functest on at least 3 different PODs
10:33:34 <morgan_orange> (when cash on the installation like yesterday) => no more possible to work
10:34:00 <morgan_orange> regarding the candidates labs I see only (for the moment) Ericsson, Intel and Huawei
10:34:25 <morgan_orange> Huwaei we may ask Quinglong (as, as far as I understand, he is already performing tests for compass/onos)
10:34:46 <morgan_orange> #action morgan_orange ask Quinglong to deploy full functest on huawei lab trhough jenkins
10:34:59 <morgan_orange> jose_lausuch: could you on E/// side?
10:35:13 <jose_lausuch> I will ask for resources
10:35:38 <morgan_orange> #action morgan_orange ask trevor for Resources on intel  for apex
10:35:55 <morgan_orange> if we could have already Apex, fuel, compass, only joid will miss
10:36:06 <morgan_orange> we are installing a joid based solution in one orange Pods
10:36:18 <morgan_orange> then we will cover all the installer, which will be a good point...
10:36:25 <jose_lausuch> es
10:36:26 <jose_lausuch> yes
10:36:42 <morgan_orange> #action jose_lausuch ask for resources (run functest one one of the E/// pod)
10:37:40 <morgan_orange> and for the change of config, for the moment it is fuzzy for me. I assumed we have default combination compass/Onos, fuel/ODL ...but it is not fully clear
10:38:03 <jose_lausuch> maybe fuel will support o.contrail soon
10:38:14 <morgan_orange> ok
10:38:34 <morgan_orange> any question on the CI, needs for PODs..
10:39:27 <morgan_orange> #topic Design Summit and OPNFV Summit
10:39:28 <jose_lausuch> nop
10:39:48 <jose_lausuch> possible jam on tuesday :p
10:40:13 <morgan_orange> #info functest will be active. 1h tutorial from josé, presentation of the test collection API, and several presentations during the Summit
10:40:41 <morgan_orange> #info according to the dependencies, I think we need to meet at least 5 other projects
10:40:50 <morgan_orange> #link https://wiki.opnfv.org/feature_test_project_matrix
10:41:09 <jose_lausuch> yes
10:41:10 <morgan_orange> #info some high level Jira have been created, but they will surely not cover the needs
10:41:14 <jose_lausuch> there are project sessions
10:41:19 <morgan_orange> yes
10:41:20 <jose_lausuch> breakout sessions
10:41:23 <jose_lausuch> we could use them
10:41:36 <morgan_orange> yes
10:41:47 <morgan_orange> I think neither viktor_nokia nor juhak will attend
10:41:54 <morgan_orange> pbandzi_:  will you be there?
10:41:54 <viktor_nokia> no
10:41:57 <jose_lausuch> pitty
10:41:58 <juhak> nope
10:42:22 <jose_lausuch> pbandzi_: you?
10:42:32 <pbandzi_> morgan_orange : i ll be on summit on November
10:42:36 <jose_lausuch> great
10:42:37 <morgan_orange> Valentin_Orange: and Guy Rodrigue will not be there as well
10:42:48 <pbandzi_> not sure if you talk about that :)
10:42:52 <morgan_orange> ok Quinglong may also be there
10:43:40 <morgan_orange> so we will have to discuss with Copper, Doctor, ONOS, OVNO (Open Contrail), PolicyTest and Promise during the sessions to precise our Jira and see if we can help or not
10:44:11 <morgan_orange> #action morgan_orange prepare the Summit, contact PTL to discuss functest implication in Doctor, Copper, ONOS, OVNO, Policytest and promise
10:44:26 <morgan_orange> do you see othe stuff we must discuss during the Summit?
10:44:36 <morgan_orange> Open Mano?
10:45:02 <jose_lausuch> maybe
10:45:03 <viktor_nokia> BTW, our Doctor expert (Tomi Juvonen) will attend the summit
10:45:05 <morgan_orange> I know that China Mobile is interested to have a session on orrchestrator (Open O)
10:45:19 <jose_lausuch> but... we got some insights already 2 weeks ago in dusseldorf
10:45:24 <morgan_orange> #info Tomi Juvonen (Doctor) will attend the summit
10:45:35 <jose_lausuch> about OpenMano
10:45:36 <jose_lausuch> hehe
10:45:50 <jose_lausuch> we can discuss it with ChinaMobile..
10:45:59 <morgan_orange> my view regarding orchestrator (for the moment), Functest is using orchestrator to ease the run of tests
10:46:39 <morgan_orange> we are not integrating any orchestrator to OPNFV (it is out of scope for the moment)
10:46:50 <morgan_orange> just use them as tool (like Cloudify for vIMS testcase)
10:47:28 <morgan_orange> for B-Release we did not plan to add new testcases (Open Mano with pktgen VNF, Open X with testcase Y)
10:47:48 <morgan_orange> but we may start an exploring discussion on orchestrator during the Summit
10:47:59 <jose_lausuch> yes
10:48:00 <morgan_orange> what is your view on the different orchestrators?
10:48:20 <jose_lausuch> same as you
10:48:27 <jose_lausuch> since they are out of scope for release B
10:48:31 <morgan_orange> #info functest not dealing with orchestrator, just using some to ease the launch of tests
10:48:35 <jose_lausuch> we use in our own for the needed tests
10:48:48 <jose_lausuch> for the future we might have to handle it differently
10:49:34 <morgan_orange> #info ok for an exploring discussion during the Summit, see if for > C release, functest could propose one (still to ease the functional testing not as part as OPNFV)
10:50:19 <morgan_orange> juhak: viktor_nokia pbandzi_ j Valentin_Orange ..feel free to share your view on that (mailing thread)
10:50:29 <viktor_nokia> ok
10:50:37 <juhak> will do
10:51:00 <morgan_orange> so jose_lausuch SFC and BGP VPN will be managed by yardstick (my understanding)
10:51:52 <morgan_orange> #info Summit, jam session organization in progress...feel free to join :)
10:52:17 <jose_lausuch> ok
10:52:21 <morgan_orange> #topic Possible expectations for Nokia open lab
10:52:30 <viktor_nokia> a couple of words regarding (future) nokia open lab, should I info?
10:52:36 <morgan_orange> yes
10:52:50 <viktor_nokia> #info Nokia is seriously considering establishment of an open lab
10:52:58 <viktor_nokia> #info for Functest (and possibly some other OPNFV projects) testing purposes
10:53:10 <viktor_nokia> #info If you have any expectations regarding HW, network topology, access methods etc. please contact e.g. me or Juha
10:53:28 <viktor_nokia> in other words, we are trying to figure out what's the best way how we can help OPNFV community :)
10:53:35 <jose_lausuch> sounds good
10:53:37 <morgan_orange> good news
10:53:39 <morgan_orange> it will be connected to CI?
10:53:42 <viktor_nokia> or should we contact pharos guys next?...
10:53:56 <jose_lausuch> I think you should contact them, Trevor for example
10:54:03 <morgan_orange> and fdegir
10:54:03 <viktor_nokia> ok
10:54:08 <jose_lausuch> it would be nice if its connected to CI, as for LF labs
10:54:10 <jose_lausuch> and orange ones
10:54:15 <viktor_nokia> morgan_orange: not sure yet, possibly
10:54:52 <jose_lausuch> for HW specifications you can contact Aric maybe?
10:54:55 <viktor_nokia> we can discuss this (CI connection)later
10:54:58 <jose_lausuch> any hw in mind?
10:55:18 <jose_lausuch> hp, cisco,dell blades/servers?
10:55:33 <viktor_nokia> possibly HP or Nokia's own
10:55:45 <jose_lausuch> ok
10:55:57 <juhak> is there any info or guideline about the process for connecting a lab to CI?
10:56:12 <morgan_orange> OK I think in mid term it is important to have this connection to CI and to keep as transparent as possible on the results. It is not easy... same issues internally but at the end it will be a great added value for all the community
10:56:27 <morgan_orange> juhak: oh yes there is a good wiki page for that
10:57:38 <morgan_orange> I will find it (connection slow at the moment) and send it to you
10:57:38 <juhak> ok, good
10:57:49 <morgan_orange> #action morgan_orange send procedure for CI connectivy to juhak
10:58:11 <morgan_orange> pitty that you could not join the Summit
10:58:19 <viktor_nokia> :(
10:58:49 <morgan_orange> jose and myself are looking for a crazy finnish drummer or bas player or singer ...
10:59:04 <juhak> heh...
10:59:05 <jose_lausuch> hehe
10:59:07 <jose_lausuch> yes
10:59:31 <viktor_nokia> hard rock hallelujah
10:59:38 <morgan_orange> #topic AoB
10:59:49 <juhak> still waiting for OPNFV LF lab access
10:59:49 <morgan_orange> any other info to share?
11:00:01 <jose_lausuch> https://etherpad.opnfv.org/p/jam_session_summit
11:00:04 <morgan_orange> I think this time slot is more convenient for most of the contributors
11:00:19 <viktor_nokia> definitely...
11:00:51 <morgan_orange> ok let's keep the uS next week and if no US contributors we will use only the Asian/European one slot
11:01:11 <jose_lausuch> ok
11:01:20 <jose_lausuch> last week was sad
11:01:27 <jose_lausuch> It was like a monologue
11:01:35 <jose_lausuch> hehe
11:01:35 <morgan_orange> juhak: I saw some mails around, they want to setup a procedure but i can try to ask one more time
11:01:55 <morgan_orange> #action morgan_orange checks why LF access still not possibfor juhak (N weeks..)
11:02:12 <juhak> ok, thanks
11:02:21 <morgan_orange> if no more question we can stop now
11:02:29 <jose_lausuch> yes, its time
11:02:49 <morgan_orange> see you next week and enjoy your Jiras
11:02:52 <morgan_orange> #endmeeting