#opnfv-testperf: Functest weekly meeting November 24th

Meeting started by morgan_orange at 08:00:24 UTC (full logs).

Meeting summary

    1. Morgan Richomme (morgan_orange, 08:00:33)
    2. Viktor Tikkanen (viktor_nokia, 08:00:35)
    3. Juha Kosonen (juhak, 08:00:39)
    4. Qinglong Lan (Qinglong, 08:01:06)
    5. agenda https://wiki.opnfv.org/functest_meeting (morgan_orange, 08:01:09)

  1. Action point follow-up (morgan_orange, 08:01:26)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2015/opnfv-testperf.2015-11-17-10.02.html (morgan_orange, 08:01:35)
    2. action 1 => not possible to grant access to LF POD2, LF POD 2 is considered as a production CI lab, the access is restricted (morgan_orange, 08:02:08)
    3. access to be found on dev labs, Orange shall be able to grant one access to one of our lab (morgan_orange, 08:02:35)
    4. action2) => wiki updated https://wiki.opnfv.org/functextnexttaks (morgan_orange, 08:03:02)
    5. I added a table showing the dependencies towards Doctor, Copper, ONOSFW, OVNO, PolicyTest and Promise (morgan_orange, 08:03:27)
    6. XiaoguangLi (xiaoguang, 08:03:31)
    7. seen from the Summit some projects are already mature => question of integration, some projects not so clear and the availability (or not) of test suites to be integrated in functest for B release (morgan_orange, 08:04:21)
    8. action 3) work on Orange POD planned tomorrow (jumphost connected, env ready..) (morgan_orange, 08:04:55)
    9. action 4) JIRA updated and Sprint 3 started (morgan_orange, 08:05:13)
    10. action 5) viktor_nokia completed Tempest backlog we will have a dedicated topis later (morgan_orange, 08:05:43)
    11. action 6) discussion on the syntezis of functest for the dashboard...let's discuss it also in a separate topic (morgan_orange, 08:06:11)

  2. B release Sprint 3 (morgan_orange, 08:06:28)
    1. Jira Spint 3 started: https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59 (morgan_orange, 08:06:43)
    2. transistion Sprint, still some code to be produced (especially ODL test suite reformating) but first tasks on intgeration (morgan_orange, 08:07:15)
    3. LF POD 2 (Fuel) ready, jose should work on the integration with Apex, Mei Mei with Huawei/Compass and myself should discuss with joid team (morgan_orange, 08:07:58)
    4. reminder for B release Functest success criteria => running all our suites on the 4 env (morgan_orange, 08:08:16)

  3. status on Onos (morgan_orange, 08:09:17)
    1. Huawei-POD is ready now, Need some time to debug with it (Qinglong, 08:09:27)
    2. ML3 is under working ,we are writing Testcases, about 3 weeks to finish scripts (Qinglong, 08:09:43)
    3. Jose Lausuch (jose_lausuch, 08:09:50)
    4. Mei Mei assigned to run functest suite on Huwaei target lab (in china First then US) (morgan_orange, 08:11:14)
    5. possibility to add ONOS as Functest testcase in DB (morgan_orange, 08:14:40)
    6. https://wiki.opnfv.org/brahmaputra_testing_page (morgan_orange, 08:14:42)
    7. B testing updated (morgan_orange, 08:14:59)
    8. table to be updated still (with results and dashboard ready status) (morgan_orange, 08:15:24)
    9. we planned to discuss dashboard and DB during next thursday meeting (morgan_orange, 08:15:39)
    10. ACTION: morgan_orange xiaoguang declare ONOS suite in the DB and update wiki accordingly (morgan_orange, 08:16:01)

  4. tempest (morgan_orange, 08:16:58)
    1. Viktor updated backlogs https://jira.opnfv.org/browse/FUNCTEST-70 (morgan_orange, 08:17:15)
    2. last 9 errors analyzed by viktor_nokia (morgan_orange, 08:18:00)
    3. most of the errors seem linked to ODL (morgan_orange, 08:18:27)
    4. interesting to see the difference with ONOS... (morgan_orange, 08:18:46)
    5. discussion on quota errors: strange as they occur after a fresh install and quota had been already extended for Arno (morgan_orange, 08:22:29)
    6. viktor_nokia "quota errors could be also caused by resources which were not freed by previously failed test cases (in the same suite)" (morgan_orange, 08:22:40)
    7. ACTION: viktor_nokia (when a ev lab will be available) test the Tempest suite manually, check quota before the test (morgan_orange, 08:23:19)
    8. error seems linked to configuration , subnet created by fuel is visible, it should not be the case (morgan_orange, 08:28:21)
    9. discussion on the opportunity to change config in order to avoir running everything as admin, in admin tenant (morgan_orange, 08:28:42)
    10. subnet mentioned only created in Fuel, not the case with other installers a priori (morgan_orange, 08:29:02)
    11. so wait and see next run also on other labs to compare (morgan_orange, 08:29:11)
    12. and see if it is not a Fuel specific error (morgan_orange, 08:29:21)
    13. tempets.conf to be improved (jose_lausuch, 08:32:02)
    14. ACTION: viktor_nokia test (when dev lab ready) the influence of tempest.conf change into Tempest, and see if upstream patch may be created on rally to fix the issues that would be solved by the config change (morgan_orange, 08:34:31)
    15. ACTION: viktor_nokia the opportunity to cretae a customized , installer & controller agnostic, OPNFV Tempest suite (morgan_orange, 08:40:19)
    16. ACTION: juhak study the creation of an OPNFV rally scenario (morgan_orange, 08:42:27)

  5. Discussion on the summary of Functest for dashboard (morgan_orange, 08:43:19)
    1. https://www.opnfv.org/opnfvtestgraphs/per-test-projects (morgan_orange, 08:51:31)
    2. https://www.opnfv.org/opnfvtestgraphs/per-installers (morgan_orange, 08:54:58)
    3. https://git.opnfv.org/cgit/releng/tree/utils/test/result_collection_api/dashboard/functest2Dashboard.py (morgan_orange, 08:57:12)
    4. discussion on the criteria to be automatically displayed in dashboard page for B-release acceptance (morgan_orange, 08:59:34)
    5. https://git.opnfv.org/cgit/releng/tree/utils/test/result_collection_api/dashboard/functest2Dashboard.py (morgan_orange, 09:00:10)
    6. grenn lights for the VIM => tempest + rally > 90 % (jose_lausuch, 09:01:20)
    7. green light for the controllers => 100% (jose_lausuch, 09:01:27)
    8. green light basic => vPing 100% (jose_lausuch, 09:01:35)
    9. green light VNF deployment => deployment vIMS (jose_lausuch, 09:01:41)
    10. ACTION: morgan_orange implement status for dashboard (morgan_orange, 09:01:59)

  6. AoB (morgan_orange, 09:02:04)
    1. change in Functest team (morgan_orange, 09:02:23)
    2. -3 (HP, metaswitch) and +2 (Cisco, HP) (morgan_orange, 09:02:45)
    3. Fuel already integrated OpenContrail, I have a contact person from Juniper to see what test to run. Work to be started this week. (jose_lausuch, 09:02:54)
    4. will send a mail for formal nomination (morgan_orange, 09:02:56)
    5. ODL extension, Peter and amaged__ should work on this, refactoring to be planned. For B-Release cherry pick of ODL tests (GBP + integration tests) for C release study to automate the integration of upostream tests to be planned (morgan_orange, 09:04:21)


Meeting ended at 09:05:18 UTC (full logs).

Action items

  1. morgan_orange xiaoguang declare ONOS suite in the DB and update wiki accordingly
  2. viktor_nokia (when a ev lab will be available) test the Tempest suite manually, check quota before the test
  3. viktor_nokia test (when dev lab ready) the influence of tempest.conf change into Tempest, and see if upstream patch may be created on rally to fix the issues that would be solved by the config change
  4. viktor_nokia the opportunity to cretae a customized , installer & controller agnostic, OPNFV Tempest suite
  5. juhak study the creation of an OPNFV rally scenario
  6. morgan_orange implement status for dashboard


Action items, by person

  1. juhak
    1. juhak study the creation of an OPNFV rally scenario
  2. morgan_orange
    1. morgan_orange xiaoguang declare ONOS suite in the DB and update wiki accordingly
    2. morgan_orange implement status for dashboard
  3. viktor_nokia
    1. viktor_nokia (when a ev lab will be available) test the Tempest suite manually, check quota before the test
    2. viktor_nokia test (when dev lab ready) the influence of tempest.conf change into Tempest, and see if upstream patch may be created on rally to fix the issues that would be solved by the config change
    3. viktor_nokia the opportunity to cretae a customized , installer & controller agnostic, OPNFV Tempest suite
  4. xiaoguang
    1. morgan_orange xiaoguang declare ONOS suite in the DB and update wiki accordingly


People present (lines said)

  1. morgan_orange (177)
  2. jose_lausuch (67)
  3. viktor_nokia (20)
  4. Qinglong (11)
  5. juhak (3)
  6. collabot (3)
  7. xiaoguang (3)


Generated by MeetBot 0.1.4.