#opnfv-testperf: functest weekly meeting December 8th

Meeting started by morgan_orange at 08:00:34 UTC (full logs).

Meeting summary

    1. Morgan Richomme (morgan_orange, 08:00:59)
    2. Viktor Tikkanen (viktor_nokia, 08:01:09)
    3. Peter Bandzi (pbandzi, 08:01:09)
    4. Juha Kosonen (juhak, 08:01:13)
    5. Ahmed Maged (amaged__, 08:01:31)
    6. Xiaoguang (lixiaoguang, 08:01:32)

  1. agenda bashing (morgan_orange, 08:01:35)
    1. https://wiki.opnfv.org/functest_meeting (morgan_orange, 08:01:42)
    2. all the feature projects have been contacted (morgan_orange, 08:02:10)
    3. DB of for milestone D => 17 projects / 89 testcases (morgan_orange, 08:02:54)
    4. http://213.77.62.197/test_projects (morgan_orange, 08:02:58)
    5. regarding functest: companion projects (tests we may run from Functest in CI) are: ovno (Opencontrail), Doctor, Promise, PolicyTest (GBP in ODL) and part of SDNVPn (ODL part) (morgan_orange, 08:03:44)
    6. and Copper (morgan_orange, 08:03:53)
    7. + of course our own testcase.. (morgan_orange, 08:04:02)
    8. second point OK May-meimei is with her, she will give an overview of Compass/Functest work (morgan_orange, 08:04:36)
    9. point 3: list of openstack services supported initied but not finished => once Functest will be connected in CI to all installers, the information will be automatically retrieved (morgan_orange, 08:05:15)
    10. point 4: creation of ONOS testcase => done it is in the DB as 2 functest testcases onos and onos-ovsdb (morgan_orange, 08:05:47)

  2. B Release Sprint 3 status (morgan_orange, 08:06:19)
    1. several actions in //: deployment of Functest on target labs, dev of testcases, integration of feature projects, docs.... (morgan_orange, 08:06:50)
    2. deployment of Functest in Lab (morgan_orange, 08:07:19)
    3. Functest integration started on Compass => target Jan (morgan_orange, 08:08:45)
    4. Jose Lausuch (jose_lausuch, 08:10:48)
    5. https://gerrit.opnfv.org/gerrit/#/c/3453/ (May-meimei, 08:12:00)
    6. https://git.opnfv.org/cgit/releng/tree/jjb/functest/functest.yml (morgan_orange, 08:12:58)
    7. patch submitted for integration of the Compass ref lab into Jenkins https://gerrit.opnfv.org/gerrit/#/c/3453/ (morgan_orange, 08:14:23)
    8. Compass is on track: goal run functest from Jenkins asap (morgan_orange, 08:15:46)
    9. onos and odl supported by compass (morgan_orange, 08:16:39)
    10. https://wiki.opnfv.org/brahmaputra_testing_page (morgan_orange, 08:16:52)
    11. once we will get the lab ready, discuss the deployment strategy regarding the controllers and/or options (specific OVS, kvm, QEMU,...) (morgan_orange, 08:19:24)
    12. apex almost ready to run functest (jose_lausuch, 08:20:53)
    13. for the moemtn 1 combination apex/odl (morgan_orange, 08:21:12)
    14. for fuel, there are problems with ODL tests due to the default port for the rest api (we have to change it) (jose_lausuch, 08:22:12)
    15. ACTION: all review patch for deployment strategy https://gerrit.opnfv.org/gerrit/#/c/4003/ (morgan_orange, 08:22:13)
    16. for joid, tests done from CI on orange pod (not the target pod, wait for connection of INTEL POD 5 to CI) (morgan_orange, 08:22:39)
    17. joid => able to run docker from CI, able to run vPing and tempest (morgan_orange, 08:22:57)
    18. joid => upgrade planned on orange pod 2 today (to move to Liberty and add Ceph, heat, ceilometer) to be closed to target release... (morgan_orange, 08:23:31)
    19. upgrade joid orange-pod2 planned this afternoon (not available for testing) => move to liberty + heat/ceilometer/ceph (morgan_orange, 08:25:21)

  3. ODL (morgan_orange, 08:27:10)
    1. so far it looks like we can add tests from suite: https://github.com/opendaylight/integration/tree/master/test/csit/suites/ovsdb (pbandzi, 08:28:06)
    2. jira for those suit to be created today (pbandzi, 08:28:31)
    3. looks however bigger task that expoected :) (pbandzi, 08:29:04)

  4. Management of constraints in CI (morgan_orange, 08:33:24)
    1. question on constarint management in Functest on CI (morgan_orange, 08:34:57)
    2. work in progress in releng (morgan_orange, 08:35:03)
    3. https://gerrit.opnfv.org/gerrit/#/c/4003/ (morgan_orange, 08:35:06)
    4. work on file listing dependencies prior to test (morgan_orange, 08:36:59)
    5. test.yaml to list the config for each test project (jose_lausuch, 08:37:05)
    6. https://gerrit.opnfv.org/gerrit/#/c/4021/ (jose_lausuch, 08:37:05)
    7. https://gerrit.opnfv.org/gerrit/#/c/4021/ (jose_lausuch, 08:37:08)
    8. https://gerrit.opnfv.org/gerrit/#/c/4021/ (morgan_orange, 08:37:08)
    9. corection to ODL... we will also include mininet... (pbandzi, 08:37:43)
    10. ACTION: jose_lausuch morgan_orange create function to deal with opnfv-test file and add support for -c in run_test (morgan_orange, 08:41:13)

  5. start speaking of documentation.... (morgan_orange, 08:41:53)
    1. ryota sent a mail expalining some changes in doc management (morgan_orange, 08:42:11)
    2. ACTION: morgan_orange initiate functest doc (morgan_orange, 08:43:31)
    3. Doc after E milestone (beginning of january) (morgan_orange, 08:44:52)

  6. AoB (morgan_orange, 08:44:56)
    1. Rally refactoring in progress => split into 2 JIRAs (morgan_orange, 08:46:52)
    2. https://jira.opnfv.org/browse/FUNCTEST-109 (morgan_orange, 08:46:55)
    3. https://jira.opnfv.org/browse/FUNCTEST-110 (morgan_orange, 08:47:04)
    4. suggestion jose_lausuch find an automatic way to detect a proper way of defining the (e.g.) number of iterations and concurrency => propose some default configuration depending on the pod config (morgan_orange, 08:51:39)
    5. Tempest will be also a little bit refactored with the creation of our own suite (no more smoke) (morgan_orange, 08:53:33)
    6. demo Juniper this week (postponed from last week), you can join (morgan_orange, 08:54:40)
    7. For release meeting: 1) we shall be able to run Functest towards 3 or 4 installers before the end of the week (morgan_orange, 08:59:44)
    8. for CI.... (morgan_orange, 09:00:38)
    9. for Release meeting 3) feature projects started showing code, but not full visibility on when we could be able to test (morgan_orange, 09:00:54)
    10. ACTION: morgan_orange contact anac1 regarding the test config file in releng (morgan_orange, 09:01:27)


Meeting ended at 09:03:43 UTC (full logs).

Action items

  1. all review patch for deployment strategy https://gerrit.opnfv.org/gerrit/#/c/4003/
  2. jose_lausuch morgan_orange create function to deal with opnfv-test file and add support for -c in run_test
  3. morgan_orange initiate functest doc
  4. morgan_orange contact anac1 regarding the test config file in releng


Action items, by person

  1. jose_lausuch
    1. jose_lausuch morgan_orange create function to deal with opnfv-test file and add support for -c in run_test
  2. morgan_orange
    1. jose_lausuch morgan_orange create function to deal with opnfv-test file and add support for -c in run_test
    2. morgan_orange initiate functest doc
    3. morgan_orange contact anac1 regarding the test config file in releng


People present (lines said)

  1. morgan_orange (159)
  2. jose_lausuch (79)
  3. May-meimei (15)
  4. pbandzi (10)
  5. juhak (8)
  6. collabot (6)
  7. raghavendrachari (4)
  8. fdegir (3)
  9. lixiaoguang (3)
  10. amaged__ (2)
  11. viktor_nokia (2)
  12. David_Orange (2)


Generated by MeetBot 0.1.4.