08:04:34 <morgan> #startmeeting functest weekly meeting December 15th
08:04:34 <collabot`> Meeting started Tue Dec 15 08:04:34 2015 UTC.  The chair is morgan. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:04:34 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:04:34 <collabot`> The meeting name has been set to 'functest_weekly_meeting_december_15th'
08:04:42 <morgan> hello everybody
08:04:49 <raghavendrachari> Hi morgan
08:04:51 <juhak> #info Juha Kosonen
08:04:57 <jose_lausuch> good morning
08:04:57 <viktor_nokia> #info Viktor Tikkanen
08:05:02 <jose_lausuch> #info Jose Lausuch
08:05:05 <Guest21419> my connectionis not very safe, I will let jose_lausuch chair...
08:05:15 <Guest21419> #info morgan
08:05:17 <Guest21419> #chair jose_lausuch
08:05:24 <jose_lausuch> thanks
08:05:28 <jose_lausuch> you wanna start?
08:06:08 <Guest21419> jose_lausuch: I just initiated the conf, but set you as chair, so you will be able to stop it if I am disconnected
08:06:37 <jose_lausuch> ok
08:07:33 <jose_lausuch> #info previous minutes: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2015/opnfv-testperf.2015-12-08-08.00.html
08:07:44 <Guest21419> #topic action points
08:08:01 <jose_lausuch> a) Rally refactoring in progress => split into 2 JIRAs
08:08:51 <jose_lausuch> any comments on this?
08:09:06 <juhak> progressing, been doing some manual testing using scenarios provided by rally/certification
08:09:07 <pbandzi> #info Peter Bandzi
08:09:21 <jose_lausuch> sounds good
08:09:48 <jose_lausuch> juhak: feel free to upload a patch when you are ready and we can start taking a look
08:09:52 <jose_lausuch> include all of us :)
08:10:19 <juhak> yes, I was planning to do so in a few days
08:10:21 <jose_lausuch> another AP: tempest
08:10:51 <jose_lausuch> just lets make sure we are a bit before the code freeze in january ;)
08:10:55 <Guest21419> I postponed my task for rally / dashboard as we may use now the results from the rally/certification feature
08:11:08 <jose_lausuch> ok morgan
08:11:24 <jose_lausuch> the sprint is over, right?
08:11:56 <Guest21419> yes Sprint #3 is over
08:12:06 <jose_lausuch> ok
08:12:08 <jose_lausuch> for tempest
08:12:10 <Guest21419> we can start Sprint #4 until the end of the year
08:12:16 <jose_lausuch> yes
08:12:37 <Guest21419> #info rally / dashboard task postponed as we may use now the results from the rally/certification feature
08:12:39 <jose_lausuch> we haven't changed our run_tempest.py to run the specific set of test
08:12:48 <Guest21419> #action morgan start Sprint #4
08:13:20 <jose_lausuch> #info try to run the given list of tempest test cases and test it during following days
08:13:20 <Guest21419> #info tempest customization from smoke to opnfv suite to be tested and integrated
08:13:35 <jose_lausuch> #action jose: change the call to rally verify in run_tempest.py
08:14:44 <jose_lausuch> #info we, together with BGPVPN, started to write some code about their tempest test cases which will be included in Functest as well
08:14:52 <jose_lausuch> #info but not in run_tempest.py
08:14:55 <jose_lausuch> ok
08:15:03 <jose_lausuch> done for APs
08:15:08 <jose_lausuch> status of installers/functest
08:15:26 <Guest21419> #topic status of installers/functest
08:15:29 <jose_lausuch> #topic Compass
08:15:31 <jose_lausuch> oops
08:15:33 <jose_lausuch> #undo
08:15:46 <Guest21419> it can be a topic ...
08:16:02 <jose_lausuch> May-meimei: ?
08:17:04 <jose_lausuch> mmm
08:17:10 <jose_lausuch> no one
08:17:18 <jose_lausuch> well I can share what you said yesterday
08:17:32 <jose_lausuch> #info Compass: CI is working and tests are triggered
08:17:53 <jose_lausuch> #info Compass: vPing spawns the 2 VMs, but the ping doesn't work..  to be troubleshooted (help needed)
08:18:14 <jose_lausuch> #info Compass: Tempest 106 tests and 51 failed.. probably due to the same issue
08:18:35 <jose_lausuch> #info Compass: vIMS and Rally => same issue seemed to be linked to some issue to connect admin network  (need to have a deeper look)
08:19:45 <jose_lausuch> #info Fuel we have full CI and running tests, https://build.opnfv.org/ci/view/fuel/job/fuel-daily-master/
08:20:05 <jose_lausuch> #info ODL plugin to be activated in Mirantis Fuel 7.0 this week
08:21:21 <jose_lausuch> #info Apex: first try to run the jjob, but functest detected failures creating routeres in OpenStack. Apex team troubleshooting and providing a fix
08:21:47 <jose_lausuch> anything for Joid?
08:22:05 <Guest21419> #info joid tests runnable on Intel POD 5
08:22:08 <jose_lausuch> #info Joid: Functest jjob ran on that installer and it worked, but there has been some changes in our jjob and we need to do some adaptations to make it work again.
08:22:20 <Guest21419> exactly :)
08:22:40 <jose_lausuch> #info   Last week I was able to start Functest from jenkins. vPing, Tempest and Rallye were runnable. Odl and vIMS not probably due to misconfiguration
08:22:47 <jose_lausuch> just copy-pasting the status from your email :)
08:23:03 <jose_lausuch> ok
08:23:08 <jose_lausuch> anyone whants to add something else?
08:23:18 <Guest21419> #info Tempest: only 6 errors with Fuel (but pure OpenStack) lots of errors seen with joid and compass
08:24:12 <Guest21419> #info all the jenkins jobs have been refactored, clear Functest page now...
08:24:39 <jose_lausuch> #info Openstack cleanup script created to be run after the tests that leave leftovers (Tempest, vIMS, ...) https://gerrit.opnfv.org/gerrit/#/c/2345/
08:24:41 <Guest21419> #info goal if the 4 installers could launch Functest before xmas break, i will be great
08:24:42 <jose_lausuch> feel free to review :)
08:24:56 <jose_lausuch> you are always great :p
08:25:37 <jose_lausuch> ok, next topic?
08:25:39 <Guest21419> #info January will be dedicated to intagration of feature tests (already started with sdnvpn), troubleshooting, and documentation
08:25:54 <Guest21419> There is a clear risk for the B release
08:26:09 <jose_lausuch> yes...
08:26:10 <Guest21419> concerns have been reported to board
08:26:25 <Guest21419> because we should also see the first tests with new controllers...
08:26:26 <jose_lausuch> any decision/suggestion from the board ?
08:26:35 <Guest21419> no it is a TSC decision anyway
08:26:38 <jose_lausuch> ok
08:26:44 <jose_lausuch> maybe today...
08:26:48 <jose_lausuch> they say something
08:27:01 <Guest21419> ok
08:27:27 <Guest21419> January will be also useful to test ODL extension...good transition to next topic
08:27:49 <Guest21419> #topic ODL
08:27:50 <jose_lausuch> #topic ODL
08:27:54 <jose_lausuch> oooo to fast
08:27:55 <Guest21419> #undo
08:27:56 <jose_lausuch> :)
08:28:06 <jose_lausuch> pbandzi amaged__ ?
08:28:19 <pbandzi> #info in progress still. not yet more updates :)
08:28:41 <jose_lausuch> feel free to ask for support
08:28:46 <jose_lausuch> we are here for that :)
08:28:47 <amaged__> pbandzi: added some comments
08:28:52 <jose_lausuch> if you need it
08:28:53 <amaged__> Not sure if anyone have seen them
08:29:03 <jose_lausuch> amaged__: where?
08:29:13 <pbandzi> thats only jira comments
08:29:39 <amaged__> Yes, jira comments
08:29:42 <pbandzi> we need some time to figure out how we do it..
08:30:13 <jose_lausuch> can you link them?
08:30:22 <Guest21419> shall we raise any oraneg flag to Debra?
08:30:34 <jose_lausuch> https://jira.opnfv.org/browse/FUNCTEST-54?
08:31:20 <jose_lausuch> pbandzi: for ovsdb, do we need mininet?
08:31:29 <pbandzi> jose_lausuch yes
08:31:42 <pbandzi> all tests depends on it
08:31:44 <jose_lausuch> so the question is how to use mininet
08:31:46 <jose_lausuch> yes
08:31:48 <jose_lausuch> mmmm
08:31:52 <jose_lausuch> you ask if another docker
08:31:59 <jose_lausuch> would it be a problem to install it in the current one?
08:32:14 <pbandzi> i think we can also install it to current one
08:32:19 <jose_lausuch> (we can of course create a new one, but let's see if we can reuse)
08:32:22 <jose_lausuch> ok
08:32:32 <jose_lausuch> what is this? https://github.com/opendaylight/releng-builder
08:32:57 <Guest21419> would we the only project that needs mininet?
08:33:01 <pbandzi> that are scripts which installs and configure odl + mininet for tests
08:33:27 <pbandzi> but we cannot use that. we can inspire from it.. because in our case odl is installed and configure by deployers
08:33:42 <jose_lausuch> pbandzi: I can include that repo in the docker image, so we have it available already
08:33:47 <jose_lausuch> ah ok
08:34:01 <jose_lausuch> so we just take the idea from there
08:34:07 <pbandzi> yes
08:34:13 <jose_lausuch> I'm seeing:
08:34:13 <jose_lausuch> git clone git://github.com/mininet/mininet 17cd mininet18git checkout -b 2.2.1 2.2.1 19cd .. 20mininet/util/install.sh -nf
08:34:16 <jose_lausuch> oops sorry
08:34:27 <jose_lausuch> git clone git://github.com/mininet/mininet
08:34:27 <jose_lausuch> cd mininet
08:34:27 <jose_lausuch> git checkout -b 2.2.1 2.2.1
08:34:27 <jose_lausuch> cd ..
08:34:27 <jose_lausuch> mininet/util/install.sh -nf
08:34:42 <jose_lausuch> https://github.com/opendaylight/releng-builder/blob/defb069fcee740e3cc0792ae175c551f26146715/vagrant/basic-mininet-fedora-node/bootstrap.sh
08:34:54 <jose_lausuch> maybe that does the magic
08:35:08 <jose_lausuch> we can try it in a running container if you want peter
08:35:55 <pbandzi> we can I had some trouble recently with my pc so could not try it on my lab. but we can take a look at it and try it in lf lab
08:36:11 <jose_lausuch> sure, let's do it later then :)
08:36:22 <jose_lausuch> great
08:36:24 <jose_lausuch> moving on
08:36:31 <Guest21419> +1, It is even becoming a priority topic
08:36:48 <Guest21419> in // on making Functest running on all the labs
08:37:10 <Guest21419> raghavendrachari: are you familiar with mininet?
08:37:28 <raghavendrachari> yes
08:38:15 <jose_lausuch> then, maybe we ask for your help :)
08:38:33 <raghavendrachari> ok sure
08:38:43 <Guest21419> but you do not have access to LF Labs...and it is very difficult to have such access...
08:39:32 <jose_lausuch> ya.. very restricted area
08:39:44 <raghavendrachari> yeah, i raised request too , but didn't get response
08:39:53 <raghavendrachari> regarding lab access
08:41:49 <jose_lausuch> I'll ask aric... but maybe it is not possible to give access to everyone ..
08:42:04 <Guest21419> I suggest to create a JIRA to assign mininet installation/config to raghavendrachari and see if we can grant an access to Orange POD
08:42:34 <Guest21419> this POD is under reinstallation, it is also iportant for juhak and viktor_nokia
08:42:45 <Guest21419> David_Orange: joined maybe you can share the status of the installation
08:43:01 <Guest21419> raghavendrachari: you ca send you public ssh key to David_Orange to get the access
08:43:05 <David_Orange> Hello
08:43:13 <raghavendrachari> ok
08:43:39 <David_Orange> I am installing new controller servers today, I have to test them
08:43:57 <Guest21419> it ill be still with ODL, right?
08:44:00 <David_Orange> and i wish to make the new install via jenkins
08:44:35 <David_Orange> yes, but i can see with narinder if we can switch
08:45:09 <David_Orange> in the best scenario it will be running at the end of the day
08:45:26 <Guest21419> If w want to test the installation of mininet it is interesting to stay on ODL, even if moving to contrail will be also interested to perform tests towards owno...
08:45:46 <Guest21419> we need other dev lab access for such tasks
08:46:23 <jose_lausuch> ok
08:46:30 <David_Orange> the other orange lab will be running for january
08:46:49 <David_Orange> but for the access on pod2 i just need an ssh key
08:46:58 <jose_lausuch> and vpn?
08:47:13 <David_Orange> no vpn, this platform is directly on the internet
08:47:16 <jose_lausuch> ok
08:47:22 <Guest21419> OK David_Orange let viktor_nokia juhak and raghavendrachari knwo when it is ready
08:47:25 <jose_lausuch> I will send you mine, if I haven't done it yet
08:48:18 <David_Orange> ok
08:48:19 <Guest21419> raghavendrachari: pbandzi  amaged__ OK to assign the installation of mininet in Functest docker to raghavendrachari ?
08:49:16 <pbandzi> yes
08:49:27 <Guest21419> #info Orange dev pod should be back in town today for testing
08:49:35 <pbandzi> thanks raghavendrachari
08:49:41 <raghavendrachari> ok
08:49:58 <Guest21419> #info could be reused by viktor_nokia juhak and raghavendrachari for Functest tests
08:50:15 <Guest21419> #action David_Orange confirm when platform is ready
08:50:23 <David_Orange> ok
08:50:25 <Guest21419> #info new Orange pod shall be available in January
08:51:08 <Guest21419> #action raghavendrachari assign tasks on mininet installation in Functest
08:51:16 <Guest21419> #action morgan create the Jira
08:51:17 <jose_lausuch> David_Orange: can you write your email here, so raghavendrachari and others send you the ssh key?
08:51:31 <Guest21419> #action raghavendrachari send public SSH key to David_Orange for access
08:51:36 <David_Orange> sure
08:52:33 <raghavendrachari> my mail id: raghavendrachari.kamsali@hpe.com
08:52:34 <David_Orange> raghavendrachari: i am not sure i have your mails, please send me your key to: david.blaisonneau AT orange.com
08:52:42 <David_Orange> ok, i send you a mail
08:53:01 <David_Orange> juhak: viktor_nokia: i already have your keys
08:53:03 <Guest21419> goot try David_Orange ...will see if security parse the full address or the domain... :)
08:53:37 <David_Orange> Guest21419: ;)
08:54:15 <Guest21419> #topic AoB
08:54:25 <Guest21419> any other topic you would like to share today...
08:54:59 <jose_lausuch> not from my side
08:57:50 <jose_lausuch> shall we close the meeting?
08:58:16 <Guest21419> If I sumarize
08:58:28 <Guest21419> still lots of work to make Functest run on all the installers
08:59:04 <Guest21419> hot topic = ODL extension (as it is not only our internal testcase but it is needed for feature projects such as PolicyTest, sdnvpn,...)
08:59:23 <Guest21419> still tuning needed on other topics (tempest, rally, vIMS)
08:59:55 <Guest21419> and we will surely get some sollicitations from feature projects (copper, promise, doctor, ocno (opencontrail))
09:00:19 <Guest21419> so pbandzi you did not answer to my question, shall we raise an orange flag to Debra? :)
09:00:41 <pbandzi> ah,  I am not sure what that means
09:00:53 <pbandzi> if orange flag is raised
09:01:11 <pbandzi> what kind of process starts then?
09:02:09 <Guest21419> it is just to indicate that it may be difficult to get more than we we have so far becasue refactoring is not so easy
09:02:48 <pbandzi> in that case we might raise it. I still believe we can make work some tests
09:03:05 <Guest21419> If you are confident, I am confident :)
09:03:11 <pbandzi> :)
09:04:03 <Guest21419> ok we will update the status for Debra but we will have a better view hopefully before the xmas break
09:04:27 <Guest21419> BTW, I assume most of the people will have deserved vacations next week
09:04:53 <jose_lausuch> I will start vacation on the 24th
09:05:01 <Guest21419> so shall we cancel the 2 next sync meeting and restart next year...of course we may use th chan for exchange until then
09:05:20 <Guest21419> ok so jose_lausuch you may chair next week :)
09:05:27 <Guest21419> I will be out for 2 weeks
09:05:29 <jose_lausuch> ya, I think it will be difficult to have everyone here
09:05:31 <jose_lausuch> but will try
09:05:36 <Guest21419> ok
09:06:14 <jose_lausuch> I have to go to another meeting now
09:06:14 <Guest21419> #info meeting next week but no meeting on the 29th
09:06:42 <Guest21419> valentin_orange: we assigned you lots of tasks ... where were you? :)
09:06:51 <jose_lausuch> morgan: are you ok if I merge a patch and dont get a +2 ?
09:06:55 <jose_lausuch> since you are gonna be on vac?
09:07:11 <Guest21419> Yes
09:07:39 <Guest21419> jose_lausuch: yes I will be somewhere with absolutely no connection...
09:07:39 <jose_lausuch> ok
09:07:47 <jose_lausuch> thanks everyone
09:07:50 <jose_lausuch> have to go now
09:07:51 <Guest21419> thanks
09:07:55 <jose_lausuch> bye
09:07:57 <Guest21419> #endmeeting