08:01:26 <morgan_orange> #startmeeting Functest weekly meeting
08:01:26 <collabot`> Meeting started Tue Feb 23 08:01:26 2016 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:26 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:26 <collabot`> The meeting name has been set to 'functest_weekly_meeting'
08:01:34 <morgan_orange> #info Morgan Richomme
08:01:40 <juhak> #info Juha Kosonen
08:03:08 <morgan_orange> #info agenda https://wiki.opnfv.org/functest_meeting
08:03:09 <jose_lausuch> #info Jose Lausuch
08:03:19 <morgan_orange> #topic action points
08:03:26 <morgan_orange> #info no action points form last week?
08:03:40 <jose_lausuch> mmmm
08:03:46 <jose_lausuch> there was something
08:03:49 <jose_lausuch> let me see the minutes
08:04:33 <jose_lausuch> just viktor nokia
08:04:43 <morgan_orange> #info it was for Viktor on Onos, so we will see next week
08:04:57 <jose_lausuch> well, what I can tell is
08:05:12 <morgan_orange> #undo
08:05:12 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b2c9d0>
08:05:17 <jose_lausuch> those test cases will fail due to lack of support for metadata in onos
08:05:18 <jose_lausuch> but
08:05:33 <jose_lausuch> the onos community is working on a patch that will be probably available for SR1
08:05:43 <jose_lausuch> for now, we just document it
08:05:49 <morgan_orange> #info action point viktor: answer from Onos 11 testcases dealing with nova metadata (not supported)
08:05:59 <morgan_orange> #info so calculation for success criteria shall be -11 tests
08:06:13 <morgan_orange> #info  onos community is working on a patch to support metadata that will be probably available for SR1
08:06:14 <jose_lausuch> if we are flexible yes
08:06:24 <morgan_orange> we are...
08:06:33 <jose_lausuch> :)
08:06:39 <morgan_orange> if we are not, we have only 3 scenarios...
08:06:56 <jose_lausuch> yes
08:07:38 <morgan_orange> #topic Last miles for B release: status on scenario
08:07:58 <morgan_orange> #info wiki page updated yesterday
08:08:00 <morgan_orange> #link https://wiki.opnfv.org/functextnexttaks
08:08:34 <morgan_orange> #info apex/odl_l2 to be added to the candidate for B release even if the reproducibility of the number of executed Tempest tests is questionable
08:08:50 <jose_lausuch> shall we name here the candidate scenarios?
08:09:30 <morgan_orange> what I mention yesterday - apex/odl_l2
08:09:30 <morgan_orange> - compass/odl_l2
08:09:30 <morgan_orange> - compass/onos
08:09:30 <morgan_orange> - compass-nosdn
08:09:30 <morgan_orange> - fuel/nosdn
08:09:31 <morgan_orange> - fuel/old_l2
08:09:31 <morgan_orange> - fuel/onos
08:09:32 <morgan_orange> - fuel/nosdn-ovs
08:09:32 <morgan_orange> - joid/odl_l2
08:09:33 <morgan_orange> - joid/nosdn
08:09:37 <morgan_orange> for Functest
08:09:47 <morgan_orange> with some precisions
08:09:54 <morgan_orange> - no vIMS on joid
08:10:19 <jose_lausuch> ok
08:10:20 <morgan_orange> - apex and fuel do not reach the 90%
08:10:31 <morgan_orange> but we can document
08:10:48 <jose_lausuch> that's right
08:11:06 <morgan_orange> there is a pending patch in fuel to increase the number of floatting IPs shall fix 5-10 in fuel
08:11:25 <jose_lausuch> #info https://gerrit.opnfv.org/gerrit/#/c/10159/
08:11:29 <jose_lausuch> to be tested first virtually
08:12:13 <morgan_orange> there is also an issue related to heat on joid
08:12:30 <morgan_orange> leads to 90% on Rally in Functest and errors in yardstick
08:12:31 <jose_lausuch> you were troubleshooting yesterday?
08:12:35 <morgan_orange> yes
08:12:41 <jose_lausuch> any conclusion?
08:12:45 <morgan_orange> apparently heat domain is missing in the configuration
08:12:53 <morgan_orange> so a question of config
08:13:07 <jose_lausuch> ah ok
08:13:10 <morgan_orange> we will test this morning and hopefully (for joid) could relaunch CI
08:13:15 <jose_lausuch> but there is user/tenant for heat?
08:13:36 <morgan_orange> there are users
08:14:14 <morgan_orange> so if we consider the scenario taht are not in B scope
08:14:37 <morgan_orange> - apex odl_l3 (vPing/Tempest), -apex/onos, -joid/onos, -fuel/bgpvpn
08:14:52 <morgan_orange> for bgpvpn I saw first tests during the week end
08:15:06 <morgan_orange> both odl based or neutron based were failed, but there were traces....
08:15:30 <jose_lausuch> ja, Niko spent some time on this last week
08:15:39 <morgan_orange> we may also mention that doctor (which is not a scenario) but is run on apex in any scenario is stil NOK then not ready for release but as vIMS it was not a criteria
08:15:43 <jose_lausuch> at least they managed to have the installation in place
08:15:49 <morgan_orange> let me info that
08:16:02 <morgan_orange> #info troubleshooting in progress on joid regarding heat issue
08:16:15 <morgan_orange> #info heat domain missing, test in progress in orange POD 2
08:16:29 <morgan_orange> #info scenario Not ready for B release - apex odl_l3 (vPing/Tempest), -apex/onos, -joid/onos, -fuel/bgpvpn
08:16:54 <morgan_orange> #info bgpvpn 1st tests during the week end: odl based or neutron based were failed, but there were traces....
08:17:09 <morgan_orange> #info doctor also running on any apex scenario but not ready for thursday
08:17:27 <morgan_orange> #info we may also mention the firt run of ocl on compass...(target SR1)
08:17:54 <morgan_orange> #info results reflected in dashboard
08:17:56 <morgan_orange> #link http://testresults.opnfv.org/dashboard
08:18:54 <morgan_orange> any question on the tests/scenario? ..except for joid/heat the last steps are mainly dealing with docs
08:19:09 <jose_lausuch> nop
08:19:13 <morgan_orange> #topic B release docs
08:19:32 <jose_lausuch> we have to document the scenario results
08:19:33 <morgan_orange> #info ChrisPriceAB should push a patch to move userguide to another place to be consistent with the other projects
08:19:55 <ChrisPriceAB> yes he should!  Will be there before lunch CET.
08:19:57 <morgan_orange> #info first compass result documents have been created (as it is stable for a while)
08:20:22 <morgan_orange> #action morgan_orange complete the other candidate scenario listed above...
08:20:40 <morgan_orange> thanks to s*$ and block copy in geany it is almost trivial...
08:20:56 <jose_lausuch> we can split the work
08:21:09 <morgan_orange> ok
08:21:12 <morgan_orange> #undo
08:21:12 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2d04c90>
08:21:42 <morgan_orange> #action morgan_orange jose_lausuch document remaining scenario
08:21:52 <morgan_orange> #info morgan_orange => apex+ joid + compass
08:21:57 <morgan_orange> #info jose_lausuch => fuel
08:21:59 <morgan_orange> ok?
08:22:12 <jose_lausuch> ok
08:22:14 <jose_lausuch> sure
08:22:46 <morgan_orange> we should also collect the Jira, document the Tempest main errors, indicate teh reason why vIMS is not working on joid (for me)
08:22:51 <morgan_orange> and we cross review
08:22:58 <morgan_orange> so it should be ready for thursday
08:23:07 <jose_lausuch> ya, and here my question
08:23:12 <jose_lausuch> where do we document the tempest errors?
08:23:13 <morgan_orange> probably a final review on the links (dashboard)
08:23:16 <jose_lausuch> in each scenario rst?
08:23:21 <jose_lausuch> or generally?
08:23:31 <jose_lausuch> since the failures are different depending on the scenario
08:23:35 <jose_lausuch> or sometimes the same errors..
08:23:39 <morgan_orange> we started to do it in teh user guide
08:23:42 <morgan_orange> so generally
08:23:49 <jose_lausuch> ok
08:23:59 <jose_lausuch> in the troubleshooting section or before
08:24:00 <morgan_orange> even if it will move in post process doc  or something like that I think it is the good place
08:24:03 <morgan_orange> yes
08:24:10 <morgan_orange> in trhe troubleshooting section
08:24:13 <jose_lausuch> ok
08:24:27 <jose_lausuch> what about splitting the troubleshooting part to another rst?
08:24:33 <jose_lausuch> and include it in the main index?
08:24:41 <morgan_orange> #info document errors (Tempest) in troubleshooting section
08:24:52 <morgan_orange> yes it is may be better to split it this way
08:25:18 <morgan_orange> we may ask Mc Documentation ChrisPriceAB :)
08:25:41 <ChrisPriceAB> I'd like fries wit that please!
08:25:51 <jose_lausuch> :D
08:26:07 <ChrisPriceAB> Breaking up the docs into concise topics is a good idea in general.  I'm all for it as we can combine them as necessary
08:26:10 <morgan_orange> meanwhile we can continue and the existing section, it would be only reorganization
08:26:37 <jose_lausuch> ok
08:26:40 <morgan_orange> OK so let's split troubleshooting section in a dedicated torubleshooting.rst
08:26:52 <jose_lausuch> who updates that patch?
08:27:03 <jose_lausuch> I can do it
08:27:14 <morgan_orange> #action jose_lausuch split user guide (before ChrisPriceAB patch??) to create a dedicate troubleshooting section
08:27:33 <morgan_orange> ok that is all for the doc..
08:27:45 <ChrisPriceAB> I can wait for Jose's patch.
08:27:46 <jose_lausuch> maybe we wait for that patch
08:27:49 <jose_lausuch> hahaha ok
08:27:50 <morgan_orange> #topic First b release review the + and the -
08:27:52 <jose_lausuch> I'll do it quickly then
08:28:01 <jose_lausuch> and include you
08:28:35 <morgan_orange> as we are preparing C release, we already intiated the + and 6 of release B
08:29:17 <morgan_orange> #info section lesson learned form B release added to https://etherpad.opnfv.org/p/functest_release_C
08:29:50 <morgan_orange> could be also interesting for the Meetup and the call for paper
08:29:58 <jose_lausuch> yes
08:30:09 <morgan_orange> #info feel free to complete it, intersting inputs for Meetup and CFP Berlin
08:30:15 <morgan_orange> #topic Meetup
08:30:22 <jose_lausuch> I will put some things :)
08:31:22 <morgan_orange> my business trip to Espoo has been approved
08:31:30 <morgan_orange> David_Orange: shall be there
08:31:30 <jose_lausuch> when are you flying ?
08:31:37 <morgan_orange> I arrived on the 29th
08:31:44 <morgan_orange> and fly back on the 31
08:31:46 <juhak> morgan_orange: great!
08:31:48 <jose_lausuch> ok
08:31:49 <jose_lausuch> 2 nights
08:32:15 <morgan_orange> i arrived in Helsinki at 19h15
08:32:29 <jose_lausuch> which hotel are you staying?
08:32:35 <morgan_orange> Glo Espoo Sello
08:32:53 <jose_lausuch> ok, I'll try to find the same hotel
08:33:36 <morgan_orange> so far I can see 5 people from Nokia, Jose, Myself, David, maybe 1 or 2 more from Orange
08:33:49 <morgan_orange> juhak: did you get any request from other people?
08:34:02 <juhak> looking forward to see you in Espoo!
08:34:03 <jose_lausuch> next time in Lanion :)
08:34:22 <juhak> I haven't got any requests from others
08:34:26 <morgan_orange> jose_lausuch: agreed jose_lausuch next time in lannion in September...the weather is better
08:34:35 <jose_lausuch> :)
08:34:42 <jose_lausuch> or Valencia!
08:35:19 <jose_lausuch> september is perfect for this : http://valenciataxi.net/wp-content/uploads/2015/05/b7737f0b39-comunidad-valenciana-valencia-cullera-CULLERA-BAHIA-1.jpg
08:37:00 <morgan_orange> http://www.tourismebretagne.com/var/crtbre/storage/images/media/images/decouvrir/emblematiques/ploumanach/cote-de-granit-rose-ploumanac-h/3370792-1-fre-FR/cote-de-granit-rose-ploumanac-h_large_rwd.jpg
08:37:12 <morgan_orange> we will vote in Espoo for the next meetup...
08:37:16 <jose_lausuch> haha ok
08:37:26 <juhak> I'm afraid the landscape in Finland in a bit different...
08:37:26 <jose_lausuch> Im fine with Lanion, I'd like to visit it some time
08:37:39 <jose_lausuch> juhak: I expect snow ...
08:37:42 <morgan_orange> the meet up is focused on Functest but I think it would be nice (if we consider European contributors)  to ask anac1 (yardstick) , Bertrand (Promise), Peter (ODL),..
08:38:35 <morgan_orange> we may also initiate an agenda on the etherpad C release page
08:38:54 <jose_lausuch> yes, it would be good
08:39:08 <jose_lausuch> so we have some topics to talk about
08:39:12 <morgan_orange> BTW I suggest some topics for teh weekly test meeting
08:39:30 <morgan_orange> there will be a qtip demo
08:39:47 <r-mibu> count me in (Ryota/doctor) :)
08:40:03 <morgan_orange> r-mibu: you are based in Munich?
08:40:04 <jose_lausuch> will you be able to join ?
08:40:24 <r-mibu> or is that f2f meeting?
08:40:34 <r-mibu> sorry, but I'll ask carlos to join
08:40:44 <r-mibu> will back later on
08:40:44 <morgan_orange> it is a 1 day workshop
08:41:17 <r-mibu> ah, ok
08:42:50 <morgan_orange> regarding the topics i suggest for the test weekly meeting: test cycles/loops/organisation, test strategy & infrastructure (use of Intel Pods), test coverage (what do we cover, what is missing), dashboard (how to rationalize for B release and automate teh production of wiki table for managers...as graphs are not enogh)
08:43:30 <morgan_orange> BTW also Valentin_Orange drafted something on vIMS (as he was fed up to dive into jenkins logs) => http://vims-status.valentin-boucher.fr/
08:43:47 <morgan_orange> I plan to add a notion of POD in the current dashboard
08:43:52 <jose_lausuch> I have some ideas on that topic
08:43:56 <jose_lausuch> to be included in the dashboard
08:44:02 <morgan_orange> juhak: you saw that we include Rally
08:44:27 <morgan_orange> and we have the criteria rate, => I should do the same for temepst (number of tests run/failed not so explicit that the %)
08:44:48 <morgan_orange> if you see other common topics for the test meeting, feel free to add
08:44:49 <juhak> morgan_orange: yes, thanks
08:44:56 <morgan_orange> could be also in the etherpad
08:46:04 <morgan_orange> #info meetup still some places left (mw = 15), European contributors to feature projects to be invited
08:46:23 <morgan_orange> #topic AoB
08:47:03 <morgan_orange> #info test weekly meeting => suggested topic for discussion for C release accross test projects:  test cycles/loops/organisation, test strategy & infrastructure (use of Intel Pods), test coverage (what do we cover, what is missing), dashboard (how to rationalize for B release and automate teh production of wiki table for managers...
08:47:21 <morgan_orange> any other info you would like to share before we dive into the ocean of documentations...
08:47:40 <jose_lausuch> not really
08:47:54 <morgan_orange> ok so we may conclude now
08:48:00 <morgan_orange> #endmeeting