#opnfv-testperf: Functest weekly meeting March 8th

Meeting started by morgan_orange at 08:00:01 UTC (full logs).

Meeting summary

    1. Morgan Richomme (morgan_orange, 08:00:07)
    2. Viktor Tikkanen (viktor_nokia, 08:00:39)
    3. agenda https://wiki.opnfv.org/functest_meeting (morgan_orange, 08:01:14)

  1. action points follow up (morgan_orange, 08:04:10)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-03-01-08.00.html (morgan_orange, 08:04:19)
    2. May-meimei did you have a look at the OPNFV Beijing meet-up group? (morgan_orange, 08:04:36)
    3. clean of the committer in progress, add of new committer OK, removal is a bit longer (need the green light of TSC) but it shall be OK soon (morgan_orange, 08:05:15)
    4. mail to express concern on git management done => we do everything in Master, bug fixes reported to Stable (morgan_orange, 08:05:43)

  2. SR1 (morgan_orange, 08:05:59)
    1. quiet post Brahmaputra time regarding the release (morgan_orange, 08:06:17)
    2. ACTION: morgan_orange check new scenario candidates (morgan_orange, 08:06:33)
    3. Release manager is no more working in Linux FOundation (mail received on Friday), self organization to be planned for SR1 (morgan_orange, 08:07:01)
    4. CI still working but no significant change since B release (morgan_orange, 08:07:22)

  3. focus on Tempest (morgan_orange, 08:07:42)
    1. http://testresults.opnfv.org/dashboard/ (morgan_orange, 08:08:17)
    2. apex/odl_l2 60-80%, apex/onos 75-92%, apex/odl_l3 56-68% (morgan_orange, 08:09:19)
    3. jose_lausuch (jose_lausuch, 08:11:29)
    4. ACTION: viktor_nokia set --serial options in repo to see influence on LF POD1 (morgan_orange, 08:16:26)
    5. ACTION: viktor_nokia send a mail to apex/pharos to indicate tempex results on apex/Nokia and show the different with results got on LF POD1 (morgan_orange, 08:19:22)
    6. compass/nosdn 100%, compass/odl-l2 94-100%, compass/onos 94%, compass/ocl 31% (morgan_orange, 08:19:47)
    7. fuel/nosdn 86-98% (better results on LF POD2 than Ericsson POD2), fuel/odl_l2 88-95%, fuel/onos 91-95%, fuel /odl_l3 79-92%, fuel/bgpvpn 76%; fuel/nosdn_ovs 98-100% (morgan_orange, 08:21:42)
    8. joid/nosdn ((Orange POD2) 88%, joid/odl_l2 98%, joid/onos: 87% (morgan_orange, 08:25:23)
    9. ACTION: morgan_orange initiate a page on Tempest errors per scenario/installer (morgan_orange, 08:28:46)
    10. ACTION: viktor_nokia reference apex tempest errors (morgan_orange, 08:29:00)
    11. ACTION: jose_lausuch reference fuel tempest errors (morgan_orange, 08:29:09)
    12. ACTION: morgan_orange reference joid errors (morgan_orange, 08:29:19)
    13. ACTION: May-meimei reference compass tempest errors (morgan_orange, 08:29:31)
    14. http://testresults.opnfv.org/reporting/vims/ (morgan_orange, 08:33:13)
    15. tempest and general status to be reported dynamically (decision to avoid using wiki for such things as it is long and difficult to maintain) (morgan_orange, 08:34:48)

  4. success criteria (morgan_orange, 08:35:27)
    1. during last test weekly meeting we initiated a discussion on the success criteria (morgan_orange, 08:35:45)
    2. there is also a mail thread => shall criteria be more strict (morgan_orange, 08:36:04)
    3. discussion on test criteria to be done during the Meet-up (morgan_orange, 08:37:56)
    4. ACTION: morgan_orange share first version of Meet-up agenda before the end of the week (morgan_orange, 08:38:49)
    5. https://wiki.opnfv.org/security (morgan_orange, 08:41:23)
    6. ACTION: morgan_orange contact OPNFV security group to see if test projects related to security are planned or not for C release (maybe a topic also for the Meet-up) (morgan_orange, 08:42:53)

  5. API/Dashbopard evolution (morgan_orange, 08:43:09)
    1. I got some question from Cisco people on the APi, they have good idea of evolution of the API (morgan_orange, 08:43:31)
    2. and they are working on ELK (Elastic Search LogStash Kibana), they are currently exporting mongo info to use them in Kibana and try to reproduce what we have in our basic dashboard (based on MIT lib dygraph) (morgan_orange, 08:44:30)
    3. evolution of the API and the dashboards to be discussed in the Meetup (morgan_orange, 08:45:05)
    4. ACTION: morgan_orange organize GTM next week for weekly meeting, keep a slot for new contributors (morgan_orange, 08:46:55)
    5. on the APi, we should add new fields (version/scenario) and a suite of unit tests is needed to ensure the stability of the APIs (migration or at least data change will be needed), option for the time search, for now we can use period=N to retrieve the last N days, but there is not API way to retrieve the last 5 scenarios X of installer Y (morgan_orange, 08:48:13)
    6. that is whty for the automation of the forecast => only the results of the last N days (throuhj period param) can be retrieved and then a post processing is needed => connected to teh discussion on success criteria (morgan_orange, 08:48:59)

  6. task allocation (morgan_orange, 08:49:10)
    1. we will wait the introduction of new contributor but we shall be able to allocate the main tasks as soon as we know them (morgan_orange, 08:49:44)
    2. roadmpat for C release is expected after the meet up (morgan_orange, 08:50:01)

  7. AoB (morgan_orange, 08:50:31)
    1. Jose Lausuch international Entertainement soon presents Functest versus Marvels (morgan_orange, 08:52:34)
    2. ACTION: morgan_orange initiate Tempest presentation on Berlin (morgan_orange, 08:56:07)
    3. Nokia public lab soon ready (morgan_orange, 08:57:01)


Meeting ended at 08:57:58 UTC (full logs).

Action items

  1. morgan_orange check new scenario candidates
  2. viktor_nokia set --serial options in repo to see influence on LF POD1
  3. viktor_nokia send a mail to apex/pharos to indicate tempex results on apex/Nokia and show the different with results got on LF POD1
  4. morgan_orange initiate a page on Tempest errors per scenario/installer
  5. viktor_nokia reference apex tempest errors
  6. jose_lausuch reference fuel tempest errors
  7. morgan_orange reference joid errors
  8. May-meimei reference compass tempest errors
  9. morgan_orange share first version of Meet-up agenda before the end of the week
  10. morgan_orange contact OPNFV security group to see if test projects related to security are planned or not for C release (maybe a topic also for the Meet-up)
  11. morgan_orange organize GTM next week for weekly meeting, keep a slot for new contributors
  12. morgan_orange initiate Tempest presentation on Berlin


Action items, by person

  1. jose_lausuch
    1. jose_lausuch reference fuel tempest errors
  2. morgan_orange
    1. morgan_orange check new scenario candidates
    2. morgan_orange initiate a page on Tempest errors per scenario/installer
    3. morgan_orange reference joid errors
    4. morgan_orange share first version of Meet-up agenda before the end of the week
    5. morgan_orange contact OPNFV security group to see if test projects related to security are planned or not for C release (maybe a topic also for the Meet-up)
    6. morgan_orange organize GTM next week for weekly meeting, keep a slot for new contributors
    7. morgan_orange initiate Tempest presentation on Berlin
  3. viktor_nokia
    1. viktor_nokia set --serial options in repo to see influence on LF POD1
    2. viktor_nokia send a mail to apex/pharos to indicate tempex results on apex/Nokia and show the different with results got on LF POD1
    3. viktor_nokia reference apex tempest errors


People present (lines said)

  1. morgan_orange (127)
  2. jose_lausuch (35)
  3. viktor_nokia (23)
  4. collabot` (3)


Generated by MeetBot 0.1.4.