#opnfv-testperf: Functest meetup in Espoo March 30th

Meeting started by morgan_orange at 06:02:15 UTC (full logs).

Meeting summary

    1. jose_lausuch (morgan_orange, 06:04:32)
    2. David_Orange (David_Orange, 06:06:14)
    3. morgan_orange (morgan_orange, 06:06:20)
    4. juha 1 (morgan_orange, 06:06:33)
    5. ollivier (morgan_orange, 06:06:44)
    6. Tapio (morgan_orange, 06:07:25)
    7. juhak (morgan_orange, 06:08:01)
    8. colum (morgan_orange, 06:08:12)
    9. frankbrockners (morgan_orange, 06:08:27)
    10. jlinkes (morgan_orange, 06:08:35)
    11. viktor_nokia (morgan_orange, 06:09:02)
    12. bertys (bertys, 06:09:16)
    13. agenda and details https://etherpad.opnfv.org/p/functest_release_C (morgan_orange, 06:10:24)

  1. introduction to Functest and Colorado release (morgan_orange, 06:19:28)
    1. http://opnfv.fr/opnfv_functest_release_C/#/ (David_Orange, 06:24:44)
    2. ACTION: morgan_orange send material for tests projects sync (David_Orange, 06:56:18)
    3. see if we can launch functest without admin net, inside a tenant (David_Orange, 07:06:20)
    4. testresults.opnfv.org (David_Orange, 07:17:40)
    5. during Brahmaputra, different results have been observed with different Labs (same scenarios), due to different HW or Network setup. A Pharos HW requirements validation would be a nice thing to have before running any functional/performance test project. (jose_lausuch, 07:17:52)
    6. http://testresults.opnfv.org/dashboard/ (David_Orange, 07:18:46)
    7. https://www.irccloud.com/pastebin/olCtClSn/ (yuanyou, 07:42:08)
    8. for Colorado => split tests in tier from 1 to 5 stars to run the tests (health / smoke / openstack ready / VNFs / features ) (morgan_orange, 08:06:53)
    9. evolution of the yaml file to test is test is runnable or not (morgan_orange, 08:07:21)
    10. question on the version of the sub components in the scenario (morgan_orange, 08:07:34)
    11. ACTION: frankbrockners is it possible to add OPNFV scenario name in rc file so other projects know what has been installed... (morgan_orange, 08:11:00)
    12. ACTION: morgan_orange create jira ticket towards genesis to include this information from all the installers (morgan_orange, 08:11:34)
    13. shall we re-run vPing after other tests? to be sure that there is no integral regression (morgan_orange, 08:20:44)
    14. proposal bertys => UI to propose runnable tests on a web page (morgan_orange, 08:22:44)
    15. ACTION: jose_lausuch refactor/split functest utils (morgan_orange, 08:23:56)

  2. test strategy for C release (morgan_orange, 10:08:20)
    1. draft document (link to be provided) to be discussed with the other test projects (morgan_orange, 10:08:37)
    2. +1 to get rid of Tempest custom list and consider smoke tests for T1 and more complete for T2 (morgan_orange, 10:29:07)
    3. check VM vPing and security group tests in Tempest (to replace existing ones if needed) (morgan_orange, 10:39:25)
    4. ACTION: David_Orange check sec group in tempest All suite (morgan_orange, 10:39:42)
    5. ACTION: viktor_nokia check vPIng scenario in tempest All suite (morgan_orange, 10:40:05)

  3. new test cases (morgan_orange, 10:42:14)
    1. : https://gist.github.com/davidblaisonneau-orange/bb74fb1a9d4a87552fc2cdf68608f69f (David_Orange, 10:42:57)
    2. security group (morgan_orange, 10:43:04)
    3. question on IPv6 support? => lab must be IPv6 compliant (morgan_orange, 10:49:46)
    4. ACTION: David_Orange add test on direct SDN controller API + add statefull rules tests with SDN API (David_Orange, 10:53:10)
    5. question on nmap testing? (morgan_orange, 10:53:37)
    6. question on the opportunity of test on power consumption? why not but need contributors (morgan_orange, 10:59:14)
    7. new VNFs, wait for 01.org feedback to see if we can have new VNFs to integrate (morgan_orange, 11:01:04)
    8. https://01.org/ (morgan_orange, 11:05:40)
    9. ACTION: infra secrutity checks could be added if not already integrated (morgan_orange, 11:07:23)
    10. ACTION: David_Orange study opportunity for this kind of checks (https,..) see with luke hinds (morgan_orange, 11:08:46)
    11. https://01.org/intel-data-plane-performance-demonstrators <-probably the framework used (David_Orange, 11:11:02)

  4. dashboard (morgan_orange, 11:23:07)
    1. presentation of existing dashboard + monitoring page (morgan_orange, 11:23:21)
    2. presentation of ELK (morgan_orange, 11:23:26)
    3. ACTION: jlinkes test is API can be connected to ELK DB to switch from Mongo to Elasticsearch DB (morgan_orange, 11:49:08)
    4. goal move to Kibana for Colorado (morgan_orange, 11:52:31)
    5. ACTION: morgan_orange talk with Yardstick (Ana) to discuss the possibility of sharing the same DB/analytics tools. Involve frankbrockners in the discussion. (jose_lausuch, 12:30:23)
    6. ACTION: morgan_orange ask Aric to add gerrit report messages on IRC testperf channel (jose_lausuch, 13:04:25)

  5. AoB (morgan_orange, 13:58:39)
    1. https://wiki.opnfv.org/display/SWREL/Releasedocs (morgan_orange, 13:58:41)
    2. ACTION: morgan_orange refactor the wiki (morgan_orange, 14:03:57)
    3. http://events.linuxfoundation.org/sites/events/files/slides/Functest%20in%20Depth_0.pdf (jose_lausuch, 14:04:06)


Meeting ended at 14:10:10 UTC (full logs).

Action items

  1. morgan_orange send material for tests projects sync
  2. frankbrockners is it possible to add OPNFV scenario name in rc file so other projects know what has been installed...
  3. morgan_orange create jira ticket towards genesis to include this information from all the installers
  4. jose_lausuch refactor/split functest utils
  5. David_Orange check sec group in tempest All suite
  6. viktor_nokia check vPIng scenario in tempest All suite
  7. David_Orange add test on direct SDN controller API + add statefull rules tests with SDN API
  8. infra secrutity checks could be added if not already integrated
  9. David_Orange study opportunity for this kind of checks (https,..) see with luke hinds
  10. jlinkes test is API can be connected to ELK DB to switch from Mongo to Elasticsearch DB
  11. morgan_orange talk with Yardstick (Ana) to discuss the possibility of sharing the same DB/analytics tools. Involve frankbrockners in the discussion.
  12. morgan_orange ask Aric to add gerrit report messages on IRC testperf channel
  13. morgan_orange refactor the wiki


Action items, by person

  1. David_Orange
    1. David_Orange check sec group in tempest All suite
    2. David_Orange add test on direct SDN controller API + add statefull rules tests with SDN API
    3. David_Orange study opportunity for this kind of checks (https,..) see with luke hinds
  2. frankbrockners
    1. frankbrockners is it possible to add OPNFV scenario name in rc file so other projects know what has been installed...
    2. morgan_orange talk with Yardstick (Ana) to discuss the possibility of sharing the same DB/analytics tools. Involve frankbrockners in the discussion.
  3. jlinkes
    1. jlinkes test is API can be connected to ELK DB to switch from Mongo to Elasticsearch DB
  4. jose_lausuch
    1. jose_lausuch refactor/split functest utils
  5. morgan_orange
    1. morgan_orange send material for tests projects sync
    2. morgan_orange create jira ticket towards genesis to include this information from all the installers
    3. morgan_orange talk with Yardstick (Ana) to discuss the possibility of sharing the same DB/analytics tools. Involve frankbrockners in the discussion.
    4. morgan_orange ask Aric to add gerrit report messages on IRC testperf channel
    5. morgan_orange refactor the wiki
  6. viktor_nokia
    1. viktor_nokia check vPIng scenario in tempest All suite


People present (lines said)

  1. morgan_orange (48)
  2. David_Orange (11)
  3. jose_lausuch (8)
  4. collabot` (6)
  5. frankbrockners (5)
  6. yuanyou (2)
  7. jlinkes (1)
  8. TapioT (1)
  9. bertys (1)
  10. juhak (0)
  11. viktor_nokia (0)


Generated by MeetBot 0.1.4.