#opnfv-testperf: OPNFV Testing working group weekly meeting September, 29th

Meeting started by morgan_orange at 14:00:06 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 14:00:16)
    1. Jose Lausuch (jose_lausuch, 14:00:26)
    2. Morgan Richomme (morgan_orange, 14:00:34)
    3. Mark Beierl (mbeierl, 14:00:34)
    4. kub (kubi001, 14:00:59)
    5. Jing (JingLu, 14:00:59)
    6. kubi (kubi001, 14:01:03)
    7. agenda for today https://wiki.opnfv.org/display/meetings/TestPerf (morgan_orange, 14:01:46)

  2. Action point follow-up (morgan_orange, 14:02:49)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-09-22-14.00.html (morgan_orange, 14:02:59)
    2. AP1: kubi plan soemthing on grafana (morgan_orange, 14:03:11)
    3. done (morgan_orange, 14:03:13)
    4. AP2: yujunz-zte send mail invitation for next APAC slots (morgan_orange, 14:03:30)
    5. done calendar created (morgan_orange, 14:03:35)
    6. AP3 morgan_orange initiate etherpad Colorado post-mortem for Test working group (morgan_orange, 14:03:43)
    7. done https://etherpad.opnfv.org/p/Colorado-Testing-postmortem (morgan_orange, 14:03:55)
    8. all brainstorm on relationships between projects to avoid overlaping (morgan_orange, 14:04:06)
    9. we will see (morgan_orange, 14:04:09)
    10. AP5 morgan_orange send mail on community to associate other working groups (morgan_orange, 14:04:22)
    11. done (morgan_orange, 14:04:24)

  3. Presentation IEEE SDN initiative to collect Open Source toolkits dealing with SDN/NFV (C. Rothenberg, G.Carella)  (morgan_orange, 14:04:42)
    1. Yujun Zhang / IRC only (yujunz, 14:05:02)
    2. presentation initiative, first presentation done during OPNFV Summit (morgan_orange, 14:06:27)
    3. initiative academic driven (morgan_orange, 14:06:46)
    4. currently using docuwiki, migration to confluence planned (morgan_orange, 14:07:47)
    5. idea of a catalog (morgan_orange, 14:08:03)
    6. target for IEEE web site beginning of Novemebr (morgan_orange, 14:17:26)
    7. live version is planned for the beginning of November (mbeierl, 14:17:26)
    8. meanwhile google doc used to reference the documents (morgan_orange, 14:17:37)
    9. Larry Lamers (ljlamers__, 14:19:07)

  4. Docker proposal for CI (mbeierl, 14:19:36)
    1. jose_lausuch is presenting overview of https://hub.docker.com/r/opnfv/ and the Jenkins jobs that push to it (mbeierl, 14:21:05)
    2. https://wiki.opnfv.org/display/INF/Docker+handling+in+CI (mbeierl, 14:21:43)
    3. google doc for previosu topic: https://docs.google.com/spreadsheets/d/1NHI4MZZWVDpxF_Rs7OOSTUa_aHL2ACUVA_Ov-YQs1DA/edit#gid=0 (morgan_orange, 14:22:09)
    4. previous topic proto site http://www.sdn-os-toolkits.org/ (until official IEEE web site planned beginning of November) (morgan_orange, 14:23:07)
    5. explanation of numbering scheme: first push on a new branch creates a 0.0, next one 0.1, etc (mbeierl, 14:23:46)
    6. manual cleaning needed (morgan_orange, 14:24:37)
    7. an example is shown in the Yardstick docker repo, where there are 74 Brahmaputra versions (mbeierl, 14:27:25)
    8. release of Colorado 1.0 (or other official releases) must be done manually. Contact jose_lausuch for help doing that for now (mbeierl, 14:27:52)
    9. at this time, logic is needed to determine where the dockerfile is located (mbeierl, 14:29:06)
    10. proposal to standardize this for all projects so that dockerfile is always found at $WORKSPACE/docker/dockerfile (mbeierl, 14:29:38)
    11. currently this only affects bottlenecks and yardstick (mbeierl, 14:29:58)
    12. ACTION: MatthewLi kubi1refactor docker dir so all the projects using docker will have the same docker path (morgan_orange, 14:30:46)
    13. changes required: bottlenecks/ci/docker -> bottlenecks/docker and for yardstick: yardstick/tests/ci/docker/yardstick-ci to yardstick/docker (mbeierl, 14:31:29)
    14. AGREED: docker path refactoring (morgan_orange, 14:31:31)
    15. harmonization on the docker jenkins job (morgan_orange, 14:31:53)
    16. ACTION: kubi001 review yardstick / docker job and align jobs with other test projects (morgan_orange, 14:33:03)
    17. jose_lausuch will propose a patch to harmonize the opnfv-docker.yaml for review (mbeierl, 14:33:16)
    18. https://wiki.opnfv.org/display/INF/Docker+handling+in+CI (jose_lausuch, 14:33:40)
    19. VOTE: Voted on "Do you approve Docker refactoring presented by jose_lausuch?" Results are, Yes: 4 (morgan_orange, 14:37:05)
    20. AGREED: docker refactoring, jose_lausuch will create a patch and put people in review (morgan_orange, 14:37:23)

  5. Update on Grafana (morgan_orange, 14:37:48)
    1. http://testresults.opnfv.org/grafana/ (jose_lausuch, 14:40:24)
    2. Grafana Dashboard access: opnfv/opnfv (jose_lausuch, 14:41:13)
    3. only registered administrator accounts can modify dashboards (mbeierl, 14:49:44)

  6. Colorado post-mortem: https://etherpad.opnfv.org/p/Colorado-Testing-postmortem (morgan_orange, 14:55:26)
    1. ACTION: kubi001 MatthewLi mtahhan mbeierl jose_lausuch dfarrell07 review post mortem for a discussion next week (morgan_orange, 14:56:29)

  7. AoB (morgan_orange, 14:56:42)


Meeting ended at 15:02:41 UTC (full logs).

Action items

  1. MatthewLi kubi1refactor docker dir so all the projects using docker will have the same docker path
  2. kubi001 review yardstick / docker job and align jobs with other test projects
  3. kubi001 MatthewLi mtahhan mbeierl jose_lausuch dfarrell07 review post mortem for a discussion next week


Action items, by person

  1. jose_lausuch
    1. kubi001 MatthewLi mtahhan mbeierl jose_lausuch dfarrell07 review post mortem for a discussion next week
  2. kubi001
    1. kubi001 review yardstick / docker job and align jobs with other test projects
    2. kubi001 MatthewLi mtahhan mbeierl jose_lausuch dfarrell07 review post mortem for a discussion next week
  3. mbeierl
    1. kubi001 MatthewLi mtahhan mbeierl jose_lausuch dfarrell07 review post mortem for a discussion next week
  4. mtahhan
    1. kubi001 MatthewLi mtahhan mbeierl jose_lausuch dfarrell07 review post mortem for a discussion next week


People present (lines said)

  1. morgan_orange (45)
  2. mbeierl (20)
  3. kubi001 (11)
  4. collabot (9)
  5. jose_lausuch (7)
  6. mtahhan (6)
  7. yujunz (4)
  8. yuyang (1)
  9. JingLu (1)
  10. ljlamers__ (1)


Generated by MeetBot 0.1.4.