#opnfv-testperf: testing working group weekly meeting March 30th

Meeting started by morgan_orange1 at 14:59:57 UTC (full logs).

Meeting summary

  1. call role (morgan_orange1, 15:00:03)
    1. Morgan Richomme (morgan_orange1, 15:00:09)

  2. action point follow up (morgan_orange1, 15:01:28)
    1. AP1: jose_lausuch => proposal on hands on testing / Design Summit / tutorial (morgan_orange1, 15:01:32)
    2. proposal ready to be sumbitted (morgan_orange1, 15:01:52)
    3. AP2: morgan_orange => proposal meeting the testing community / Design summit / panel (morgan_orange1, 15:02:00)
    4. done proposal submitted (morgan_orange1, 15:02:05)
    5. AP3: yujunz How do we consume the tests / Design or standard session (morgan_orange1, 15:02:15)
    6. AP4: trevor_intel Plugfest - stress test strategy / design or standard session (morgan_orange1, 15:02:35)
    7. done (morgan_orange1, 15:02:55)
    8. AP5: jose_lausuch => proposal upstream and Xcollaoration / design summit (morgan_orange1, 15:03:02)
    9. done to be submitted (morgan_orange1, 15:03:11)
    10. AP6: dmcbride Testing and milestones alignment / CI challenges / Features + Installer + CI + testing equation / panel / design summit (morgan_orange1, 15:03:21)
    11. AP7: morgan_orange challenge / micro service approach how to consumme API /Design summit (morgan_orange1, 15:03:46)
    12. test ok to be sumitted => with kubi001 (morgan_orange1, 15:03:58)
    13. AP8: nikolas jose_lausuch Testing and CI gating / Design Summit (morgan_orange1, 15:04:05)
    14. done (morgan_orange1, 15:04:10)
    15. AP9: dmcbride bring discussion to be done at the TSC (morgan_orange1, 15:04:19)
    16. Trevor Cooper (trevor_intel_, 15:04:20)

  3. ETSI plugfest test plan summary (morgan_orange1, 15:04:45)
    1. plugfest organized by ETSI (morgan_orange1, 15:06:05)
    2. https://portal.etsi.org/Portals/0/TBpages/CTI/Docs/1st_ETSI_NFV_Plugtests_Report_v1.0.0.pdf (morgan_orange1, 15:08:49)
    3. domains: NFVI&VIM, MANO, VNFs (morgan_orange1, 15:09:56)
    4. manual testing (morgan_orange1, 15:10:05)
    5. very detailed test sequence created for the different test cases (morgan_orange1, 15:13:16)
    6. opportunity to create test cases based on these definitiions? (morgan_orange1, 15:13:45)
    7. dfarrell07 (dfarrell07, 15:14:47)
    8. SUT configuration graphs provided (see P25) (morgan_orange1, 15:17:47)
    9. 9 VNF providers participated to the ETSI plugfest (morgan_orange1, 15:20:00)
    10. 35 organizations (including 2 OPNFV platforms (Intel and E///)) (morgan_orange1, 15:20:29)
    11. Commertial VNFs were used no Open Source Vnf used (morgan_orange1, 15:20:57)
    12. ACTION: jose_lausuch morgan_orange1 plan a session with pierre Lynch during the OPNFV plugfest to see if we could translate tests into OPNFV functional test suites (morgan_orange1, 15:23:22)

  4. Introduction to ABOT (morgan_orange1, 15:23:39)
    1. https://wiki.opnfv.org/pages/viewpage.action?pageId=6827111&preview=%2F6827111%2F8688320%2FABot_Test_Automation_Solution.pdf (morgan_orange1, 15:24:04)
    2. https://portal.etsi.org/Portals/0/TBpages/CTI/Docs/1st_ETSI_NFV_Plugtests_Report_v1.0.0.pdf (pjlynch, 15:25:33)
    3. https://portal.etsi.org/Portals/0/TBpages/CTI/Docs/1st_ETSI_NFV_Plugtests_Test_Plan_v1.0.0.pdf (pjlynch, 15:27:53)
    4. presentation of Abot + clearwater test case, and OAI EPC test case (morgan_orange1, 15:36:16)
    5. goal "orchestrate" VOLTE case (morgan_orange1, 15:37:12)
    6. question on how the traffic is generated => for IMS => use sipp (morgan_orange1, 15:38:57)
    7. question what is the goal conformance or performance? (morgan_orange1, 15:39:15)
    8. for the moment more conformance but plan for performance (morgan_orange1, 15:39:34)
    9. question on the licensing model (morgan_orange1, 15:41:46)

  5. MANO testing update (morgan_orange1, 15:47:37)
    1. in functest for D: cloudify_ims (clearwater), orchestra_ims (openbaton/openIMS), opera_ims (open-o/onap/clearwater), vyos_vrouter (cloudify) (morgan_orange1, 15:52:07)
    2. test run in labs still lacking integration testing time for Danube 1.0 (morgan_orange1, 15:52:22)
    3. https://build.opnfv.org/ci/job/functest-fuel-baremetal-weekly-master/16/consoleFull (morgan_orange1, 15:53:21)
    4. ACTION: prakash share xls file referencing MANO testing actions (morgan_orange1, 16:00:17)

  6. AoB (morgan_orange1, 16:00:23)
    1. Danube 1.0 tag to be created (morgan_orange1, 16:01:24)
    2. Possible to fix vsperf results in DB after Danube 1.0 and keep vswith menu in reporting page (morgan_orange1, 16:06:27)
    3. new reporting page online: (morgan_orange1, 16:06:32)
    4. http://testresults.opnfv.org/reporting/ (morgan_orange1, 16:06:45)
    5. catalogue page almost ready but need to chrosscheck that the DB testcases are correct => not possible for Danube 1.0 (morgan_orange1, 16:07:10)
    6. ACTION: PTLs last check on the testing working group documentation (morgan_orange1, 16:07:31)
    7. http://docs.opnfv.org/en/stable-danube/testing/ecosystem/overview.html#introduction (morgan_orange1, 16:07:49)


Meeting ended at 16:08:08 UTC (full logs).

Action items

  1. jose_lausuch morgan_orange1 plan a session with pierre Lynch during the OPNFV plugfest to see if we could translate tests into OPNFV functional test suites
  2. prakash share xls file referencing MANO testing actions
  3. PTLs last check on the testing working group documentation


Action items, by person

  1. jose_lausuch
    1. jose_lausuch morgan_orange1 plan a session with pierre Lynch during the OPNFV plugfest to see if we could translate tests into OPNFV functional test suites
  2. morgan_orange1
    1. jose_lausuch morgan_orange1 plan a session with pierre Lynch during the OPNFV plugfest to see if we could translate tests into OPNFV functional test suites
  3. UNASSIGNED
    1. prakash share xls file referencing MANO testing actions
    2. PTLs last check on the testing working group documentation


People present (lines said)

  1. morgan_orange1 (58)
  2. collabot (5)
  3. pjlynch (4)
  4. dmcbride (2)
  5. dfarrell07 (1)
  6. trevor_intel_ (1)
  7. gabriel_yuyang (0)
  8. kubi001 (0)
  9. bryan_att (0)
  10. jose_lausuch (0)


Generated by MeetBot 0.1.4.