#opnfv-testperf: testing working group weekly meeting June 22nd

Meeting started by morgan_orange at 15:00:33 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 15:00:42)
    1. Jose Lausuch (jose_lausuch, 15:00:46)
    2. Ace (Ace__, 15:00:56)
    3. Jack (JackChan, 15:00:58)
    4. Morgan Richomme (morgan_orange, 15:00:59)
    5. Yujun Zhang (yujunz, 15:01:05)
    6. gabriel_yuyang (gabriel_yuyang, 15:01:33)
    7. SernFeng (serena-zte, 15:01:55)
    8. Ross (rbbratta, 15:02:28)
    9. https://global.gotomeeting.com/join/819733085 (jose_lausuch, 15:03:08)
    10. SerenaFeng (serena-zte, 15:03:46)
    11. kubi (kubi001, 15:03:57)

  2. Action point follow up (01/06) (morgan_orange, 15:04:06)
    1. AP1: mbeierl to prepare list of all sessions for callout at the end of the panel (morgan_orange, 15:04:12)
    2. done (morgan_orange, 15:04:17)
    3. AP2 all review page for test strategy / need of stable Pods (morgan_orange, 15:04:22)
    4. see next topic for vote (morgan_orange, 15:04:28)
    5. AP3 mbeierl update description, delete old case (if not possible through the API, send a mail we will do it directly on the DB) (morgan_orange, 15:04:39)
    6. done during the plugfest (morgan_orange, 15:04:46)
    7. AP4 trevor_intel same clean vsperf test case, give humane readable description (morgan_orange, 15:04:52)
    8. pending (morgan_orange, 15:05:01)
    9. http://testresults.opnfv.org/test/api/v1/projects/vsperf/cases (morgan_orange, 15:05:08)
    10. AP5 trevor_intel send a mail to see if we cancel or not the meeting next week (standard time) (morgan_orange, 15:05:14)
    11. done (morgan_orange, 15:05:19)

  3. Validation discussion strategy long duration/reliency testing before reporting to TSC/Infra (morgan_orange, 15:06:39)
    1. https://global.gotomeeting.com/join/819733085 (yujunz, 15:06:47)
    2. Trevor Cooper (trevor_intel, 15:07:19)
    3. Agreed to ask for a TSC meeting slot to make request for long duration tests (trevor_intel, 15:09:20)
    4. https://wiki.opnfv.org/display/bottlenecks/Sress+Testing+over+OPNFV+Platform (morgan_orange, 15:09:20)
    5. https://wiki.opnfv.org/display/testing/Euphrates+Testing+needs (morgan_orange, 15:09:43)
    6. ACTION: morgan_orange ask for a 10 minutes slot to discuss this during TSC meeting (morgan_orange, 15:11:19)
    7. provide feedback on stress test strategy (morgan_orange, 15:13:23)
    8. goal: inform TSC + infra (morgan_orange, 15:13:36)
    9. probably impact on teh way we are releasing (2 versions in //) (morgan_orange, 15:13:49)

  4. Documentation for Euphrates (morgan_orange, 15:14:13)
    1. https://gerrit.opnfv.org/gerrit/#/c/35179/ (morgan_orange, 15:14:44)
    2. #info Please review patch for developer guide submitted by Morgan (trevor_intel, 15:16:30)
    3. This is a plan for the developer guide (trevor_intel, 15:17:05)
    4. each project needs to take care of no duplicating info in this document (morgan_orange, 15:17:59)
    5. http://docs.opnfv.org/en/stable-danube/ (morgan_orange, 15:18:33)

  5. Bitergia/Test API status? (morgan_orange, 15:22:00)
    1. for the test APi lots of requirements for access control (morgan_orange, 15:24:14)
    2. related to Dovetail questions (morgan_orange, 15:24:34)
    3. paginations has been added to test API (morgan_orange, 15:24:40)
    4. need for authentication is not clear. In OpenStack results are anonymous..but there are no control. You can send whatever you want (morgan_orange, 15:30:04)
    5. need for Dovetail (src trevor_intel): 1) know who is pushing the data (credentials) 2) private database (no public access) (morgan_orange, 15:31:59)
    6. suggestion to create a wiki page to continue on this topic to be sure that requirements are clear for everybody (morgan_orange, 15:34:07)
    7. ACTION: trevor_intel initiate wiki page on authenticaiton needs for Dovetail (morgan_orange, 15:34:24)
    8. https://wiki.opnfv.org/display/bamboo/Bamboo+Home (donaldh, 15:36:06)

  6. Bamboo integration (morgan_orange, 15:36:35)
    1. https://wiki.opnfv.org/display/bamboo/Bamboo+Home (morgan_orange, 15:36:48)
    2. goal of Bamboo for Euphrates: get an instance of pnda on Linux foundation (morgan_orange, 15:38:38)
    3. Testing group is working with bitergia to create dashboards for some test cases, could make sense to see if bamboo could also host this processing (morgan_orange, 15:43:12)
    4. https://pndablog.wordpress.com/2017/06/21/introducing-red-pnda-a-pnda-platform-for-development-demonstration-and-education/ (yujunz, 15:47:03)
    5. discussion on dimensioning for Bamboo (morgan_orange_, 15:48:54)
    6. donaldh reco start with a non HA config => contact Jack Morgan & Fatih (morgan_orange_, 15:51:18)
    7. for info backup of the Test DB available on http://artifacts!,opnfv.org/testapibackup.html (morgan_orange_, 15:53:26)
    8. ~60 Mo other figures (influDB from yardstick or power consumption to be shared with Bamaboo) (morgan_orange_, 15:53:54)
    9. Testing working group time meeting updated in the calendar (morgan_orange_, 15:57:19)


Meeting ended at 16:02:11 UTC (full logs).

Action items

  1. morgan_orange ask for a 10 minutes slot to discuss this during TSC meeting
  2. trevor_intel initiate wiki page on authenticaiton needs for Dovetail


Action items, by person

  1. morgan_orange
    1. morgan_orange ask for a 10 minutes slot to discuss this during TSC meeting
  2. trevor_intel
    1. trevor_intel initiate wiki page on authenticaiton needs for Dovetail


People present (lines said)

  1. morgan_orange (43)
  2. morgan_orange_ (8)
  3. yujunz (6)
  4. trevor_intel (4)
  5. collabot (4)
  6. serena-zte (3)
  7. donaldh (2)
  8. jose_lausuch (2)
  9. akramsawaf (1)
  10. Ace__ (1)
  11. rbbratta (1)
  12. kubi001 (1)
  13. JackChan (1)
  14. gabriel_yuyang (1)


Generated by MeetBot 0.1.4.