#opnfv-testperf: Test Working Group Meeting

Meeting started by gabriel_yuyang at 15:01:54 UTC (full logs).

Meeting summary

  1. Roll Call (gabriel_yuyang, 15:02:03)
    1. Jose Lausuch (jose_lausuch, 15:02:14)
    2. Jack (JackChan, 15:02:39)
    3. Linda Wang (LindaWang, 15:04:20)

  2. action item follow-up (gabriel_yuyang, 15:05:13)
    1. gabriel continue to summarize the bitergia activities and see next steps (gabriel_yuyang, 15:06:09)
    2. ACTION: gabriel summarize the bitergia activities and invite them in the next week meeting (gabriel_yuyang, 15:06:38)
    3. Kubi and HA team has contacted the HA team, join the weekly meeting (gabriel_yuyang, 15:07:58)
    4. action on Kubi is closed (gabriel_yuyang, 15:08:41)
    5. gabriel reach out to David about XCI-baremetal and CI chain requirements (gabriel_yuyang, 15:09:47)
    6. ACTION: gabriel reach out to David about XCI-baremetal and CI chain requirements (gabriel_yuyang, 15:09:56)
    7. Jack help look at the reporting page for VSPERF, need to fix the version, scenarios, jack will contact David to see what he need also. then to fix (gabriel_yuyang, 15:12:13)
    8. Trevor suggest to reference to Storperf (gabriel_yuyang, 15:12:35)
    9. ACTION: Prakash will help to check storperf's reporting (gabriel_yuyang, 15:14:48)
    10. Sridhar share the difference/solution and suggest to ask Morgan's opinions (gabriel_yuyang, 15:16:54)
    11. Jack send email to David to figure out a way to add time stamp (gabriel_yuyang, 15:17:44)
    12. Jack will find out David's needs (gabriel_yuyang, 15:18:20)
    13. ACTION: Jack send email to David to figure out a way to add time stamp (gabriel_yuyang, 15:19:09)

  3. Update on monitoring module of long duration test (gabriel_yuyang, 15:20:41)
    1. Intern project for monitoring long duration test from Bottlenecks by Rutuja (gabriel_yuyang, 15:21:28)
    2. 3 tools are used to accomplish this task: Prometheus, Grafana, Collectd for now (gabriel_yuyang, 15:22:07)
    3. Rutuja shows the Prometheus querying page for metrics (gabriel_yuyang, 15:26:56)
    4. Grafana is used to do dashboarding with panels showing results from metrics (gabriel_yuyang, 15:27:40)
    5. Collectd is used for monitoring and gather metrics (gabriel_yuyang, 15:31:35)
    6. Prakash want to know if the collectd container could be used for storperf/yardstick (gabriel_yuyang, 15:41:27)
    7. Sridhar want to know if this could be installed in VM (gabriel_yuyang, 15:41:52)
    8. Gabriel answers that could provide the collect client configuration file to VM, once the VM is installed with Cllectd. Grafana should be able to show the results from VM (gabriel_yuyang, 15:42:50)
    9. Rutuja will upload the slides on wiki after the meeting (gabriel_yuyang, 15:45:21)
    10. Gabriel suggest impoved by extracting ip from pod.yaml (gabriel_yuyang, 15:48:09)

  4. Bottlenecks load manager discussion (gabriel_yuyang, 15:49:04)
    1. Bottlenecks want to provide an service registration module for projects register API/test case (gabriel_yuyang, 15:54:33)
    2. Bottlenecks could scheduling test cases while adding monitoring module (gabriel_yuyang, 15:55:02)
    3. Gabriel ask if functest could support the API resgitration (gabriel_yuyang, 15:55:29)
    4. Functest has made it (Long duration test regarding functional test) a plan for Fraser: https://wiki.opnfv.org/display/functest/6.+Fraser (LindaWang, 15:55:34)
    5. Gabriel will make details introduction and reference codes in plugfest (gabriel_yuyang, 15:56:41)
    6. https://gerrit.opnfv.org/gerrit/#/c/46111/ (jose_lausuch, 15:59:17)
    7. docker build will be move from docker hub to releng (gabriel_yuyang, 16:00:03)


Meeting ended at 16:01:32 UTC (full logs).

Action items

  1. gabriel summarize the bitergia activities and invite them in the next week meeting
  2. gabriel reach out to David about XCI-baremetal and CI chain requirements
  3. Prakash will help to check storperf's reporting
  4. Jack send email to David to figure out a way to add time stamp


People present (lines said)

  1. gabriel_yuyang (36)
  2. collabot (5)
  3. jose_lausuch (3)
  4. LindaWang (2)
  5. JackChan (1)
  6. kubi0011 (0)


Generated by MeetBot 0.1.4.