#opnfv-testperf: Testperf Weekly Call 20180816

Meeting started by gabriel_yuyang at 15:03:06 UTC (full logs).

Meeting summary

  1. Roll Call (gabriel_yuyang, 15:03:16)
    1. Gabriel Yu (gabriel_yuyang, 15:03:22)
    2. Mark Beierl (mbeierl, 15:03:23)
    3. Emma Foley (efoley, 15:03:24)
    4. Rex (mj_rex, 15:03:33)

  2. Test results mgnt for testing projects (gabriel_yuyang, 15:03:49)
    1. VSPERF has issues getting test results displayed in TestAPI and would like to discuss about the DB for test results (gabriel_yuyang, 15:06:51)
    2. VSPERF also want put time series data into DB for later analysis (gabriel_yuyang, 15:07:17)
    3. Issues with TestAPI should be raised in RELENG project (mbeierl, 15:08:17)
    4. Now testing projects have their own support data bases, i.e., basically 4 kinds of dbs (gabriel_yuyang, 15:08:31)
    5. Mark suggest to discuss it in TSC and Releng to make the situation better (gabriel_yuyang, 15:11:57)
    6. http://testresults.opnfv.org/fraser/functest/status-apex.html For Functest (mbeierl, 15:12:36)
    7. http://testresults.opnfv.org/test/#/results (gabriel_yuyang, 15:13:16)
    8. http://testresults.opnfv.org/fraser/vsperf/reporting.html (mbeierl, 15:13:24)
    9. http://testresults.opnfv.org/master/vsperf/reporting.html reports 404 but fraser does work. (mbeierl, 15:15:04)
    10. http://testresults.opnfv.org/test/#/results (gabriel_yuyang, 15:17:53)
    11. http://testresults.opnfv.org/test/api/v1/results?project=vsperf&period=2 shows that results are populated (mbeierl, 15:19:24)
    12. The dashboard is giving 404 and that is the issue (mbeierl, 15:19:38)
    13. the git repo for the dashboard is here: https://github.com/opnfv/releng-testresults (mbeierl, 15:22:10)
    14. The results are in the testDB, but not displayed in the TestAPI (gabriel_yuyang, 15:22:13)
    15. ACTION: Gabriel reach out to Serena for VSperf displaying issue (gabriel_yuyang, 15:23:56)
    16. here is a sample of the 'series data' that storperf puts into the results db: http://testresults.opnfv.org/test/api/v1/results?project=storperf&period=2 (mbeierl, 15:29:09)
    17. Bottlenecks, VSperf, NFVbench would like to use Prometheus to store time series results (gabriel_yuyang, 15:29:41)
    18. https://github.com/att-comdev/prometheus-openstack-exporter/blob/3231f14419f0c47547ce2551b7d884cd222104e6/exporter/main.py#L46 (gabriel_yuyang, 15:39:53)
    19. an example of prometheus exporter (gabriel_yuyang, 15:40:06)

  3. K8S capacity testing (gabriel_yuyang, 15:45:40)
    1. https://gerrit.opnfv.org/gerrit/#/c/60969/ (gabriel_yuyang, 15:45:59)
    2. Al Morton (acmacm, 15:50:17)


Meeting ended at 16:00:58 UTC (full logs).

Action items

  1. Gabriel reach out to Serena for VSperf displaying issue


People present (lines said)

  1. gabriel_yuyang (19)
  2. mbeierl (10)
  3. varesa (8)
  4. collabot (3)
  5. efoley (1)
  6. acmacm (1)
  7. mj_rex (1)


Generated by MeetBot 0.1.4.