15:03:48 <acm> #startmeeting VSPERF
15:03:48 <collabot> Meeting started Wed Jul 26 15:03:48 2017 UTC.  The chair is acm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:48 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:48 <collabot> The meeting name has been set to 'vsperf'
15:04:06 <acm> #info Al Morton
15:05:16 <acm> #agenda
15:08:23 <acm> #info delay histogram, upgrades CI hosts, feedback from IETF BMWG on the test results
15:09:14 <acm> #topic upgrades to CI
15:10:02 <acm> #info Centos 7.3 image upload/install on sandbox, no difference to Tput.
15:10:53 <acm> #info Chris - there is an unknown source of packet loss, will investigate locally
15:11:45 <acm> #info Chirs never sees loss anymore - current status is in JIRA 518
15:12:16 <acm> #topic delay histogram
15:15:14 <acm> #info Al's feedback on the list
15:21:29 <acm> #info no generic historgarm config for the T-gens
15:23:35 <acm> #sridhar - two configs involved: generator itself as it summarizes the latency, and results display
15:23:50 <acm> #info acm thinks they should be the same.
15:26:22 <acm> #action sridhar generic config for generator histogram collection
15:27:57 <acm> #topic stress-ng test case proposal
15:29:52 <acm> #info new noisy neighbor (_nn) test case with 2544 tput
15:30:25 <acm> #info need many VMs, sridhar looking for a place to put VNF images
15:31:50 <acm> #info  stress-ng is created to cause a particular sort of load/noise, and generates when it is spawned
15:32:29 <acm> #info mars - the right place may be OPNFV artifacts directory
15:33:23 <acm> #info mars - naming of test cases is not very good, maybe _nn should be a prefix, not a suffix
15:34:21 <acm> #action sridhar will send out test case proposal
15:35:13 <acm> #info sridhar shows the stress-ng configuration parameters and example
15:37:36 <acm> #info author of stress-ng Collin King, at Canonical, very helpful, already added new feature
15:38:23 <acm> #topic VSPERF at IETF BMWG
15:40:51 <acm> #info question from BMWG - did you try IMIX??
15:41:42 <acm> #info answer - VSPERF is limited fixed packet sizes, and IMIX is a feature that benchmarkers would like to see
15:42:38 <acm> #info need a generic way to specify IMIX, that we can translate to all T-gens
15:43:47 <acm> #info yardstick may have the generic spec, also IMIX Genome spec
15:44:16 <acm> #action sridhar will look at YS IMIX and IMIX Genome RFC
15:44:57 <acm> #info BMWG agree with more info on latency
15:46:38 <acm> #info Interest to refine the back 2 back frame testing - described the correction factor we used in Design Summit calculations
15:48:22 <acm> #info if we want to reduce frame sizes used in b2b frame testing, need to feedback results from Tput tests
15:49:37 <acm> #info BMWG is re-chratering, taking-up new proposals NOW!
15:51:49 <acm> #topic next week
15:52:14 <acm> #info acm will not be able to join, away all week
15:52:35 <acm> #info  no other business
15:52:42 <acm> #endmeeting