16:04:44 <SRao> #startmeeting Vswitchperef
16:04:44 <collabot`> Meeting started Wed Dec  5 16:04:44 2018 UTC.  The chair is SRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:44 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:04:44 <collabot`> The meeting name has been set to 'vswitchperef'
16:04:55 <SRao> #topic Development Update
16:05:16 <SRao> #info Added a patch to affinitize stressor-vm cpus
16:05:30 <SRao> #info added a patch to fix variable name.
16:06:47 <acm> #info Al Mort9on
16:07:04 <acm> #info Al Morton
16:07:12 <SRao> #info include 'before' and 'after' images for affinitize patch.
16:08:26 <acm> #action all need reviews on
16:08:31 <acm> pathches
16:08:45 <acm> Im in another meeting Sridhar, sorry!
16:08:55 <SRao> #topic IEEE NFVSDN
16:09:31 <SRao> #info 3-hr tutorial on dataplane performance benchmarking, tried to convince the attendees to participate in these projects.
16:10:07 <SRao> #info Majority of the participants from academia. VSPERF can be used as part of the research activity.
16:10:46 <SRao> #info NFVBench Demo - Trex reported -ve dropped packets.
16:10:50 <acm> # info  I've seen that too, Sridhar!
16:11:16 <acm> It's rare, but it happens
16:12:51 <SRao> #info If someone can create a vagrantfile it would help users to try vsperf on laptop
16:13:16 <acm> #info  I think that the method of reading TX and Rx counters separately may be part of the issue (with -Trex)
16:14:05 <acm> #info - no vagrant experience for me, good question about is it still cool...
16:15:30 <SRao> #info Collectd reporting the l3-cache values - has issues of staledata, and timestamps.
16:15:56 <acm> #info I'd like to use collectd to read interface tx/rx packet counters periodically, can it do that?
16:16:44 <SRao> #topic Containerizing VSPERF.
16:16:49 <acm> #topic Conatinerizing VSPERF
16:17:34 <SRao> #info should we put the contents in existing repo or should we create a new repo - vswitchperf-containers?
16:17:45 <acm> #info I'd like to9 get some advice from Eddie Arrage or Alec H
16:18:13 <acm> #info It would be a quick e-mail
16:18:19 <acm> ok
16:18:50 <SRao> #info If existing one - create a folder containers, and within that we need 2 folders one for vsperf and results.
16:19:02 <acm> #action acm write e-mail to Eddie Arrage or Alec H to get their suggestion on Container->VSPERF
16:19:37 <acm> i heard the word before...
16:20:24 <acm> #info  first define the messages to be exhanged
16:20:56 <acm> #info we have four candidate rpcs to support - minimal - start tests and check status
16:22:28 <acm> #info Install - upload a config file - start tests and check ststus
16:22:52 <acm> #info  I think we need results too
16:23:25 <acm> #info reuest feedback on this
16:26:40 <acm> #INFO that's good!
16:26:46 <bfubel> ok
16:27:03 <SRao> #action Sridhar to send .proto to AL.
16:27:26 <SRao> #action Sridhar to create results container.
16:27:28 <acm> #info - ok, I was imagining a high-level question first, and see where that goes
16:29:02 <acm> #info ok, thanks!
16:29:17 <SRao> #info https://wiki.opnfv.org/display/DEV/Intern+Project%3A+VSPERF+Automated+Deployment+and+Results+Management
16:29:37 <acm> #info yes, I'll add that to the discussion.
16:29:51 <acm> #info Eddie is the right guy!
16:30:13 <acm> #info not yet
16:30:45 <acm> #info  is possible to results push to Acumos ?
16:31:17 <acm> #info  I would assume our VES guy QAlok Gupta knows
16:32:18 <acm> #info  so question: can any project push results data to Acumos today???
16:33:46 <acm> #info  Yes, AT&T , but I don't have any contact with them, directly, so far
16:36:32 <SRao> #info AL: Started work on Long-Duration testing.
16:38:17 <SRao> #action Need better support of 'integrating' iperf (non-dpdk) tools.
16:41:15 <SRao> #info LDT: Early Stopping, based on monitoring some metrics
16:42:32 <SRao> #topic OPNFV Strategy - VSPERF.
16:54:06 <bfubel> lspci -s 84:00.1 -v |grep NUMA
16:55:48 <bfubel> ethtool -i p2p2
16:59:30 <SRao> #endmeeting