15:02:41 <SRao> #startmeeting vswitchperf
15:02:41 <collabot`> Meeting started Wed Mar 11 15:02:41 2020 UTC.  The chair is SRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:41 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:41 <collabot`> The meeting name has been set to 'vswitchperf'
15:03:17 <SRao> #topic New Student Volunteers
15:04:54 <SRao> #info Shubham: P4 (TestVNF)
15:05:04 <SRao> #info Adarsh: P1 (Kibana For VSPERF)
15:05:42 <SRao> #info Parth: GUI for VSperf.
15:05:50 <SRao> #info Parth: CN Benchmarking.
15:08:00 <SRao> #action Sridhar to create wiki to capture Shubham and Adarsh works.
15:08:30 <SRao> #action Sridhar to create Jira for these two works.
15:19:41 <SRao> #topic VSPERF and CNTT.
15:20:10 <SRao> #info Al: VSPERF is applicable even for post-deployment.
15:21:04 <SRao> #info With commercial (virtual) TGens, VSPERF may not add value as it has to rely on T-Rex only
15:22:44 <SRao> #info Al: VSPERF supports more than one TGen, and Better Metrics Collection, TST-009 Test Support,
15:23:44 <SRao> #info Al: VSPERF brings with it barometer Fully
15:24:15 <SRao> #info Al: Get Integrated with X-Testing Quickly.
15:24:49 <SRao> #info Hardware Validation (redfish, OPEN) --> Software Pre-Validation (WIP) --> Baremetal Provisioning [Airship] --> NwLinks Validation ( Open for project) --> [Performance Benchmarking (VSperf)] --> OS Deployment [Airship] --> Sw Post-Validation (Open for project) --> Functional Testing (X-Testing) --> Performance Testing (VSPERF, NFVBench, XTesting, Prox, etc..)
15:26:51 <SRao> #topic TestCases for CN-Benchmarking
15:28:32 <SRao> #info The Node-1 and Node-2 will be ready to for Parth and Emanuele To Use it.
15:29:35 <SRao> #action Sridhar to summarize the test from the "previous works" into a wiki.
15:30:49 <SRao> #info Federica: Start with Replicating the previous works -- Same Traffic Patterns.
15:32:24 <SRao> #info 2544 Tests with With Different Search Algorithms--- We can start legacy Binary Search.
15:32:35 <SRao> #info 2544 With different Search Algorithms.
15:35:01 <SRao> #info 2544 with Loss-Verification
15:36:02 <SRao> #info Metrics (TST-OO9?) - Throughput, Latency (%le), Delay-Variation (HDR).
15:36:21 <SRao> #info Traffic Type: UDP
15:36:48 <SRao> #info TCP: Testing match-action (as OVS and VPP are used).
15:37:39 <SRao> #info AL: Analyse the UDP/TCP performance in comparison with previous-works.
15:38:13 <SRao> #info CNCF --- Refer to the testcases (Traffic type) ?
15:41:50 <SRao> #info CSIT - NetworkMesh, MemIf, ...
15:43:12 <SRao> #info NetworkServiceMesh not NetworkMesh
15:44:27 <SRao> #info https://github.com/cncf/cnf-testbed/tree/master/examples/use_case/3c2n-csp
15:47:00 <SRao> #info Ancuta: Able to deploy the VM (on Pod-12, Node-5).
15:48:53 <SRao> #info Ancuta: Once I get the CLA approved, Will submit the patch.
15:58:58 <SRao> #action Sridhar to create wiki for GUIl
16:01:49 <SRao> #endmeeting