23:19:41 <anac> #startmeeting Breakout session testing projects
23:19:41 <collabot> Meeting started Mon Nov  9 23:19:41 2015 UTC.  The chair is anac. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:19:41 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
23:19:41 <collabot> The meeting name has been set to 'breakout_session_testing_projects'
23:20:30 <anac> #info Agenda on Etherpad https://etherpad.opnfv.org/p/OPNFV_Design_Summit_2015
23:24:21 <anac> #info important to diferentiate between CI resources for testing and resources for platform ci
23:31:29 <anac> #info suggestion to dedicate 1 POD per installer for release platform verification
23:33:50 <anac> ##info #info suggestion to run 2 biulds per day
23:34:06 <anac> #undo
23:34:06 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2d9d410>
23:34:22 <anac> #info suggestion to run 2 builds per day
23:36:34 <anac> #info only stable version of installer should be delopyed for testing the platform
23:38:58 <anac> #topic common objects for all test projects
23:40:05 <anac> #info test result API - not mandatory to use it, to use it - the project needs to be added to the database
23:40:35 <anac> #info Functest and Yardstick use it, Vsperf on the way
23:41:35 <anac> #info test case definition - high level decription to produce test documents, there is a field for url
23:42:25 <anac> #agreed test cases advertized in release B should be in the database
23:48:13 <anac> #info suggestion that the test cases should register their test cases in yardstick
23:58:03 <anac> #info suggestion that a test case shall be documented, clearly stated what installer it works in (ideally all installers)
00:01:05 <anac> #info criteria for B-release: matrix (installer/test cases), test case documented, run functest and yardstick, 4 iterations in CI are run
00:03:33 <anac> #info will there be iso for the release? installer needs to provide scripts (mimimum), iso production is up to the installer project
00:10:11 <anac> #info SDN controller tests are included in Functest
00:13:47 <anac> #info a comment was made that stability testing is missing in the testing scope
00:15:18 <anac> #info proposal to plan for stability test in release C
00:18:58 <anac> #info for C-release: elaborate on loops of tests
00:41:02 <anac> #info suggestion to run vsperf and qtip on a system installed with base-OS
00:41:34 <anac> #info who is responsible for troubleshooting?
00:44:00 <anac> #endmeeting